summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-02 03:44:13 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-02 03:44:13 +0000
commit8ecc5b34f47e3b59b37cf133d791c27b569a35cf (patch)
treecee300be71c36e55532809d743b07cfaebbe4bf6
parentVersion bump. (diff)
downloadgentoo-2-8ecc5b34f47e3b59b37cf133d791c27b569a35cf.tar.gz
gentoo-2-8ecc5b34f47e3b59b37cf133d791c27b569a35cf.tar.bz2
gentoo-2-8ecc5b34f47e3b59b37cf133d791c27b569a35cf.zip
import X11 fixes #91071
(Portage version: 2.0.51.20-r5)
-rw-r--r--sys-apps/groff/groff-1.18.1-r4.ebuild13
-rw-r--r--sys-apps/groff/groff-1.19.1-r2.ebuild17
2 files changed, 13 insertions, 17 deletions
diff --git a/sys-apps/groff/groff-1.18.1-r4.ebuild b/sys-apps/groff/groff-1.18.1-r4.ebuild
index 17760271b8e4..a4a88c794d8d 100644
--- a/sys-apps/groff/groff-1.18.1-r4.ebuild
+++ b/sys-apps/groff/groff-1.18.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.18.1-r4.ebuild,v 1.9 2005/01/02 23:19:04 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.18.1-r4.ebuild,v 1.10 2005/05/02 03:44:13 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -12,11 +12,10 @@ SRC_URI="ftp://groff.ffii.org/pub/groff/old/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha hppa amd64 ia64 ppc64"
+KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86"
IUSE="X cjk"
-DEPEND="virtual/libc
- >=sys-apps/texinfo-4.0"
+DEPEND=">=sys-apps/texinfo-4.0"
PDEPEND=">=sys-apps/man-1.5k-r1"
src_unpack() {
@@ -83,8 +82,7 @@ src_compile() {
# Only build X stuff if we have X installed, but do
# not depend on it, else we get circular deps.
- if use X && [ -x /usr/X11R6/bin/xmkmf ]
- then
+ if use X && [[ -n $(type -p xmkmf) ]] ; then
cd ${S}/src/xditview
xmkmf || die
make depend all || die
@@ -99,8 +97,7 @@ src_install() {
docdir=${D}/usr/share/doc/${PF} \
install || die
- if use X && [ -x /usr/X11R6/bin/xmkmf ]
- then
+ if use X && [[ -n $(type -p xmkmf) ]] ; then
cd ${S}/src/xditview
make DESTDIR=${D} \
BINDIR=/usr/bin \
diff --git a/sys-apps/groff/groff-1.19.1-r2.ebuild b/sys-apps/groff/groff-1.19.1-r2.ebuild
index 19a45357a596..6aa1352ab3a4 100644
--- a/sys-apps/groff/groff-1.19.1-r2.ebuild
+++ b/sys-apps/groff/groff-1.19.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.1-r2.ebuild,v 1.13 2005/04/27 03:47:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.1-r2.ebuild,v 1.14 2005/05/02 03:44:13 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -23,26 +23,25 @@ src_unpack() {
# Fix the info pages to have .info extensions,
# else they do not get gzipped.
- epatch ${FILESDIR}/groff-1.18-infoext.patch
+ epatch "${FILESDIR}"/groff-1.18-infoext.patch
# Do not generate example files that require us to
# depend on netpbm.
- epatch ${FILESDIR}/groff-1.18-no-netpbm-depend.patch
+ epatch "${FILESDIR}"/groff-1.18-no-netpbm-depend.patch
# Make dashes the same as minus on the keyboard so that you
# can search for it. Fixes #17580 and #16108
# Thanks to James Cloos <cloos@jhcloos.com>
- epatch ${FILESDIR}/${PN}-man-UTF-8.diff
+ epatch "${FILESDIR}"/${PN}-man-UTF-8.diff
# Fix stack limit (inifite loop) #64117
- epatch ${FILESDIR}/${P}-stack.patch
+ epatch "${FILESDIR}"/${P}-stack.patch
# Fix tempfile usage #68404
- epatch ${FILESDIR}/${P}-tmpfile.patch
+ epatch "${FILESDIR}"/${P}-tmpfile.patch
# Fix make dependencies so we can build in parallel
- epatch ${FILESDIR}/${P}-parallel-make.patch
-
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
# Make sure we can cross-compile this puppy
if tc-is-cross-compiler ; then
@@ -57,7 +56,7 @@ src_unpack() {
fi
# Only build X stuff if we have X installed, but do
# not depend on it, else we get circular deps :(
- if ! use X || [ ! -x /usr/X11R6/bin/xmkmf ] ; then
+ if ! use X && [[ -n $(type -p xmkmf) ]] ; then
touch .dont-build-X
fi
}