summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-11-19 19:16:08 +0000
committerMike Frysinger <vapier@gentoo.org>2014-11-19 19:16:08 +0000
commit90d18914f316a50718d9aea9a2abca86600d7ba3 (patch)
treea0bd99330f19f1a944ecfe5cd64b697e5c0c4d5e
parentRemoval of old version (diff)
downloadgentoo-2-90d18914f316a50718d9aea9a2abca86600d7ba3.tar.gz
gentoo-2-90d18914f316a50718d9aea9a2abca86600d7ba3.tar.bz2
gentoo-2-90d18914f316a50718d9aea9a2abca86600d7ba3.zip
Add various fixes from upstream.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
-rw-r--r--media-sound/alsa-utils/ChangeLog11
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.28-r1.ebuild79
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.28-aplay-return.patch45
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.28-mixer-proto.patch24
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.28-monitor-proto.patch24
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.28-va-end.patch39
6 files changed, 221 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 4323ee611be8..e3f4590afbd0 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.377 2014/11/08 18:52:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.378 2014/11/19 19:16:08 vapier Exp $
+
+*alsa-utils-1.0.28-r1 (19 Nov 2014)
+
+ 19 Nov 2014; Mike Frysinger <vapier@gentoo.org> +alsa-utils-1.0.28-r1.ebuild,
+ +files/alsa-utils-1.0.28-aplay-return.patch,
+ +files/alsa-utils-1.0.28-mixer-proto.patch,
+ +files/alsa-utils-1.0.28-monitor-proto.patch,
+ +files/alsa-utils-1.0.28-va-end.patch:
+ Add various fixes from upstream.
08 Nov 2014; Samuli Suominen <ssuominen@gentoo.org> alsa-utils-1.0.28.ebuild:
ppc/ppc64 stable wrt #522038
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.28-r1.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.28-r1.ebuild
new file mode 100644
index 000000000000..eccdf92cad38
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.28-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.28-r1.ebuild,v 1.1 2014/11/19 19:16:08 vapier Exp $
+
+EAPI=5
+inherit eutils systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc +libsamplerate +ncurses nls selinux"
+
+CDEPEND=">=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7 )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-alsa )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-aplay-return.patch
+ epatch "${FILESDIR}"/${P}-va-end.patch
+ epatch "${FILESDIR}"/${P}-{mixer,monitor}-proto.patch
+ epatch_user
+}
+
+src_configure() {
+ local myconf
+ use doc || myconf='--disable-xmlto'
+
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
+ econf \
+ --disable-maintainer-mode \
+ $(use_enable libsamplerate alsaloop) \
+ $(use_enable nls) \
+ $(use_enable ncurses alsamixer) \
+ --disable-alsaconf \
+ "$(systemd_with_unitdir)" \
+ --with-udev-rules-dir="$(get_udevdir)"/rules.d \
+ ${myconf}
+}
+
+src_install() {
+ default
+ dodoc seq/*/README.*
+
+ newinitd "${FILESDIR}"/alsasound.initd-r6 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+
+ # ALSA lib parser.c:1266:(uc_mgr_scan_master_configs) error: could not
+ # scan directory /usr/share/alsa/ucm: No such file or directory
+ # alsaucm: unable to obtain card list: No such file or directory
+ keepdir /usr/share/alsa/ucm
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.28-aplay-return.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.28-aplay-return.patch
new file mode 100644
index 000000000000..e25788892b28
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.28-aplay-return.patch
@@ -0,0 +1,45 @@
+http://crbug.com/433899
+
+From 8f361d83cfcb39887f5fc591633e68d9448e3425 Mon Sep 17 00:00:00 2001
+From: Jaroslav Kysela <perex@perex.cz>
+Date: Wed, 1 Oct 2014 15:43:57 +0200
+Subject: [PATCH [alsa-utils]] Revert "aplay: fix pcm_read() return value"
+
+This reverts commit 8aa13eec80eac312e4b99423909387660fb99b8f.
+
+The semantics for pcm_read() and pcm_readv() was changed, but the
+callers expect the exact frame count as requested. It's possible
+to fix callers, but the fix is more complicated than to revert the
+change. Note that '-d' processing was broken in some cases.
+
+Note: The reverted commit allows that the return value might be
+greater than requested (see the first condition in read routines).
+---
+ aplay/aplay.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/aplay/aplay.c b/aplay/aplay.c
+index 30d3f31..e58e1bc 100644
+--- a/aplay/aplay.c
++++ b/aplay/aplay.c
+@@ -2039,7 +2039,7 @@ static ssize_t pcm_read(u_char *data, size_t rcount)
+ data += r * bits_per_frame / 8;
+ }
+ }
+- return result;
++ return rcount;
+ }
+
+ static ssize_t pcm_readv(u_char **data, unsigned int channels, size_t rcount)
+@@ -2084,7 +2084,7 @@ static ssize_t pcm_readv(u_char **data, unsigned int channels, size_t rcount)
+ count -= r;
+ }
+ }
+- return result;
++ return rcount;
+ }
+
+ /*
+--
+2.1.3
+
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.28-mixer-proto.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.28-mixer-proto.patch
new file mode 100644
index 000000000000..fdd26c328469
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.28-mixer-proto.patch
@@ -0,0 +1,24 @@
+From c788ce9b6088e2c937f77231eab520c3d16e0c76 Mon Sep 17 00:00:00 2001
+From: Jaroslav Kysela <perex@perex.cz>
+Date: Wed, 25 Jun 2014 10:49:23 +0200
+Subject: [PATCH [alsa-utils]] alsamixer: include missing mixer_controls.h
+
+---
+ alsamixer/mainloop.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/alsamixer/mainloop.c b/alsamixer/mainloop.c
+index 351f57f..79d81a9 100644
+--- a/alsamixer/mainloop.c
++++ b/alsamixer/mainloop.c
+@@ -29,6 +29,7 @@
+ #include "widget.h"
+ #include "mixer_widget.h"
+ #include "mixer_display.h"
++#include "mixer_controls.h"
+ #include "mainloop.h"
+
+ static WINDOW *curses_initialized;
+--
+2.1.3
+
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.28-monitor-proto.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.28-monitor-proto.patch
new file mode 100644
index 000000000000..55d93f832d93
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.28-monitor-proto.patch
@@ -0,0 +1,24 @@
+From 74e5d57c999f8afed4f87046dcac84f6709b9196 Mon Sep 17 00:00:00 2001
+From: Jaroslav Kysela <perex@perex.cz>
+Date: Wed, 24 Sep 2014 10:46:02 +0200
+Subject: [PATCH [alsa-utils]] alsactl: aded missing monitor() prototype
+
+---
+ alsactl/alsactl.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/alsactl/alsactl.h b/alsactl/alsactl.h
+index bd9bf23..4f969ec 100644
+--- a/alsactl/alsactl.h
++++ b/alsactl/alsactl.h
+@@ -31,6 +31,7 @@ int save_state(const char *file, const char *cardname);
+ int load_state(const char *file, const char *initfile, const char *cardname,
+ int do_init);
+ int power(const char *argv[], int argc);
++int monitor(const char *name);
+ int state_daemon(const char *file, const char *cardname, int period,
+ const char *pidfile);
+ int state_daemon_kill(const char *pidfile, const char *cmd);
+--
+2.1.3
+
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.28-va-end.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.28-va-end.patch
new file mode 100644
index 000000000000..a4153bd89f56
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.28-va-end.patch
@@ -0,0 +1,39 @@
+From 89a4f490bd974e454d82942100f241bb1a2270f3 Mon Sep 17 00:00:00 2001
+From: Jaroslav Kysela <perex@perex.cz>
+Date: Wed, 24 Sep 2014 10:52:17 +0200
+Subject: [PATCH [alsa-utils]] =?UTF-8?q?alsactl:=20coverity=20-=20missing?=
+ =?UTF-8?q?=5Fva=5Fend=20=E2=80=93=20va=5Fend=20was=20not=20called=20for?=
+ =?UTF-8?q?=20"ap"?=
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+---
+ alsactl/utils.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/alsactl/utils.c b/alsactl/utils.c
+index b5d183c..304df7c 100644
+--- a/alsactl/utils.c
++++ b/alsactl/utils.c
+@@ -157,8 +157,8 @@ void cerror_(const char *fcn, long line, int cond, const char *fmt, ...)
+ fprintf(stderr, "%s: %s:%ld: ", command, fcn, line);
+ vfprintf(stderr, fmt, ap);
+ putc('\n', stderr);
+- va_end(ap);
+ }
++ va_end(ap);
+ }
+
+ void dbg_(const char *fcn, long line, const char *fmt, ...)
+@@ -174,6 +174,6 @@ void dbg_(const char *fcn, long line, const char *fmt, ...)
+ fprintf(stderr, "%s: %s:%ld: ", command, fcn, line);
+ vfprintf(stderr, fmt, ap);
+ putc('\n', stderr);
+- va_end(ap);
+ }
++ va_end(ap);
+ }
+--
+2.1.3
+