summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-01-28 01:46:03 +0000
committerTim Harder <radhermit@gentoo.org>2015-01-28 01:46:03 +0000
commit910d334637851ed2ee2751233caed51dcc29a21d (patch)
tree7b499d6b1b8d31ddb276506dcbab1734cca2dea4
parentVersion bump. (diff)
downloadgentoo-2-910d334637851ed2ee2751233caed51dcc29a21d.tar.gz
gentoo-2-910d334637851ed2ee2751233caed51dcc29a21d.tar.bz2
gentoo-2-910d334637851ed2ee2751233caed51dcc29a21d.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
-rw-r--r--app-editors/vile/ChangeLog9
-rw-r--r--app-editors/vile/vile-9.8o.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-editors/vile/ChangeLog b/app-editors/vile/ChangeLog
index fc700608d68e..dde16511bfe8 100644
--- a/app-editors/vile/ChangeLog
+++ b/app-editors/vile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vile
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/ChangeLog,v 1.56 2014/08/26 15:15:02 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/ChangeLog,v 1.57 2015/01/28 01:46:03 radhermit Exp $
+
+*vile-9.8o (28 Jan 2015)
+
+ 28 Jan 2015; Tim Harder <radhermit@gentoo.org> +vile-9.8o.ebuild:
+ Version bump.
*vile-9.8n (26 Aug 2014)
diff --git a/app-editors/vile/vile-9.8o.ebuild b/app-editors/vile/vile-9.8o.ebuild
new file mode 100644
index 000000000000..90affd6d95b3
--- /dev/null
+++ b/app-editors/vile/vile-9.8o.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.8o.ebuild,v 1.1 2015/01/28 01:46:03 radhermit Exp $
+
+EAPI="5"
+
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="perl"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ app-admin/eselect-vi"
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ $(use_with perl )
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_OPT_S="" install
+ dodoc CHANGES* README doc/*.doc
+ dohtml doc/*.html
+}
+
+pkg_postinst() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}