summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-01 10:18:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-01 10:18:16 +0000
commit9161c2ac09f04f6aa78dd45e81e768b28fe9a865 (patch)
treed0914dfb9c5afd61fe8cc3bfed020766e03cde33
parentUpdate homepage. (diff)
downloadgentoo-2-9161c2ac09f04f6aa78dd45e81e768b28fe9a865.tar.gz
gentoo-2-9161c2ac09f04f6aa78dd45e81e768b28fe9a865.tar.bz2
gentoo-2-9161c2ac09f04f6aa78dd45e81e768b28fe9a865.zip
Fix installation of documentation (bug #271944).
(Portage version: 13625-svn/cvs/Linux x86_64)
-rw-r--r--net-libs/gnutls/ChangeLog6
-rw-r--r--net-libs/gnutls/gnutls-2.8.0.ebuild22
-rw-r--r--net-libs/gnutls/gnutls-2.9.0.ebuild22
3 files changed, 33 insertions, 17 deletions
diff --git a/net-libs/gnutls/ChangeLog b/net-libs/gnutls/ChangeLog
index 3f90d35869ca..2932c3e1430d 100644
--- a/net-libs/gnutls/ChangeLog
+++ b/net-libs/gnutls/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/gnutls
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.201 2009/05/28 17:33:30 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.202 2009/06/01 10:18:16 arfrever Exp $
+
+ 01 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ gnutls-2.8.0.ebuild, gnutls-2.9.0.ebuild:
+ Fix installation of documentation (bug #271944).
*gnutls-2.9.0 (28 May 2009)
*gnutls-2.8.0 (28 May 2009)
diff --git a/net-libs/gnutls/gnutls-2.8.0.ebuild b/net-libs/gnutls/gnutls-2.8.0.ebuild
index 951ed4add4d5..839b8d174bac 100644
--- a/net-libs/gnutls/gnutls-2.8.0.ebuild
+++ b/net-libs/gnutls/gnutls-2.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.8.0.ebuild,v 1.1 2009/05/28 17:33:30 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.8.0.ebuild,v 1.2 2009/06/01 10:18:16 arfrever Exp $
EAPI="2"
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.gnutls.org/"
MINOR_VERSION="${PV#*.}"
MINOR_VERSION="${MINOR_VERSION%.*}"
-if [[ $((MINOR_VERSION % 2)) == 0 ]] ; then
+if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
#SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
else
@@ -23,7 +23,7 @@ unset MINOR_VERSION
LICENSE="LGPL-2.1 GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="bindist +cxx doc guile lzo nls zlib"
+IUSE="bindist +cxx doc examples guile lzo nls zlib"
RDEPEND="dev-libs/libgpg-error
>=dev-libs/libgcrypt-1.4.0
@@ -46,12 +46,14 @@ pkg_setup() {
}
src_prepare() {
+ sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
+
local dir
- for dir in m4 lib/m4 libextra/m4 ; do
+ for dir in m4 lib/m4 libextra/m4; do
rm -f "${dir}/lt"* "${dir}/libtool.m4"
done
find . -name ltmain.sh -exec rm {} \;
- for dir in . lib libextra ; do
+ for dir in . lib libextra; do
pushd "${dir}" > /dev/null
eautoreconf
popd > /dev/null
@@ -63,7 +65,7 @@ src_prepare() {
src_configure() {
local myconf
use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
- econf \
+ econf --htmldir=/usr/share/doc/${P}/html \
$(use_enable cxx) \
$(use_enable doc gtk-doc) \
$(use_enable guile) \
@@ -77,8 +79,12 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS README THANKS doc/TODO
- if use doc ; then
- dodoc doc/README.autoconf doc/tex/gnutls.ps
+ if use doc; then
+ dodoc doc/gnutls.{pdf,ps}
+ dohtml doc/gnutls.html
+ fi
+
+ if use examples; then
docinto examples
dodoc doc/examples/*.c
fi
diff --git a/net-libs/gnutls/gnutls-2.9.0.ebuild b/net-libs/gnutls/gnutls-2.9.0.ebuild
index 353da1a15bb4..1350c8ea5647 100644
--- a/net-libs/gnutls/gnutls-2.9.0.ebuild
+++ b/net-libs/gnutls/gnutls-2.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.9.0.ebuild,v 1.1 2009/05/28 17:33:30 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.9.0.ebuild,v 1.2 2009/06/01 10:18:16 arfrever Exp $
EAPI="2"
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.gnutls.org/"
MINOR_VERSION="${PV#*.}"
MINOR_VERSION="${MINOR_VERSION%.*}"
-if [[ $((MINOR_VERSION % 2)) == 0 ]] ; then
+if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
#SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
else
@@ -23,7 +23,7 @@ unset MINOR_VERSION
LICENSE="LGPL-2.1 GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="bindist +cxx doc guile lzo nls zlib"
+IUSE="bindist +cxx doc examples guile lzo nls zlib"
RDEPEND="dev-libs/libgpg-error
>=dev-libs/libgcrypt-1.4.0
@@ -46,12 +46,14 @@ pkg_setup() {
}
src_prepare() {
+ sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
+
local dir
- for dir in m4 lib/m4 libextra/m4 ; do
+ for dir in m4 lib/m4 libextra/m4; do
rm -f "${dir}/lt"* "${dir}/libtool.m4"
done
find . -name ltmain.sh -exec rm {} \;
- for dir in . lib libextra ; do
+ for dir in . lib libextra; do
pushd "${dir}" > /dev/null
eautoreconf
popd > /dev/null
@@ -63,7 +65,7 @@ src_prepare() {
src_configure() {
local myconf
use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
- econf \
+ econf --htmldir=/usr/share/doc/${P}/html \
$(use_enable cxx) \
$(use_enable doc gtk-doc) \
$(use_enable guile) \
@@ -77,8 +79,12 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS README THANKS doc/TODO
- if use doc ; then
- dodoc doc/README.autoconf doc/tex/gnutls.ps
+ if use doc; then
+ dodoc doc/gnutls.{pdf,ps}
+ dohtml doc/gnutls.html
+ fi
+
+ if use examples; then
docinto examples
dodoc doc/examples/*.c
fi