summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-21 11:48:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-21 11:48:29 +0000
commit966a9901e1d02a5179ef62686ed0c12cc090b9a1 (patch)
treea5d3eb78d0f5a89f172a159eb0ab8c43ff793b60
parentdefine eapi before inherit and assign rdepend explicitly (diff)
downloadgentoo-2-966a9901e1d02a5179ef62686ed0c12cc090b9a1.tar.gz
gentoo-2-966a9901e1d02a5179ef62686ed0c12cc090b9a1.tar.bz2
gentoo-2-966a9901e1d02a5179ef62686ed0c12cc090b9a1.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
-rw-r--r--dev-ml/camomile/ChangeLog7
-rw-r--r--dev-ml/camomile/camomile-0.7.2.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ml/camomile/ChangeLog b/dev-ml/camomile/ChangeLog
index fbbf763cd0e1..951f98ce4599 100644
--- a/dev-ml/camomile/ChangeLog
+++ b/dev-ml/camomile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camomile
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.14 2009/06/21 11:42:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.15 2009/06/21 11:48:29 aballier Exp $
+
+*camomile-0.7.2 (21 Jun 2009)
+
+ 21 Jun 2009; Alexis Ballier <aballier@gentoo.org> +camomile-0.7.2.ebuild:
+ version bump
21 Jun 2009; Alexis Ballier <aballier@gentoo.org> camomile-0.7.1.ebuild:
define eapi before inherit and assign rdepend explicitly
diff --git a/dev-ml/camomile/camomile-0.7.2.ebuild b/dev-ml/camomile/camomile-0.7.2.ebuild
new file mode 100644
index 000000000000..c7ceb6c5d43a
--- /dev/null
+++ b/dev-ml/camomile/camomile-0.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.7.2.ebuild,v 1.1 2009/06/21 11:48:29 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml."
+HOMEPAGE="http://camomile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/camomile/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 byte unidata unimaps charmap_data locale_data || die "failed to build"
+ if use ocamlopt; then
+ emake -j1 opt || die "failed to build native code"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
+}