summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-17 22:33:51 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-17 22:33:51 +0000
commit9bbd9604199ae12ab0b95f7e73838aab0f2d5a86 (patch)
tree8b8e5dcb6d64379ae35895f0b5e6171def7076af
parentStable on sparc (diff)
downloadgentoo-2-9bbd9604199ae12ab0b95f7e73838aab0f2d5a86.tar.gz
gentoo-2-9bbd9604199ae12ab0b95f7e73838aab0f2d5a86.tar.bz2
gentoo-2-9bbd9604199ae12ab0b95f7e73838aab0f2d5a86.zip
dont run simple tests when doing a native cross build #92695
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r12.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.5.20050421.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.3.5.ebuild3
10 files changed, 21 insertions, 17 deletions
diff --git a/sys-libs/glibc/glibc-2.3.2-r12.ebuild b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
index 4d3f6fdd3db8..d716bb0046d2 100644
--- a/sys-libs/glibc/glibc-2.3.2-r12.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.12 2005/05/17 00:52:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.13 2005/05/17 22:33:51 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -52,7 +52,7 @@ DEPEND=">=sys-devel/gcc-3.2.3-r1
RDEPEND="virtual/os-headers
nls? ( sys-devel/gettext )"
PDEPEND="ppc? ( >=sys-kernel/linux-headers-2.4.22 )"
-PROVIDE="virtual/glibc virtual/libc"
+PROVIDE="virtual/libc"
# Try to get a kernel source tree with version equal or greater
# than $1. We basically just try a few default locations. The
diff --git a/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild b/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild
index 2de069bd1d88..55bc77dd704f 100644
--- a/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild,v 1.9 2005/05/17 00:52:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420-r2.ebuild,v 1.10 2005/05/17 22:33:51 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -42,7 +42,7 @@ DEPEND=">=sys-devel/gcc-3.2.3-r1
nls? ( sys-devel/gettext )"
RDEPEND="virtual/os-headers
nls? ( sys-devel/gettext )"
-PROVIDE="virtual/glibc virtual/libc"
+PROVIDE="virtual/libc"
# Try to get a kernel source tree with version equal or greater
diff --git a/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild b/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
index 6d8ec05c0f74..8e7506c806af 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild,v 1.14 2005/05/17 00:52:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild,v 1.15 2005/05/17 22:33:51 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -61,7 +61,7 @@ DEPEND=">=sys-devel/gcc-3.2.3-r1
RDEPEND="virtual/os-headers
nls? ( sys-devel/gettext )"
-PROVIDE="virtual/glibc virtual/libc"
+PROVIDE="virtual/libc"
# Theoretical cross-compiler support
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 4c66182a513f..da45b3a430cc 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.46 2005/05/17 00:52:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.47 2005/05/17 22:33:51 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -71,7 +71,7 @@ RDEPEND="virtual/os-headers
# until amd64's 2004.3 is purged out of existence
PDEPEND="amd64? ( multilib? ( app-emulation/emul-linux-x86-glibc ) )"
-PROVIDE="virtual/glibc virtual/libc"
+PROVIDE="virtual/libc"
# We need to be able to set alternative headers for
# compiling for non-native platform
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index b7485f811626..40fae773b0c6 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.11 2005/05/17 00:52:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.12 2005/05/17 22:33:51 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -69,7 +69,7 @@ RDEPEND="virtual/os-headers
# until amd64's 2004.3 is purged out of existence
PDEPEND="amd64? ( multilib? ( app-emulation/emul-linux-x86-glibc ) )"
-PROVIDE="virtual/glibc virtual/libc"
+PROVIDE="virtual/libc"
# We need to be able to set alternative headers for
# compiling for non-native platform
@@ -1011,6 +1011,7 @@ EOF
# simple test to make sure our new glibc isnt completely broken.
# for now, skip the multilib scenario. also make sure we don't
# test with statically built binaries since they will fail.
+ [[ ${CBUILD} != ${CHOST} ]] && return 0
[[ $(get_libdir) != "lib" ]] && return 0
for x in date env ls true uname ; do
x=$(type -p ${x})
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
index d4d29a88c223..23566f7c4383 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.52 2005/05/17 00:52:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.53 2005/05/17 22:33:51 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -69,7 +69,7 @@ RDEPEND="virtual/os-headers
# until amd64's 2004.3 is purged out of existence
PDEPEND="amd64? ( multilib? ( app-emulation/emul-linux-x86-glibc ) )"
-PROVIDE="virtual/glibc virtual/libc"
+PROVIDE="virtual/libc"
# We need to be able to set alternative headers for
# compiling for non-native platform
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index f182aeea5fd4..6578d3c5482d 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.48 2005/05/17 00:52:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.49 2005/05/17 22:33:51 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -497,6 +497,7 @@ toolchain-glibc_src_install() {
# simple test to make sure our new glibc isnt completely broken.
# for now, skip the multilib scenario. also make sure we don't
# test with statically built binaries since they will fail.
+ [[ ${CBUILD} != ${CHOST} ]] && return 0
[[ $(get_libdir) != "lib" ]] && return 0
for x in date env ls true uname ; do
x=$(type -p ${x})
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125.ebuild
index b59c6267ea67..2d4e8b6aa7c9 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125.ebuild,v 1.40 2005/05/17 00:52:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125.ebuild,v 1.41 2005/05/17 22:33:51 vapier Exp $
KEYWORDS="~amd64 ~mips ~sparc ~x86 -ppc"
@@ -28,7 +28,7 @@ LICENSE="LGPL-2"
IUSE="nls pic build nptl nptlonly erandom hardened debug userlocales nomalloccheck multilib"
-PROVIDE="virtual/glibc virtual/libc"
+PROVIDE="virtual/libc"
export CBUILD=${CBUILD:-${CHOST}}
if [[ ${CBUILD} = ${CHOST} ]] ; then
diff --git a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
index 8f8da5dcaa7d..59d344b52119 100644
--- a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.10 2005/05/17 00:52:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.11 2005/05/17 22:33:51 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -504,6 +504,7 @@ toolchain-glibc_src_install() {
# simple test to make sure our new glibc isnt completely broken.
# for now, skip the multilib scenario. also make sure we don't
# test with statically built binaries since they will fail.
+ [[ ${CBUILD} != ${CHOST} ]] && return 0
[[ $(get_libdir) != "lib" ]] && return 0
for x in date env ls true uname ; do
x=$(type -p ${x})
diff --git a/sys-libs/glibc/glibc-2.3.5.ebuild b/sys-libs/glibc/glibc-2.3.5.ebuild
index 8389e2e70278..7999fe9cb8c4 100644
--- a/sys-libs/glibc/glibc-2.3.5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.16 2005/05/17 00:52:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.17 2005/05/17 22:33:51 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -497,6 +497,7 @@ toolchain-glibc_src_install() {
# simple test to make sure our new glibc isnt completely broken.
# for now, skip the multilib scenario. also make sure we don't
# test with statically built binaries since they will fail.
+ [[ ${CBUILD} != ${CHOST} ]] && return 0
[[ $(get_libdir) != "lib" ]] && return 0
for x in date env ls true uname ; do
x=$(type -p ${x})