summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-14 22:30:18 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-14 22:30:18 +0000
commit9d89944f332c4290c40d4932495035ff8358a01f (patch)
tree1cbc8b85434f798cc9812f7b925b5ea08f8acf77
parentVersion bump for Gnome 3.14. (diff)
downloadgentoo-2-9d89944f332c4290c40d4932495035ff8358a01f.tar.gz
gentoo-2-9d89944f332c4290c40d4932495035ff8358a01f.tar.bz2
gentoo-2-9d89944f332c4290c40d4932495035ff8358a01f.zip
Convert to distutils-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--app-accessibility/sphinx3/ChangeLog10
-rw-r--r--app-accessibility/sphinx3/sphinx3-0.8-r1.ebuild61
2 files changed, 68 insertions, 3 deletions
diff --git a/app-accessibility/sphinx3/ChangeLog b/app-accessibility/sphinx3/ChangeLog
index eb1fe1cd09f1..4ed72116b66f 100644
--- a/app-accessibility/sphinx3/ChangeLog
+++ b/app-accessibility/sphinx3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/sphinx3
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/ChangeLog,v 1.10 2013/10/09 02:03:56 teiresias Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/ChangeLog,v 1.11 2014/12/14 22:30:18 mgorny Exp $
+
+*sphinx3-0.8-r1 (14 Dec 2014)
+
+ 14 Dec 2014; Michał Górny <mgorny@gentoo.org> +sphinx3-0.8-r1.ebuild:
+ Convert to distutils-r1.
09 Oct 2013; Christopher Brannon <teiresias@gentoo.org> sphinx3-0.8.ebuild,
+files/sphinx3-0.8-libutil.patch:
@@ -42,4 +47,3 @@ Remove include of nonexistent header. Closes bug #487098.
+sphinx3-0.6.ebuild:
Initial import, bug #129149 with help from Franklin Marmon
<marmon@montana.com>.
-
diff --git a/app-accessibility/sphinx3/sphinx3-0.8-r1.ebuild b/app-accessibility/sphinx3/sphinx3-0.8-r1.ebuild
new file mode 100644
index 000000000000..bc7dc486c298
--- /dev/null
+++ b/app-accessibility/sphinx3/sphinx3-0.8-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/sphinx3-0.8-r1.ebuild,v 1.1 2014/12/14 22:30:18 mgorny Exp $
+
+EAPI=5
+
+# disable automatic phase exports and deps
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils distutils-r1 prefix eutils
+
+DESCRIPTION="CMU Speech Recognition engine"
+HOMEPAGE="http://cmusphinx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc python static-libs"
+
+RDEPEND=">=app-accessibility/sphinxbase-0.7[static-libs?,python?,${PYTHON_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Due to generated Python setup.py.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_heap_fix.patch" \
+ "${FILESDIR}/${P}-libutil.patch"
+ eprefixify 'python/setup.py'
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use python; then
+ cd python || die
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog NEWS README )
+ autotools-utils_src_install
+
+ if use doc; then
+ cd doc || die
+ dohtml -r -x CVS s3* s3 *.html
+ fi
+
+ if use python; then
+ unset DOCS
+
+ cd "${S}"/python || die
+ distutils-r1_src_install
+ fi
+}