summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-05-17 05:50:18 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-05-17 05:50:18 +0000
commit9e97829b69cccdb7e5839791021da1e29a2c9694 (patch)
tree6ad7d1709ee70b00c578ce9c518a1ee7b3d6ed58
parentFix for #20647 (~x86 masked). (diff)
downloadgentoo-2-9e97829b69cccdb7e5839791021da1e29a2c9694.tar.gz
gentoo-2-9e97829b69cccdb7e5839791021da1e29a2c9694.tar.bz2
gentoo-2-9e97829b69cccdb7e5839791021da1e29a2c9694.zip
new version, now builds with icc
-rw-r--r--dev-libs/boost/ChangeLog10
-rw-r--r--dev-libs/boost/Manifest7
-rw-r--r--dev-libs/boost/boost-1.30.0.ebuild103
-rw-r--r--dev-libs/boost/files/digest-boost-1.30.01
4 files changed, 120 insertions, 1 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 5122c7120e59..137cee76da59 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.3 2002/05/07 03:58:19 drobbins Exp
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.5 2003/05/17 05:50:03 george Exp $
+
+*boost-1.30.0 (16 May 2003)
+
+ 16 May 2003; George Shapovalov <george@gentoo.org> boost-1.30.0.ebuild :
+ new version. (#18183)
+ now supports building with icc
+ Thanks to Jeremy Maitin-Shepard <jbms@ittbi.com> and Garen <garen@garen.net>
+ for submitting and polishing the ebuild
*boost-1.29.0 (21 Oct 2002)
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
new file mode 100644
index 000000000000..e86293ed77c4
--- /dev/null
+++ b/dev-libs/boost/Manifest
@@ -0,0 +1,7 @@
+MD5 54906ad63b12ddbb313cab67b57c9bb1 boost-1.29.0.ebuild 1440
+MD5 cab792d31d69aaa8618b050dadcb426a boost-1.28.ebuild 1446
+MD5 e3b0bea67bd52edad9f17544a9e76f3e boost-1.30.0.ebuild 3000
+MD5 f7c854cc61848f5c42009aee06aa1bb8 ChangeLog 1037
+MD5 ed187a2b2048776a7e5b27060d96938c files/digest-boost-1.29.0 65
+MD5 2b36d47323b021671d391600501685cc files/digest-boost-1.30.0 66
+MD5 0debdea0d8401ccef37a4421c1bc8c07 files/digest-boost-1.28 65
diff --git a/dev-libs/boost/boost-1.30.0.ebuild b/dev-libs/boost/boost-1.30.0.ebuild
new file mode 100644
index 000000000000..4c0a250cbc35
--- /dev/null
+++ b/dev-libs/boost/boost-1.30.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.30.0.ebuild,v 1.1 2003/05/17 05:50:03 george Exp $
+
+MY_V="${PV//\./_}"
+
+DESCRIPTION="Boost provides free peer-reviewed portable C++ source libraries."
+HOMEPAGE="http://www.boost.org"
+#SRC_URI="http://easynews.dl.sourceforge.net/sourceforge/boost/boost_${MY_V}.tar.bz2"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${MY_V}.tar.bz2"
+
+LICENSE="freedist"
+KEYWORDS="~x86 ~ppc"
+SLOT="1"
+IUSE="icc"
+
+# This would be a good place for someone to figure out how to get
+# boost to build nicely with icc, as it's documented to be doable.
+
+DEPEND="virtual/glibc"
+RDEPEND=">=dev-util/yacc-1.9.1-r1
+ >=dev-lang/python-2.2.1
+ icc? ( >=dev-lang/icc-7.1 )"
+
+S="${WORKDIR}/boost_${MY_V}"
+
+src_compile() {
+ local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | /usr/bin/cut -d . -f 2,3)
+ local BOOST_TOOLSET
+
+ if [ "`use icc`" ] ; then
+ BOOST_TOOLSET="intel-linux"
+ else
+ BOOST_TOOLSET="gcc"
+ fi
+
+ # Build bjam, a jam variant, which is used instead of make
+ cd ${S}/tools/build/jam_src
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
+ cd ${S}
+
+ if [ "`use icc`" ] ; then
+ ./tools/build/jam_src/bin.linux${ARCH}/bjam -j2 \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_LINUX_VERSION="70" || die "Failed to build boost libraries."
+ else
+ ./tools/build/jam_src/bin.linux${ARCH}/bjam -j6 \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET}
+
+ einfo "Don't worry if there are a few (probably 6) failures above."
+ einfo "Some targets merely need to be combined. Here goes:"
+
+ ./tools/build/jam_src/bin.linux${ARCH}/bjam \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET} || die "Failed to build boost libraries."
+ fi
+}
+
+src_install () {
+ # Unfortunately boost doesn't provide a standard way to
+ # install itself. So it's done "manually" here.
+
+ cd ${S}
+
+ # install libraries
+ find libs -type f -name \*.a -exec dolib.a {} \;
+ find libs -type f -name \*.so -exec dolib.so {} \;
+
+ # install source/header files
+
+ find boost -type f \
+ -exec install -D -m0644 {} ${D}/usr/include/{} \;
+
+ # install documentation
+ dodoc README
+ dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css
+ dohtml -A pdf -r more
+ dohtml -r people
+ dohtml -r doc
+
+ find libs -type f -not -regex '^libs/[^/]*/build/.*' \
+ -and -not -regex '^libs/.*/test[^/]?/.*' \
+ -and -not -regex '^libs/.*/bench[^/]?/.*' \
+ -and -not -regex '^libs/[^/]*/tools/.*' \
+ -and -not -name \*.bat \
+ -and -not -name Jamfile\* \
+ -and -not -regex '^libs/[^/]*/src/.*' \
+ -and -not -iname makefile \
+ -and -not -name \*.mak \
+ -and -not -name .\* \
+ -and -not -name \*.dsw \
+ -and -not -name \*.dsp \
+ -exec \
+ install -D -m0644 \{\} ${D}/usr/share/doc/${P}/html/\{\} \;
+}
diff --git a/dev-libs/boost/files/digest-boost-1.30.0 b/dev-libs/boost/files/digest-boost-1.30.0
new file mode 100644
index 000000000000..7a834e5f5068
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.30.0
@@ -0,0 +1 @@
+MD5 65fd58943e1763e064d271630e257649 boost_1_30_0.tar.bz2 5448725