summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-12-21 08:16:22 +0000
committerMike Gilbert <floppym@gentoo.org>2011-12-21 08:16:22 +0000
commit9ff1426edbeed80da21df2106663ce1ff2978eba (patch)
tree6f5d6815e5f07123c03f25995a747080759800db
parentForce usage of python2. Patch by Ian Delaney. Resolves bug 367801. (diff)
downloadgentoo-2-9ff1426edbeed80da21df2106663ce1ff2978eba.tar.gz
gentoo-2-9ff1426edbeed80da21df2106663ce1ff2978eba.tar.bz2
gentoo-2-9ff1426edbeed80da21df2106663ce1ff2978eba.zip
Fix tests with python 3; bug 377459. Patch by Arfrever, tested by Ian Delaney.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
-rw-r--r--sys-apps/hwdata-redhat/ChangeLog8
-rw-r--r--sys-apps/hwdata-redhat/files/hwdata-redhat-0.217-python-3.patch13
-rw-r--r--sys-apps/hwdata-redhat/hwdata-redhat-0.217.ebuild7
3 files changed, 23 insertions, 5 deletions
diff --git a/sys-apps/hwdata-redhat/ChangeLog b/sys-apps/hwdata-redhat/ChangeLog
index b52ab80d136b..5701069b0d45 100644
--- a/sys-apps/hwdata-redhat/ChangeLog
+++ b/sys-apps/hwdata-redhat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/hwdata-redhat
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwdata-redhat/ChangeLog,v 1.5 2009/01/31 07:46:18 dberkholz Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwdata-redhat/ChangeLog,v 1.6 2011/12/21 08:16:22 floppym Exp $
+
+ 21 Dec 2011; Mike Gilbert <floppym@gentoo.org>
+ +files/hwdata-redhat-0.217-python-3.patch, hwdata-redhat-0.217.ebuild:
+ Fix tests with python 3; bug 377459. Patch by Arfrever, tested by Ian Delaney.
31 Jan 2009; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
Give up maintainership; reassign to maintainer-needed.
diff --git a/sys-apps/hwdata-redhat/files/hwdata-redhat-0.217-python-3.patch b/sys-apps/hwdata-redhat/files/hwdata-redhat-0.217-python-3.patch
new file mode 100644
index 000000000000..f16fddd992c4
--- /dev/null
+++ b/sys-apps/hwdata-redhat/files/hwdata-redhat-0.217-python-3.patch
@@ -0,0 +1,13 @@
+--- check-pci-ids.py
++++ check-pci-ids.py
+@@ -5,8 +5,8 @@
+
+ # Check that the sorting order is preserved in pci.ids
+
+-vendor_id = None
+-device_id = None
++vendor_id = -1
++device_id = -1
+ lineno = 1
+
+ file = open("pci.ids")
diff --git a/sys-apps/hwdata-redhat/hwdata-redhat-0.217.ebuild b/sys-apps/hwdata-redhat/hwdata-redhat-0.217.ebuild
index bb0b48762889..ff3edd25b963 100644
--- a/sys-apps/hwdata-redhat/hwdata-redhat-0.217.ebuild
+++ b/sys-apps/hwdata-redhat/hwdata-redhat-0.217.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwdata-redhat/hwdata-redhat-0.217.ebuild,v 1.1 2008/07/15 17:05:57 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwdata-redhat/hwdata-redhat-0.217.ebuild,v 1.2 2011/12/21 08:16:22 floppym Exp $
-inherit flag-o-matic rpm
+inherit eutils flag-o-matic rpm
# Tag for which Fedora Core version it's from
FCVER="9"
@@ -29,6 +29,7 @@ src_unpack() {
cd "${S}"
sed -i -e "s:\(/sbin\/lspci\):/usr\1:g" Makefile || die
+ epatch "${FILESDIR}/${P}-python-3.patch"
}
src_install() {