summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-02-16 23:09:24 +0000
committerJohannes Huber <johu@gentoo.org>2012-02-16 23:09:24 +0000
commita1504211365c4f1d62eeeebee69726cec3e87ff8 (patch)
tree8bf328cba138caa862b9241bfa8cfc41aa47bb79
parentAdd patch from upstream for x32 targets. (diff)
downloadgentoo-2-a1504211365c4f1d62eeeebee69726cec3e87ff8.tar.gz
gentoo-2-a1504211365c4f1d62eeeebee69726cec3e87ff8.tar.bz2
gentoo-2-a1504211365c4f1d62eeeebee69726cec3e87ff8.zip
Version bump.
(Portage version: 2.2.0_alpha86/cvs/Linux i686)
-rw-r--r--media-libs/phonon-gstreamer/ChangeLog8
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-4.6.0.ebuild50
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild6
3 files changed, 60 insertions, 4 deletions
diff --git a/media-libs/phonon-gstreamer/ChangeLog b/media-libs/phonon-gstreamer/ChangeLog
index 4ed415e70549..c8622f317eb5 100644
--- a/media-libs/phonon-gstreamer/ChangeLog
+++ b/media-libs/phonon-gstreamer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/phonon-gstreamer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/ChangeLog,v 1.15 2012/02/15 17:26:18 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/ChangeLog,v 1.16 2012/02/16 23:09:24 johu Exp $
+
+*phonon-gstreamer-4.6.0 (16 Feb 2012)
+
+ 16 Feb 2012; Johannes Huber <johu@gentoo.org> +phonon-gstreamer-4.6.0.ebuild,
+ phonon-gstreamer-9999.ebuild:
+ Version bump.
15 Feb 2012; nixnut <nixnut@gentoo.org> phonon-gstreamer-4.5.0.ebuild:
ppc stable #401313
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-4.6.0.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-4.6.0.ebuild
new file mode 100644
index 000000000000..9965e6c04424
--- /dev/null
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-4.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/phonon-gstreamer-4.6.0.ebuild,v 1.1 2012/02/16 23:09:24 johu Exp $
+
+EAPI=4
+
+[[ ${PV} == *9999 ]] && git_eclass="git-2"
+EGIT_REPO_URI="git://anongit.kde.org/${PN}"
+
+MY_PN="phonon-backend-gstreamer"
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils ${git_eclass}
+
+DESCRIPTION="Phonon GStreamer backend"
+HOMEPAGE="https://projects.kde.org/projects/kdesupport/phonon/phonon-gstreamer"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/src/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+SLOT="0"
+IUSE="alsa debug +network"
+
+RDEPEND="
+ media-libs/gstreamer
+ media-plugins/gst-plugins-meta[alsa?,ogg,vorbis]
+ >=media-libs/phonon-4.6.0
+ >=x11-libs/qt-core-4.6.0:4[glib]
+ >=x11-libs/qt-gui-4.6.0:4[glib]
+ >=x11-libs/qt-opengl-4.6.0:4
+ virtual/opengl
+ network? ( media-plugins/gst-plugins-soup )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/automoc-0.9.87
+ dev-util/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with alsa)
+ )
+ cmake-utils_src_configure
+}
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
index c1fa7a572b57..eca564065f63 100644
--- a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild,v 1.8 2011/12/30 18:53:03 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild,v 1.9 2012/02/16 23:09:24 johu Exp $
EAPI=4
@@ -14,7 +14,7 @@ inherit cmake-utils ${git_eclass}
DESCRIPTION="Phonon GStreamer backend"
HOMEPAGE="https://projects.kde.org/projects/kdesupport/phonon/phonon-gstreamer"
-[[ ${PV} == *9999 ]] || SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/src/${MY_P}.tar.bz2"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/src/${MY_P}.tar.xz"
LICENSE="LGPL-2.1"
if [[ ${PV} == *9999 ]]; then