summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2004-10-15 15:40:33 +0000
committerAndreas Proschofsky <suka@gentoo.org>2004-10-15 15:40:33 +0000
commita2ed238c3bcdf648bc60bf2899f0d8a9aaadaa7e (patch)
tree06b2de85f0422e17a8889fb0ab172bbd5880be82
parentstable on x86 for bug #63556 (diff)
downloadgentoo-2-a2ed238c3bcdf648bc60bf2899f0d8a9aaadaa7e.tar.gz
gentoo-2-a2ed238c3bcdf648bc60bf2899f0d8a9aaadaa7e.tar.bz2
gentoo-2-a2ed238c3bcdf648bc60bf2899f0d8a9aaadaa7e.zip
depend on curl only if the appropiate use flag is set
-rw-r--r--app-office/openoffice/ChangeLog5
-rw-r--r--app-office/openoffice/openoffice-1.1.3.ebuild16
2 files changed, 15 insertions, 6 deletions
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index b0187a3432b1..2923cca5e9db 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-office/openoffice
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.84 2004/10/12 14:58:10 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.85 2004/10/15 15:40:33 suka Exp $
+
+ 15 Oct 2004; suka@gentoo.org openoffice-1.1.3.ebuild:
+ depend on curl only if the appropiate use flag is set
12 Oct 2004; suka@gentoo.org openoffice-1.1.3.ebuild:
mark stable on x86 for bug #63556
diff --git a/app-office/openoffice/openoffice-1.1.3.ebuild b/app-office/openoffice/openoffice-1.1.3.ebuild
index 2a6db7ef2cb5..0996e76bd804 100644
--- a/app-office/openoffice/openoffice-1.1.3.ebuild
+++ b/app-office/openoffice/openoffice-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.3.ebuild,v 1.3 2004/10/12 14:58:10 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.3.ebuild,v 1.4 2004/10/15 15:40:33 suka Exp $
# Notes:
#
@@ -26,7 +26,7 @@
inherit flag-o-matic eutils gcc
-IUSE="gnome kde java"
+IUSE="gnome kde java curl"
LOC="/opt"
INSTDIR="${LOC}/OpenOffice.org"
@@ -59,7 +59,7 @@ DEPEND="${RDEPEND}
>=sys-apps/findutils-4.1.20-r1
app-shells/tcsh
dev-util/pkgconfig
- net-misc/curl
+ curl? ( net-misc/curl )
sys-libs/pam
sys-libs/zlib
!dev-util/dmake
@@ -298,6 +298,7 @@ src_compile() {
local buildcmd=""
export MYCONF=""
+ #Check if we use java
if use java
then
MYCONF="${MYCONF} --with-jdk-home=${JAVA_HOME}"
@@ -305,6 +306,12 @@ src_compile() {
MYCONF="${MYCONF} --disable-java"
fi
+ #See if we use system-curl
+ if use curl
+ then
+ MYCONF="${MYCONF} --with-system-curl"
+ fi
+
# Do NOT compile with a external STLport, as gcc-2.95.3 users will
# get linker errors due to the ABI being different (STLport will be
# compiled with 2.95.3, while OO is compiled with 3.x). (Az)
@@ -321,8 +328,7 @@ src_compile() {
--enable-libsn \
--without-fonts \
--with-system-zlib \
- --with-system-freetype \
- --with-system-curl"
+ --with-system-freetype"
./configure ${MYCONF} || die