summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-04 01:33:03 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-04 01:33:03 +0000
commita60b06218cca0c6f3d3f193a0a97ff0d3bc7eb3d (patch)
tree2f1985b89d828759c87ce9cee0085acee0fbdbd3
parentAdded fix for OO/wine transparencies from bug #96053. Thanks to bartron for (diff)
downloadgentoo-2-a60b06218cca0c6f3d3f193a0a97ff0d3bc7eb3d.tar.gz
gentoo-2-a60b06218cca0c6f3d3f193a0a97ff0d3bc7eb3d.tar.bz2
gentoo-2-a60b06218cca0c6f3d3f193a0a97ff0d3bc7eb3d.zip
merge newer patches into older versions and sync style across the ebuilds
(Portage version: 2.0.51.22-r2)
-rw-r--r--app-emulation/wine/files/wine-20041019-no-stack.patch (renamed from app-emulation/wine/files/20041019-no-stack.patch)4
-rw-r--r--app-emulation/wine/files/wine-20050211-docs.patch (renamed from app-emulation/wine/files/20050211-docs.patch)4
-rw-r--r--app-emulation/wine/wine-20041019-r3.ebuild9
-rw-r--r--app-emulation/wine/wine-20050111-r2.ebuild9
-rw-r--r--app-emulation/wine/wine-20050211.ebuild11
-rw-r--r--app-emulation/wine/wine-20050310-r1.ebuild9
-rw-r--r--app-emulation/wine/wine-20050419.ebuild5
-rw-r--r--app-emulation/wine/wine-20050524.ebuild5
-rw-r--r--app-emulation/wine/wine-20050628.ebuild5
-rw-r--r--app-emulation/wine/wine-20050725-r1.ebuild6
-rw-r--r--app-emulation/wine/wine-20050830.ebuild6
-rw-r--r--app-emulation/wine/wine-20050930.ebuild5
12 files changed, 44 insertions, 34 deletions
diff --git a/app-emulation/wine/files/20041019-no-stack.patch b/app-emulation/wine/files/wine-20041019-no-stack.patch
index a615f28d42be..49852f3b6513 100644
--- a/app-emulation/wine/files/20041019-no-stack.patch
+++ b/app-emulation/wine/files/wine-20041019-no-stack.patch
@@ -1,5 +1,5 @@
---- loader/Makefile.in.orig 2004-12-02 08:57:46.540539616 -0500
-+++ loader/Makefile.in 2004-12-02 08:57:53.043551008 -0500
+--- loader/Makefile.in
++++ loader/Makefile.in
@@ -21,5 +21,6 @@
@MAKE_RULES@
diff --git a/app-emulation/wine/files/20050211-docs.patch b/app-emulation/wine/files/wine-20050211-docs.patch
index e47d09602d01..8716f4e88ee7 100644
--- a/app-emulation/wine/files/20050211-docs.patch
+++ b/app-emulation/wine/files/wine-20050211-docs.patch
@@ -1,5 +1,5 @@
---- documentation/getting.sgml.orig 2005-02-19 21:00:05.000000000 -0500
-+++ documentation/getting.sgml 2005-02-19 21:01:20.000000000 -0500
+--- documentation/getting.sgml
++++ documentation/getting.sgml
@@ -30,6 +30,7 @@
few clicks. Building your own installable binary package from a
source package is also possible, although it is beyond the scope of
diff --git a/app-emulation/wine/wine-20041019-r3.ebuild b/app-emulation/wine/wine-20041019-r3.ebuild
index ea6a4df40ade..65ed45610125 100644
--- a/app-emulation/wine/wine-20041019-r3.ebuild
+++ b/app-emulation/wine/wine-20041019-r3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.17 2005/10/02 03:24:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.18 2005/10/04 01:33:03 vapier Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic multilib
-DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+DESCRIPTION="free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.com/"
SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
@@ -41,7 +41,8 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/${PV}-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
diff --git a/app-emulation/wine/wine-20050111-r2.ebuild b/app-emulation/wine/wine-20050111-r2.ebuild
index 67bbcda6e5f4..ab79db64b3e6 100644
--- a/app-emulation/wine/wine-20050111-r2.ebuild
+++ b/app-emulation/wine/wine-20050111-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111-r2.ebuild,v 1.1 2005/08/24 00:19:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111-r2.ebuild,v 1.2 2005/10/04 01:33:03 vapier Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic multilib
-DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+DESCRIPTION="free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.com/"
SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
@@ -41,7 +41,8 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-upstream-registry-fix.patch.bz2 #85387
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
index 9d20acb3e2ca..a69e50278302 100644
--- a/app-emulation/wine/wine-20050211.ebuild
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.15 2005/08/23 01:13:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.16 2005/10/04 01:33:03 vapier Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic multilib
-DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+DESCRIPTION="free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.com/"
SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
@@ -62,9 +62,10 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
- epatch "${FILESDIR}"/20050211-docs.patch
+ epatch "${FILESDIR}"/wine-20050211-docs.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
diff --git a/app-emulation/wine/wine-20050310-r1.ebuild b/app-emulation/wine/wine-20050310-r1.ebuild
index 3817b8b88a0e..2db0095cd84d 100644
--- a/app-emulation/wine/wine-20050310-r1.ebuild
+++ b/app-emulation/wine/wine-20050310-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.8 2005/08/23 01:13:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.9 2005/10/04 01:33:03 vapier Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic multilib
-DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+DESCRIPTION="free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.com/"
SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
@@ -65,7 +65,8 @@ src_unpack() {
epatch "${FILESDIR}"/wine-hangfix-bug2660.patch #98156
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/wine-20050310-upstream-colortable.patch #88715
- epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
diff --git a/app-emulation/wine/wine-20050419.ebuild b/app-emulation/wine/wine-20050419.ebuild
index ab40efb905cd..184bf59d23c6 100644
--- a/app-emulation/wine/wine-20050419.ebuild
+++ b/app-emulation/wine/wine-20050419.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.10 2005/08/23 01:13:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.11 2005/10/04 01:33:03 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -64,7 +64,8 @@ src_unpack() {
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
epatch "${FILESDIR}"/wine-hangfix-bug2660.patch #98156
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
diff --git a/app-emulation/wine/wine-20050524.ebuild b/app-emulation/wine/wine-20050524.ebuild
index 29d99a504914..56bb08eeeb57 100644
--- a/app-emulation/wine/wine-20050524.ebuild
+++ b/app-emulation/wine/wine-20050524.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.9 2005/08/23 01:13:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.10 2005/10/04 01:33:03 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -64,8 +64,9 @@ src_unpack() {
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
epatch "${FILESDIR}"/wine-hangfix-bug2660.patch #98156
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
epatch "${FILESDIR}"/wine-20050725-gcc-32bit.patch
+ epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
diff --git a/app-emulation/wine/wine-20050628.ebuild b/app-emulation/wine/wine-20050628.ebuild
index 988e74631c61..d3bb4da8f67d 100644
--- a/app-emulation/wine/wine-20050628.ebuild
+++ b/app-emulation/wine/wine-20050628.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050628.ebuild,v 1.4 2005/08/23 01:13:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050628.ebuild,v 1.5 2005/10/04 01:33:03 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -63,8 +63,9 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
epatch "${FILESDIR}"/wine-20050725-gcc-32bit.patch
+ epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
diff --git a/app-emulation/wine/wine-20050725-r1.ebuild b/app-emulation/wine/wine-20050725-r1.ebuild
index 42a9fefa10ef..c2c021ff0dfb 100644
--- a/app-emulation/wine/wine-20050725-r1.ebuild
+++ b/app-emulation/wine/wine-20050725-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050725-r1.ebuild,v 1.2 2005/09/01 23:28:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050725-r1.ebuild,v 1.3 2005/10/04 01:33:03 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -63,8 +63,10 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
epatch "${FILESDIR}"/wine-20050725-gcc-32bit.patch
+ epatch "${FILESDIR}"/wine-20050930-no-x.patch
+ epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
diff --git a/app-emulation/wine/wine-20050830.ebuild b/app-emulation/wine/wine-20050830.ebuild
index 70a3cdca8110..2605d3b68e65 100644
--- a/app-emulation/wine/wine-20050830.ebuild
+++ b/app-emulation/wine/wine-20050830.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050830.ebuild,v 1.1 2005/09/02 00:49:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050830.ebuild,v 1.2 2005/10/04 01:33:03 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -63,8 +63,10 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
epatch "${FILESDIR}"/wine-20050830-gcc-32bit.patch
+ epatch "${FILESDIR}"/wine-20050930-no-x.patch
+ epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
epatch "${FILESDIR}"/wine-20050830-no-ldap.patch
}
diff --git a/app-emulation/wine/wine-20050930.ebuild b/app-emulation/wine/wine-20050930.ebuild
index 672aaa1c84df..eb8e7068a312 100644
--- a/app-emulation/wine/wine-20050930.ebuild
+++ b/app-emulation/wine/wine-20050930.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050930.ebuild,v 1.2 2005/10/03 22:34:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050930.ebuild,v 1.3 2005/10/04 01:33:03 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -67,8 +67,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/20041019-no-stack.patch #66002
-# epatch "${FILESDIR}"/wine-20050830-gcc-32bit.patch
+ epatch "${FILESDIR}"/wine-20041019-no-stack.patch #66002
epatch "${FILESDIR}"/wine-20050930-no-x.patch
epatch "${FILESDIR}"/wine-20050930-dont-warn-lib-path.patch #107971
}