summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-06-06 10:10:00 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-06-06 10:10:00 +0000
commita93c67b850bec001db722c9b7fc7bdad60e728ac (patch)
treef77a2b2facad133b306ff9e5be7330b0fcddf3cf
parentstable on ppc64 (diff)
downloadgentoo-2-a93c67b850bec001db722c9b7fc7bdad60e728ac.tar.gz
gentoo-2-a93c67b850bec001db722c9b7fc7bdad60e728ac.tar.bz2
gentoo-2-a93c67b850bec001db722c9b7fc7bdad60e728ac.zip
clean the amd64 stank off. fix frontendonly. fix xv usage.
(Portage version: 2.0.51.22-r1)
-rw-r--r--media-tv/mythtv/ChangeLog6
-rw-r--r--media-tv/mythtv/mythtv-0.18.1-r1.ebuild16
-rw-r--r--media-tv/mythtv/mythtv-0.18.1-r2.ebuild18
3 files changed, 28 insertions, 12 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 7e3ecdae34aa..b975e6987ad5 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.67 2005/06/01 11:28:11 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.68 2005/06/06 10:10:00 cardoe Exp $
+
+ 06 Jun 2005; Doug Goldstein <cardoe@gentoo.org> mythtv-0.18.1-r1.ebuild,
+ mythtv-0.18.1-r2.ebuild:
+ clean the amd64 stank off. fix frontendonly. fix xv usage.
01 Jun 2005; Herbie Hopkins <herbs@gentoo.org>
+files/mythtv-0.18.1-x86_64-configure.patch, mythtv-0.18.1-r2.ebuild:
diff --git a/media-tv/mythtv/mythtv-0.18.1-r1.ebuild b/media-tv/mythtv/mythtv-0.18.1-r1.ebuild
index bb828b80c0a3..dbc38e6d5cff 100644
--- a/media-tv/mythtv/mythtv-0.18.1-r1.ebuild
+++ b/media-tv/mythtv/mythtv-0.18.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18.1-r1.ebuild,v 1.5 2005/06/01 00:39:10 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18.1-r1.ebuild,v 1.6 2005/06/06 10:10:00 cardoe Exp $
inherit flag-o-matic eutils debug
@@ -11,7 +11,7 @@ SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~amd64"
-IUSE="alsa altivec arts debug dvb frontendonly jack joystick lcd lirc mmx nvidia oggvorbis opengl oss unichrome xv"
+IUSE="alsa altivec arts debug dvb frontendonly jack joystick lcd lirc mmx nvidia oggvorbis opengl oss unichrome"
DEPEND=">=media-libs/freetype-2.0
>=media-sound/lame-3.93.1
@@ -39,6 +39,12 @@ pkg_setup() {
die "Qt needs MySQL support"
fi
+ if ! built_with_use x11-base/xorg-x11 xv; then
+ eerror "xorg-x11 is missing XV support. Please add"
+ eerror "'xv' to your USE flags, and re-emerge xorg-x11."
+ die "xorg-x11 needs XV support"
+ fi
+
if use nvidia; then
echo
ewarn "You enabled the 'nvidia' USE flag, you must have a GeForce 4 or"
@@ -82,7 +88,7 @@ src_compile() {
$(use_enable opengl opengl-vsync)
$(use_enable oggvorbis vorbis)
$(use_enable nvidia xvmc)
- $(use_enable xv)
+ --enable-xv
--disable-firewire
--disable-directfb
--enable-x11
@@ -126,8 +132,8 @@ src_compile() {
if use frontendonly; then
##Backend Removal
cd ${S}
- sed -e "s:CONFIG += linux backend:CONFIG += linux:" \
- -i 'settings.pro' || die "Removal of mythbackend failed"
+ sed -e "s:CCONFIG linux backend:CCONFIG linux:" \
+ -i 'configure' || die "Removal of mythbackend failed"
fi
# let MythTV come up with our CFLAGS. Upstream will support this
diff --git a/media-tv/mythtv/mythtv-0.18.1-r2.ebuild b/media-tv/mythtv/mythtv-0.18.1-r2.ebuild
index bd394f6f320f..3ea158330cbc 100644
--- a/media-tv/mythtv/mythtv-0.18.1-r2.ebuild
+++ b/media-tv/mythtv/mythtv-0.18.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18.1-r2.ebuild,v 1.3 2005/06/01 11:28:11 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18.1-r2.ebuild,v 1.4 2005/06/06 10:10:00 cardoe Exp $
inherit flag-o-matic eutils debug
@@ -11,7 +11,7 @@ SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alsa altivec arts debug dvb frontendonly ieee1394 jack joystick lcd lirc mmx nvidia oggvorbis opengl oss unichrome xv"
+IUSE="alsa altivec arts debug dvb frontendonly ieee1394 jack joystick lcd lirc mmx nvidia oggvorbis opengl oss unichrome"
DEPEND=">=media-libs/freetype-2.0
>=media-sound/lame-3.93.1
@@ -41,6 +41,12 @@ pkg_setup() {
die "Qt needs MySQL support"
fi
+ if ! built_with_use x11-base/xorg-x11 xv; then
+ eerror "xorg-x11 is missing XV support. Please add"
+ eerror "'xv' to your USE flags, and re-emerge xorg-x11."
+ die "xorg-x11 needs XV support"
+ fi
+
if use nvidia; then
echo
ewarn "You enabled the 'nvidia' USE flag, you must have a GeForce 4 or"
@@ -63,7 +69,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}-opengl-fix.patch
# Add support for amd64 --arch options, bug 94664
- use amd64 && epatch ${FILESDIR}/${P}-x86_64-configure.patch
+ epatch ${FILESDIR}/${P}-x86_64-configure.patch
if [ $(get_libdir) != "lib" ] ; then
sed -i -e "s:\$\${PREFIX}/lib/:\$\${PREFIX}/$(get_libdir)/:g" \
@@ -94,7 +100,7 @@ src_compile() {
$(use_enable opengl opengl-vsync)
$(use_enable oggvorbis vorbis)
$(use_enable nvidia xvmc)
- $(use_enable xv)
+ --enable-xv
$(use_enable ieee1394 firewire)
--disable-directfb
--enable-x11
@@ -138,8 +144,8 @@ src_compile() {
if use frontendonly; then
##Backend Removal
cd ${S}
- sed -e "s:CONFIG += linux backend:CONFIG += linux:" \
- -i 'settings.pro' || die "Removal of mythbackend failed"
+ sed -e "s:CCONFIG linux backend:CCONFIG linux:" \
+ -i 'configure' || die "Removal of mythbackend failed"
fi
# let MythTV come up with our CFLAGS. Upstream will support this