summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 21:47:29 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 21:47:29 +0000
commitac946f05d4b6e6cad626a549f1feafafd77b8305 (patch)
treeb5f69937e76d50792180367910f0b48dbe594859
parentcolord now has subslots (diff)
downloadgentoo-2-ac946f05d4b6e6cad626a549f1feafafd77b8305.tar.gz
gentoo-2-ac946f05d4b6e6cad626a549f1feafafd77b8305.tar.bz2
gentoo-2-ac946f05d4b6e6cad626a549f1feafafd77b8305.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
-rw-r--r--sys-libs/libosinfo/ChangeLog7
-rw-r--r--sys-libs/libosinfo/libosinfo-0.2.10.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-libs/libosinfo/ChangeLog b/sys-libs/libosinfo/ChangeLog
index e69bc2e99788..004cf317ac3e 100644
--- a/sys-libs/libosinfo/ChangeLog
+++ b/sys-libs/libosinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libosinfo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/ChangeLog,v 1.31 2014/04/27 09:10:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/ChangeLog,v 1.32 2014/04/27 21:47:29 eva Exp $
+
+*libosinfo-0.2.10 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +libosinfo-0.2.10.ebuild:
+ Version bump for Gnome 3.12.
27 Apr 2014; Pacho Ramos <pacho@gentoo.org> -libosinfo-0.2.6.ebuild:
drop old
diff --git a/sys-libs/libosinfo/libosinfo-0.2.10.ebuild b/sys-libs/libosinfo/libosinfo-0.2.10.ebuild
new file mode 100644
index 000000000000..103efa38670d
--- /dev/null
+++ b/sys-libs/libosinfo/libosinfo-0.2.10.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/libosinfo-0.2.10.ebuild,v 1.1 2014/04/27 21:47:29 eva Exp $
+
+EAPI=5
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
+
+inherit udev vala
+
+DESCRIPTION="GObject library for managing information about real and virtual OSes"
+HOMEPAGE="http://fedorahosted.org/libosinfo/"
+SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+IUSE="+introspection +vala test"
+REQUIRED_USE="vala? ( introspection )"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2:2
+ >=dev-libs/libxslt-1.0.0:=
+ dev-libs/libxml2:=
+ net-libs/libsoup-gnome:2.4
+ sys-apps/hwids
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ >=dev-util/gtk-doc-am-1.10
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ # --enable-udev is only for rules.d file install
+ econf \
+ --disable-static \
+ --disable-gtk-doc \
+ $(use_enable test tests) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ --enable-udev \
+ --disable-coverage \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ --with-udev-rulesdir="$(get_udevdir)"/rules.d \
+ --with-usb-ids-path=/usr/share/misc/usb.ids \
+ --with-pci-ids-path=/usr/share/misc/pci.ids
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}