summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-01-27 22:46:43 +0000
committerHanno Böck <hanno@gentoo.org>2011-01-27 22:46:43 +0000
commitb8c39c5166da65a02e839e8369a687cb830ee44d (patch)
tree98d91cef1336dedce9dc0bdbec60766727756e3d
parentsoundconverter bump (diff)
downloadgentoo-2-b8c39c5166da65a02e839e8369a687cb830ee44d.tar.gz
gentoo-2-b8c39c5166da65a02e839e8369a687cb830ee44d.tar.bz2
gentoo-2-b8c39c5166da65a02e839e8369a687cb830ee44d.zip
scribus bump
(Portage version: 2.1.9.35/cvs/Linux x86_64)
-rw-r--r--app-office/scribus/ChangeLog9
-rw-r--r--app-office/scribus/scribus-1.3.9.ebuild79
2 files changed, 86 insertions, 2 deletions
diff --git a/app-office/scribus/ChangeLog b/app-office/scribus/ChangeLog
index c605c293b8c3..30df185119a6 100644
--- a/app-office/scribus/ChangeLog
+++ b/app-office/scribus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/scribus
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.137 2010/11/08 13:00:32 nelchael Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.138 2011/01/27 22:46:43 hanno Exp $
+
+*scribus-1.3.9 (27 Jan 2011)
+
+ 27 Jan 2011; Hanno Boeck <hanno@gentoo.org> +scribus-1.3.9.ebuild:
+ Version bump.
08 Nov 2010; Krzysztof Pawlik <nelchael@gentoo.org> scribus-1.3.6.ebuild,
scribus-1.3.8.ebuild:
diff --git a/app-office/scribus/scribus-1.3.9.ebuild b/app-office/scribus/scribus-1.3.9.ebuild
new file mode 100644
index 000000000000..95b12de2f6fc
--- /dev/null
+++ b/app-office/scribus/scribus-1.3.9.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-1.3.9.ebuild,v 1.1 2011/01/27 22:46:43 hanno Exp $
+
+EAPI=2
+PYTHON_DEPEND="2:2.6"
+
+inherit cmake-utils fdo-mime multilib python
+
+DESCRIPTION="Desktop publishing (DTP) and layout program"
+HOMEPAGE="http://www.scribus.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cairo debug +minimal +pdf spell"
+
+COMMON_DEPEND="
+ dev-libs/hyphen
+ dev-libs/libxml2
+ media-libs/fontconfig
+ >=media-libs/freetype-2
+ virtual/jpeg
+ =media-libs/lcms-1*
+ media-libs/libpng
+ media-libs/tiff
+ net-print/cups
+ sys-libs/zlib
+ x11-libs/qt-gui:4
+ spell? ( app-text/aspell )
+ pdf? ( app-text/podofo )
+ cairo? ( x11-libs/cairo[X,svg] )"
+RDEPEND="${COMMON_DEPEND}
+ app-text/ghostscript-gpl"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.5.1-system-hyphen.patch"
+ )
+
+DOCS="AUTHORS ChangeLog* LINKS NEWS README TODO TRANSLATION"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DHAVE_PYTHON=ON"
+ "-DPYTHON_INCLUDE_PATH=$(python_get_includedir)"
+ "-DPYTHON_LIBRARY=$(python_get_library)"
+ "-DWANT_NORPATH=ON"
+ "-DWANT_QTARTHUR=ON"
+ "-DWANT_QT3SUPPORT=OFF"
+ $(cmake-utils_use_has spell ASPELL)
+ $(cmake-utils_use_has pdf PODOFO)
+ $(cmake-utils_use_want cairo)
+ $(cmake-utils_use_want minimal NOHEADERINSTALL)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ doicon resources/icons/scribus.png
+ domenu scribus.desktop
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}