summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2004-04-27 03:24:35 +0000
committerTom Gall <tgall@gentoo.org>2004-04-27 03:24:35 +0000
commitb9e6c5922db3ba0b634b7a50510955dbaae28b38 (patch)
tree39e19ab45c5792d361b4a802c130bb05cb8b3143
parentheader fix (Manifest recommit) (diff)
downloadgentoo-2-b9e6c5922db3ba0b634b7a50510955dbaae28b38.tar.gz
gentoo-2-b9e6c5922db3ba0b634b7a50510955dbaae28b38.tar.bz2
gentoo-2-b9e6c5922db3ba0b634b7a50510955dbaae28b38.zip
fix bug 49111 (ppc64, ppc)
-rw-r--r--sys-devel/gcc/ChangeLog5
-rw-r--r--sys-devel/gcc/gcc-3.4.0.ebuild4
2 files changed, 5 insertions, 4 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index c8510b2505c1..f31e8ca4ceca 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.219 2004/04/26 19:40:03 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.220 2004/04/27 03:24:35 tgall Exp $
+
+ 26 Apr 2004; Tom Gall <tgall@gentoo.org> gcc-3.4.0.ebuild:
+ fix bug 49111, appears to work quite well on ppc64
26 Apr 2004; Travis Tilley <lv@gentoo.org> gcc-3.4.0.ebuild:
fix bug where the ebuild tries to nuke libiberty from outside the sandbox
diff --git a/sys-devel/gcc/gcc-3.4.0.ebuild b/sys-devel/gcc/gcc-3.4.0.ebuild
index 4b73edf0ed98..2757e2b06f08 100644
--- a/sys-devel/gcc/gcc-3.4.0.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.6 2004/04/27 02:28:01 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.7 2004/04/27 03:24:35 tgall Exp $
IUSE="static nls bootstrap java build X multilib gcj hardened f77 objc uclibc"
@@ -386,11 +386,9 @@ src_compile() {
# Default arch support
use amd64 && myconf="${myconf} --with-cpu=k8 --with-arch=k8"
- #use ppc64 && myconf="${myconf} --with-arch=powerpc64"
#use s390 && myconf="${myconf} --with-arch=nofreakingclue"
use x86 && myconf="${myconf} --with-cpu=pentium4 --with-arch=i586"
#use mips && myconf="${myconf} --with-arch=mips3"
- #use ppc && myconf="${myconf} --with-arch=g3"
# In general gcc does not like optimization, and add -O2 where
# it is safe. This is especially true for gcc 3.3 + 3.4