summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-24 05:13:00 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-24 05:13:00 +0000
commitba5445f1f563035b3f4cf86f6603ab317ad1225e (patch)
treec70014c9d43bce57fd3db226015aedd755ec5488
parentquick description fix (diff)
downloadgentoo-2-ba5445f1f563035b3f4cf86f6603ab317ad1225e.tar.gz
gentoo-2-ba5445f1f563035b3f4cf86f6603ab317ad1225e.tar.bz2
gentoo-2-ba5445f1f563035b3f4cf86f6603ab317ad1225e.zip
version bump
-rw-r--r--net-misc/hylafax/ChangeLog13
-rw-r--r--net-misc/hylafax/files/digest-hylafax-000614-r11
-rw-r--r--net-misc/hylafax/files/digest-hylafax-4.1.22
-rw-r--r--net-misc/hylafax/files/hylafax-4.1.2-gentoo-diffs.tar.bz2bin0 -> 3605 bytes
-rw-r--r--net-misc/hylafax/hylafax-4.1.2.ebuild92
5 files changed, 107 insertions, 1 deletions
diff --git a/net-misc/hylafax/ChangeLog b/net-misc/hylafax/ChangeLog
index 597099a2c149..049964c1dd3c 100644
--- a/net-misc/hylafax/ChangeLog
+++ b/net-misc/hylafax/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-misc/hylafax
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.1 2002/02/01 21:53:35 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.2 2002/04/24 05:13:00 seemant Exp $
+
+*hylafax-4.1.2 (23 Apr 2002)
+
+ 22 Apr 2002; Seemant Kulleen <seemant@gentoo.org> hylafax-4.1.2.ebuild
+ files/hylafax-4.1.2-gentoo-diffs.tar.bz2 files/digest-hylafax-4.1.2 :
+
+ Updated to newest stable release. This is a pain to build because it requires
+ a lower GNU/sed version than we have in portage. So, GNU/sed-3.02 is fetched
+ and built statically, so that it can be used to configure hylafax. The
+ other patches are taken from Mandrake's srpm for 4.1.1, but seems to work well
+ with this.
*hylafax-cvs-000614-r1 (1 Feb 2002)
diff --git a/net-misc/hylafax/files/digest-hylafax-000614-r1 b/net-misc/hylafax/files/digest-hylafax-000614-r1
new file mode 100644
index 000000000000..82e0698edc19
--- /dev/null
+++ b/net-misc/hylafax/files/digest-hylafax-000614-r1
@@ -0,0 +1 @@
+MD5 d69c311c00d2959bb1adedb0cb6a2324 hylafax-cvs-000614.tar.bz2 1114036
diff --git a/net-misc/hylafax/files/digest-hylafax-4.1.2 b/net-misc/hylafax/files/digest-hylafax-4.1.2
new file mode 100644
index 000000000000..ceaf6513eeeb
--- /dev/null
+++ b/net-misc/hylafax/files/digest-hylafax-4.1.2
@@ -0,0 +1,2 @@
+MD5 b10225bbbda1f02c07258621d0ceb819 hylafax-4.1.2.tar.gz 1259364
+MD5 74db866f052b47fa8ec1c2b8f967bc69 sed-3.02.tar.gz 264236
diff --git a/net-misc/hylafax/files/hylafax-4.1.2-gentoo-diffs.tar.bz2 b/net-misc/hylafax/files/hylafax-4.1.2-gentoo-diffs.tar.bz2
new file mode 100644
index 000000000000..a50adbd3467f
--- /dev/null
+++ b/net-misc/hylafax/files/hylafax-4.1.2-gentoo-diffs.tar.bz2
Binary files differ
diff --git a/net-misc/hylafax/hylafax-4.1.2.ebuild b/net-misc/hylafax/hylafax-4.1.2.ebuild
new file mode 100644
index 000000000000..d8fa7854edde
--- /dev/null
+++ b/net-misc/hylafax/hylafax-4.1.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.1.2.ebuild,v 1.1 2002/04/24 05:13:00 seemant Exp $
+
+S=${WORKDIR}/${P}
+MYSED=sed-3.02
+PATCHES=${WORKDIR}/patches
+DESCRIPTION="Fax package for class 1 and 2 fax modems."
+SRC_URI="ftp://ftp.hylafax.org/source/${P}.tar.gz SRC_URI=ftp://alpha.gnu.org/pub/gnu/sed/${MYSED}.tar.gz"
+HOMEPAGE="http://www.hylafax.org"
+
+DEPEND="net-dialup/mgetty
+ sys-libs/zlib
+ app-text/ghostscript
+ media-libs/tiff
+ jpeg? ( media-libs/jpeg )"
+
+src_unpack() {
+
+ unpack ${MYSED}.tar.gz
+ unpack ${P}.tar.gz
+ mkdir patches
+ cd patches
+ tar jxvf ${FILESDIR}/${P}-gentoo-diffs.tar.bz2
+ cd ${S}
+ patch -p1 < ${PATCHES}/${P}-dso.chris.patch
+ patch -p1 < ${PATCHES}/${P}-shlib-pic.chris.patch
+ patch -p1 < ${PATCHES}/${P}-gentoo.patch
+ patch -p1 < ${PATCHES}/${P}-topmargin.patch
+
+}
+
+src_compile() {
+
+ # first compile the sed-3.02 release which is what hylafax's compile process
+ # knows about
+ cd ${WORKDIR}/${MYSED}
+ ./configure --disable-nls --prefix=/usr || die
+ emake LDFLAGS=-static || die
+
+ # now, patch the configure script to call the static sed-3.02 instead of
+ # the system sed
+ cd ${S}
+ cp configure configure.orig
+ sed "s:sed :${WORKDIR}/${MYSED}/sed/sed :g" configure.orig > configure
+
+
+ ./configure \
+ --with-DIR_BIN=/usr/bin \
+ --with-DIR_SBIN=/usr/sbin \
+ --with-DIR_LIB=/usr/lib \
+ --with-DIR_LIBEXEC=/usr/sbin \
+ --with-DIR_LIBDATA=/usr/lib/fax \
+ --with-DIR_LOCKS=/var/lock \
+ --with-DIR_MAN=/usr/share/man \
+ --with-DIR_SPOOL=/var/spool/fax \
+ --with-AFM=no \
+ --with-AWK=/usr/bin/gawk \
+ --with-PATH_VGETTY=/sbin/vgetty \
+ --with-PATH_GETTY=/sbin/agetty \
+ --with-HTML=no \
+ --with-PATH_DPSRIP=/var/spool/fax/bin/ps2fax \
+ --with-PATH_IMPRIP=/usr/share/fax/psrip \
+ --with-SYSVINIT=/etc/init.d \
+ --with-INTERACTIVE=no || die
+
+ make \
+ OPTIMIZER="${CFLAGS}" || die
+}
+
+src_install() {
+
+ dodir /usr/{bin,sbin} /usr/lib/fax /usr/share/man /var/spool/fax
+
+ make \
+ BIN=${D}/usr/bin \
+ SBIN=${D}/usr/sbin \
+ LIBDIR=${D}/usr/lib \
+ LIB=${D}/usr/lib \
+ LIBEXEC=${D}/usr/sbin \
+ LIBDATA=${D}/usr/lib/fax \
+ MAN=${D}/usr/share/man \
+ SPOOL=${D}/var/spool/fax \
+ install || die
+
+ insinto /etc/init.d
+ doins etc/hylafax
+
+ dodoc COPYRIGHT README TODO VERSION
+ dohtml -r .
+}