summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-02-18 18:30:21 +0000
committerDon Seiler <rizzo@gentoo.org>2005-02-18 18:30:21 +0000
commitbfa320eef3c5b670d13934917cb9c3429812c0b8 (patch)
tree4c2c8325da20b121b2ef0b182aa6f0261793fcc4
parentStable on mips, bug #82450 (diff)
downloadgentoo-2-bfa320eef3c5b670d13934917cb9c3429812c0b8.tar.gz
gentoo-2-bfa320eef3c5b670d13934917cb9c3429812c0b8.tar.bz2
gentoo-2-bfa320eef3c5b670d13934917cb9c3429812c0b8.zip
Patch to remove some extraneous printf() lines. Closes bug #82118, thanks Manuel Sabban.
(Portage version: 2.0.51.16)
-rw-r--r--x11-plugins/gaimosd/ChangeLog8
-rw-r--r--x11-plugins/gaimosd/files/gaimosd-quiet.diff31
-rw-r--r--x11-plugins/gaimosd/gaimosd-1.0.0.ebuild10
3 files changed, 45 insertions, 4 deletions
diff --git a/x11-plugins/gaimosd/ChangeLog b/x11-plugins/gaimosd/ChangeLog
index 0839183fddae..70f0ca72443b 100644
--- a/x11-plugins/gaimosd/ChangeLog
+++ b/x11-plugins/gaimosd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/gaimosd
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaimosd/ChangeLog,v 1.3 2004/12/14 03:53:34 eradicator Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaimosd/ChangeLog,v 1.4 2005/02/18 18:30:21 rizzo Exp $
+
+ 18 Feb 2005; Don Seiler <rizzo@gentoo.org> gaimosd-1.0.0.ebuild:
+ Patch to remove some extraneous printf() lines. Closes bug #82118, thanks
+ Manuel Sabban.
13 Dec 2004; Jeremy Huddleston <eradicator@gentoo.org>
gaimosd-1.0.0.ebuild:
diff --git a/x11-plugins/gaimosd/files/gaimosd-quiet.diff b/x11-plugins/gaimosd/files/gaimosd-quiet.diff
new file mode 100644
index 000000000000..682a3aedbd83
--- /dev/null
+++ b/x11-plugins/gaimosd/files/gaimosd-quiet.diff
@@ -0,0 +1,31 @@
+diff -ruN old/gaimosd-1.0.0/display.c new/gaimosd-1.0.0/display.c
+--- old/gaimosd-1.0.0/display.c 2004-09-20 08:08:44.000000000 +0200
++++ new/gaimosd-1.0.0/display.c 2005-02-15 16:32:25.349400000 +0100
+@@ -65,11 +65,9 @@
+ gboolean
+ osd_display_cb(osd_display_t *disp)
+ {
+- printf("bar 1\n");
+ if (!disp)
+ return FALSE;
+
+- printf("bar 2\n");
+ if (disp->lines > -Osd_lines) {
+ disp->lines--;
+ XOSD_SCROLL(Osd, 1);
+@@ -82,7 +80,6 @@
+ return TRUE;
+ }
+
+- printf("bar 3\n");
+ XOSD_HIDE(Osd);
+ XOSD_SCROLL(Osd, Osd_lines);
+ Osd_current = NULL;
+@@ -328,7 +325,6 @@
+ XOSD_SET_COLOUR(Osd, color);
+ XOSD_SET_TIMEOUT(Osd, -1);
+
+- printf("foo 1\n");
+ for (i = 0; i < Osd_lines; i++) {
+ if (!slist)
+ break;
diff --git a/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild b/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild
index 4f3abba6df4c..7f04016c5cc8 100644
--- a/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild
+++ b/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild,v 1.4 2004/12/14 03:53:34 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild,v 1.5 2005/02/18 18:30:21 rizzo Exp $
inherit eutils
@@ -16,6 +16,12 @@ KEYWORDS="~amd64 ~x86 ~ppc"
DEPEND=">=net-im/gaim-1.0.0
x11-libs/xosd"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gaimosd-quiet.diff
+}
+
src_compile() {
econf --enable-customized-buddies --enable-customized-conversations || die
emake || die "emake failed"