summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-05-03 06:08:01 +0000
committerJeroen Roovers <jer@gentoo.org>2015-05-03 06:08:01 +0000
commitc11715e693c4fe3199aab8f653e3ec82dcc1f597 (patch)
treec833cc209714f4a718635e21e4ec3bb70ec010fd
parentremoved sys-firmware/iwl7265-ucode from package.mask (diff)
downloadgentoo-2-c11715e693c4fe3199aab8f653e3ec82dcc1f597.tar.gz
gentoo-2-c11715e693c4fe3199aab8f653e3ec82dcc1f597.tar.bz2
gentoo-2-c11715e693c4fe3199aab8f653e3ec82dcc1f597.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A792A613)
-rw-r--r--dev-util/debhelper/ChangeLog7
-rw-r--r--dev-util/debhelper/debhelper-9.20150502.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-util/debhelper/ChangeLog b/dev-util/debhelper/ChangeLog
index ecb607872c33..b4dbe3759fca 100644
--- a/dev-util/debhelper/ChangeLog
+++ b/dev-util/debhelper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/debhelper
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/ChangeLog,v 1.126 2015/03/10 10:13:57 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/ChangeLog,v 1.127 2015/05/03 06:08:01 jer Exp $
+
+*debhelper-9.20150502 (03 May 2015)
+
+ 03 May 2015; Jeroen Roovers <jer@gentoo.org> +debhelper-9.20150502.ebuild:
+ Version bump.
10 Mar 2015; Jeroen Roovers <jer@gentoo.org> -debhelper-9.20130630.ebuild,
-debhelper-9.20140228.ebuild, -debhelper-9.20141107.ebuild,
diff --git a/dev-util/debhelper/debhelper-9.20150502.ebuild b/dev-util/debhelper/debhelper-9.20150502.ebuild
new file mode 100644
index 000000000000..9a12872e788f
--- /dev/null
+++ b/dev-util/debhelper/debhelper-9.20150502.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/debhelper-9.20150502.ebuild,v 1.1 2015/05/03 06:08:01 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Collection of programs that can be used to automate common tasks in debian/rules"
+HOMEPAGE="http://packages.qa.debian.org/d/debhelper.html http://joeyh.name/code/debhelper/"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+DH_LINGUAS=( de es fr )
+IUSE+=" ${DH_LINGUAS[@]/#/linguas_}"
+
+NLS_DEPEND=$(
+ printf "linguas_%s? ( >=app-text/po4a-0.24 )\n" ${DH_LINGUAS[@]}
+)
+
+RDEPEND="
+ >=dev-lang/perl-5.10:=
+ >=app-arch/dpkg-1.17
+ dev-perl/TimeDate
+ virtual/perl-Getopt-Long
+"
+DEPEND="${RDEPEND}
+ ${NLS_DEPEND}
+ test? ( dev-perl/Test-Pod )
+"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ tc-export CC
+
+ local LANGS="" USE_NLS=no lingua
+ for lingua in ${DH_LINGUAS[@]}; do
+ if use linguas_${lingua}; then
+ LANGS+=" ${lingua}"
+ USE_NLS=yes
+ fi
+ done
+
+ emake USE_NLS="${USE_NLS}" LANGS="${LANGS}" build
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc doc/* debian/changelog
+ docinto examples
+ dodoc examples/*
+ local lingua
+ for manfile in *.1 *.7 ; do
+ for lingua in ${DH_LINGUAS[@]}; do
+ case ${manfile} in
+ *.${lingua}.?)
+ use linguas_${lingua} \
+ && cp ${manfile} "${T}"/${manfile/.${lingua}/} \
+ && doman -i18n=${lingua} "${T}"/${manfile/.${lingua}/}
+ ;;
+ *)
+ doman ${manfile}
+ ;;
+ esac
+ done
+ done
+}