summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-12-31 15:19:02 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-12-31 15:19:02 +0000
commitc2b9cbadaaeb209791fca04fd8f2afdf8e94be15 (patch)
treefb90d3da181a375f1265a016aae4a291ef3e298e
parentVersion bump. (diff)
downloadgentoo-2-c2b9cbadaaeb209791fca04fd8f2afdf8e94be15.tar.gz
gentoo-2-c2b9cbadaaeb209791fca04fd8f2afdf8e94be15.tar.bz2
gentoo-2-c2b9cbadaaeb209791fca04fd8f2afdf8e94be15.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
-rw-r--r--dev-util/cloc/ChangeLog7
-rw-r--r--dev-util/cloc/cloc-1.62.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-util/cloc/ChangeLog b/dev-util/cloc/ChangeLog
index 7825658cea56..d48ec259b430 100644
--- a/dev-util/cloc/ChangeLog
+++ b/dev-util/cloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cloc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cloc/ChangeLog,v 1.13 2014/06/03 11:04:47 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cloc/ChangeLog,v 1.14 2014/12/31 15:19:02 kensington Exp $
+
+*cloc-1.62 (31 Dec 2014)
+
+ 31 Dec 2014; Michael Palimaka <kensington@gentoo.org> +cloc-1.62.ebuild:
+ Version bump.
03 Jun 2014; Chema Alonso <nimiux@gentoo.org> cloc-1.60.ebuild:
Stable for amd64 wrt bug #508384
diff --git a/dev-util/cloc/cloc-1.62.ebuild b/dev-util/cloc/cloc-1.62.ebuild
new file mode 100644
index 000000000000..40402ea09588
--- /dev/null
+++ b/dev-util/cloc/cloc-1.62.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cloc/cloc-1.62.ebuild,v 1.1 2014/12/31 15:19:02 kensington Exp $
+
+EAPI=5
+
+DESCRIPTION="Count Lines of Code"
+HOMEPAGE="http://cloc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.pl mirror://sourceforge/${PN}/${PN}.1.pod"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND=">=dev-lang/perl-5.6"
+RDEPEND="${DEPEND}
+ dev-perl/Algorithm-Diff
+ dev-perl/regexp-common
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp"
+
+S=${WORKDIR}
+
+src_unpack() { :; }
+
+src_prepare() {
+ pod2man "${DISTDIR}"/${PN}.1.pod > ${PN}.1 || die
+}
+
+src_install() {
+ doman ${PN}.1
+ newbin "${DISTDIR}"/${P}.pl ${PN}
+}