summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2012-12-11 17:01:02 +0000
committerIan Stakenvicius <axs@gentoo.org>2012-12-11 17:01:02 +0000
commitc8160dbecdb5197bf8226d955303ba67d0847082 (patch)
treea63f03bd2ac57300b19ef6800fa3c8cd22f252e7
parentvirtualize udev dependency (diff)
downloadgentoo-2-c8160dbecdb5197bf8226d955303ba67d0847082.tar.gz
gentoo-2-c8160dbecdb5197bf8226d955303ba67d0847082.tar.bz2
gentoo-2-c8160dbecdb5197bf8226d955303ba67d0847082.zip
virtualize udev dependency, get udevdir via udev.eclass
(Portage version: 2.1.11.33/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
-rw-r--r--net-print/hplip/ChangeLog6
-rw-r--r--net-print/hplip/hplip-3.12.10a-r1.ebuild9
-rw-r--r--net-print/hplip/hplip-3.12.10a.ebuild9
-rw-r--r--net-print/hplip/hplip-3.12.11.ebuild9
-rw-r--r--net-print/hplip/hplip-3.12.9-r1.ebuild9
5 files changed, 21 insertions, 21 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index 37b049ac8619..8f1757bae7e6 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.255 2012/11/30 15:47:05 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.256 2012/12/11 17:01:02 axs Exp $
+
+ 11 Dec 2012; Ian Stakenvicius <axs@gentoo.org> hplip-3.12.9-r1.ebuild,
+ hplip-3.12.10a.ebuild, hplip-3.12.10a-r1.ebuild, hplip-3.12.11.ebuild:
+ virtualize udev dependency, get udevdir via udev.eclass
*hplip-3.12.11 (30 Nov 2012)
diff --git a/net-print/hplip/hplip-3.12.10a-r1.ebuild b/net-print/hplip/hplip-3.12.10a-r1.ebuild
index 51a7373c327f..b92b22dc3c4b 100644
--- a/net-print/hplip/hplip-3.12.10a-r1.ebuild
+++ b/net-print/hplip/hplip-3.12.10a-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.10a-r1.ebuild,v 1.1 2012/11/18 12:13:48 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.10a-r1.ebuild,v 1.2 2012/12/11 17:01:02 axs Exp $
EAPI=4
@@ -8,7 +8,7 @@ PYTHON_DEPEND="!minimal? 2"
PYTHON_USE_WITH="threads xml"
PYTHON_USE_WITH_OPT="!minimal"
-inherit eutils fdo-mime linux-info python autotools toolchain-funcs
+inherit eutils fdo-mime linux-info python udev autotools toolchain-funcs
DESCRIPTION="HP Linux Imaging and Printing. Includes printer, scanner, fax drivers and service tools."
HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
@@ -49,7 +49,7 @@ RDEPEND="${COMMON_DEPEND}
)
!minimal? (
dev-python/pygobject:2
- kernel_linux? ( >=sys-fs/udev-114 )
+ kernel_linux? ( virtual/udev !<sys-fs/udev-114 )
scanner? (
dev-python/imaging
X? ( || (
@@ -117,8 +117,7 @@ src_prepare() {
# Fix for Gentoo bug https://bugs.gentoo.org/show_bug.cgi?id=345725
# Upstream bug: https://bugs.launchpad.net/hplip/+bug/880847,
# https://bugs.launchpad.net/hplip/+bug/500086
- local udevdir=/lib/udev
- has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ local udevdir="$(udev_get_udevdir)"
sed -i -e "s|/etc/udev|${udevdir}|g" \
$(find . -type f -exec grep -l /etc/udev {} +) || die
diff --git a/net-print/hplip/hplip-3.12.10a.ebuild b/net-print/hplip/hplip-3.12.10a.ebuild
index 2b3b8758007d..33a6ac56cc36 100644
--- a/net-print/hplip/hplip-3.12.10a.ebuild
+++ b/net-print/hplip/hplip-3.12.10a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.10a.ebuild,v 1.8 2012/11/28 20:20:27 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.10a.ebuild,v 1.9 2012/12/11 17:01:02 axs Exp $
EAPI=4
@@ -8,7 +8,7 @@ PYTHON_DEPEND="!minimal? 2"
PYTHON_USE_WITH="threads xml"
PYTHON_USE_WITH_OPT="!minimal"
-inherit eutils fdo-mime linux-info python autotools toolchain-funcs
+inherit eutils fdo-mime linux-info python udev autotools toolchain-funcs
DESCRIPTION="HP Linux Imaging and Printing. Includes printer, scanner, fax drivers and service tools."
HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
@@ -49,7 +49,7 @@ RDEPEND="${COMMON_DEPEND}
)
!minimal? (
dev-python/pygobject:2
- kernel_linux? ( >=sys-fs/udev-114 )
+ kernel_linux? ( virtual/udev !<sys-fs/udev-114 )
scanner? (
dev-python/imaging
X? ( || (
@@ -106,8 +106,7 @@ src_prepare() {
epatch "${WORKDIR}"
# Fix for Gentoo bug #345725
- local udevdir=/lib/udev
- has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ local udevdir=$(udev_get_udevdir)
sed -i -e "s|/etc/udev|${udevdir}|g" \
$(find . -type f -exec grep -l /etc/udev {} +) || die
diff --git a/net-print/hplip/hplip-3.12.11.ebuild b/net-print/hplip/hplip-3.12.11.ebuild
index d196238c230a..edb322d6c603 100644
--- a/net-print/hplip/hplip-3.12.11.ebuild
+++ b/net-print/hplip/hplip-3.12.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.11.ebuild,v 1.1 2012/11/30 15:47:05 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.11.ebuild,v 1.2 2012/12/11 17:01:02 axs Exp $
EAPI=5
@@ -8,7 +8,7 @@ PYTHON_DEPEND="!minimal? 2"
PYTHON_USE_WITH="threads xml"
PYTHON_USE_WITH_OPT="!minimal"
-inherit eutils fdo-mime linux-info python autotools toolchain-funcs
+inherit eutils fdo-mime linux-info python udev autotools toolchain-funcs
DESCRIPTION="HP Linux Imaging and Printing. Includes printer, scanner, fax drivers and service tools."
HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
@@ -49,7 +49,7 @@ RDEPEND="${COMMON_DEPEND}
)
!minimal? (
dev-python/pygobject:2
- kernel_linux? ( >=sys-fs/udev-114 )
+ kernel_linux? ( virtual/udev !<sys-fs/udev-114 )
scanner? (
dev-python/imaging
X? ( || (
@@ -117,8 +117,7 @@ src_prepare() {
# Fix for Gentoo bug https://bugs.gentoo.org/show_bug.cgi?id=345725
# Upstream bug: https://bugs.launchpad.net/hplip/+bug/880847,
# https://bugs.launchpad.net/hplip/+bug/500086
- local udevdir=/lib/udev
- has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ local udevdir=$(udev_get_udevdir)
sed -i -e "s|/etc/udev|${udevdir}|g" \
$(find . -type f -exec grep -l /etc/udev {} +) || die
diff --git a/net-print/hplip/hplip-3.12.9-r1.ebuild b/net-print/hplip/hplip-3.12.9-r1.ebuild
index 2cfb5c5a8bb5..ff98d1c674f4 100644
--- a/net-print/hplip/hplip-3.12.9-r1.ebuild
+++ b/net-print/hplip/hplip-3.12.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.9-r1.ebuild,v 1.6 2012/10/20 11:54:01 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.9-r1.ebuild,v 1.7 2012/12/11 17:01:02 axs Exp $
EAPI=4
@@ -8,7 +8,7 @@ PYTHON_DEPEND="!minimal? 2"
PYTHON_USE_WITH="threads xml"
PYTHON_USE_WITH_OPT="!minimal"
-inherit eutils fdo-mime linux-info python autotools toolchain-funcs
+inherit eutils fdo-mime linux-info python udev autotools toolchain-funcs
DESCRIPTION="HP Linux Imaging and Printing. Includes printer, scanner, fax drivers and service tools."
HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
@@ -48,7 +48,7 @@ RDEPEND="${COMMON_DEPEND}
)
!minimal? (
dev-python/pygobject:2
- kernel_linux? ( >=sys-fs/udev-114 )
+ kernel_linux? ( virtual/udev !<sys-fs/udev-114 )
scanner? (
dev-python/imaging
X? ( || (
@@ -105,8 +105,7 @@ src_prepare() {
epatch "${WORKDIR}"
# Fix for Gentoo bug #345725
- local udevdir=/lib/udev
- has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ local udevdir="$(udev_get_udevdir)"
sed -i -e "s|/etc/udev|${udevdir}|g" \
$(find . -type f -exec grep -l /etc/udev {} +) || die