summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-09-05 22:58:28 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-09-05 22:58:28 +0000
commitcb2255b70809d5dccfbcc3500a09f7cb3fd12376 (patch)
treeaad17cda0c8ef461144af8b1206353950c087109
parentDon't build protoize on FreeBSD, again. (diff)
downloadgentoo-2-cb2255b70809d5dccfbcc3500a09f7cb3fd12376.tar.gz
gentoo-2-cb2255b70809d5dccfbcc3500a09f7cb3fd12376.tar.bz2
gentoo-2-cb2255b70809d5dccfbcc3500a09f7cb3fd12376.zip
Fix the ibam patch
(Portage version: 2.1.1_rc1-r4)
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog6
-rw-r--r--app-laptop/pbbuttonsd/files/pbbuttonsd-ibam-g++.patch33
2 files changed, 23 insertions, 16 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index 8eafc8a76014..92132bd49c83 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.53 2006/08/27 20:17:42 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.54 2006/09/05 22:58:27 lu_zero Exp $
+
+ 06 Sep 2006; Luca Barbato <lu_zero@gentoo.org>
+ files/pbbuttonsd-ibam-g++.patch:
+ Update the g++ patch to really build ibam when needed
27 Aug 2006; Luca Barbato <lu_zero@gentoo.org>
+files/pbbuttonsd-ibam-g++.patch, pbbuttonsd-0.7.8.ebuild:
diff --git a/app-laptop/pbbuttonsd/files/pbbuttonsd-ibam-g++.patch b/app-laptop/pbbuttonsd/files/pbbuttonsd-ibam-g++.patch
index 85000783838c..60a9199a36e5 100644
--- a/app-laptop/pbbuttonsd/files/pbbuttonsd-ibam-g++.patch
+++ b/app-laptop/pbbuttonsd/files/pbbuttonsd-ibam-g++.patch
@@ -1,30 +1,30 @@
---- pbbuttonsd-0.7.8.orig/configure.in 2006-07-31 10:08:31.000000000 +0200
-+++ pbbuttonsd-0.7.8/configure.in 2006-08-27 21:36:25.000000000 +0200
-@@ -81,9 +81,7 @@
- pbb_with_ibam=yes
- AC_ARG_WITH(ibam, [ --with-ibam enable IBAM support in pbbuttonsd (default=yes)],
- pbb_with_ibam=$withval, )
--if test "$pbb_with_ibam" == "yes"; then
-- AC_DEFINE_UNQUOTED(WITH_IBAM, 1, [enable IBAM support])
--fi
-+AM_CONDITIONAL(WITH_IBAM, test "$pbb_with_ibam" = yes)
+diff -urN pbbuttonsd-0.7.8.orig/configure.in pbbuttonsd-0.7.8/configure.in
+--- pbbuttonsd-0.7.8.orig/configure.in 2006-09-06 01:57:19.000000000 +0200
++++ pbbuttonsd-0.7.8/configure.in 2006-09-06 01:58:03.000000000 +0200
+@@ -87,6 +87,7 @@
dnl Conditionals
AM_CONDITIONAL(DEBUG, test "$enable_debug" = yes)
---- pbbuttonsd-0.7.8.orig/src/Makefile.am 2006-07-22 19:25:39.000000000 +0200
-+++ pbbuttonsd-0.7.8/src/Makefile.am 2006-08-27 21:40:53.000000000 +0200
-@@ -4,6 +4,10 @@
++AM_CONDITIONAL(WITH_IBAM, test "$pbb_with_ibam" = yes)
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+diff -urN pbbuttonsd-0.7.8.orig/src/Makefile.am pbbuttonsd-0.7.8/src/Makefile.am
+--- pbbuttonsd-0.7.8.orig/src/Makefile.am 2006-09-06 01:57:20.000000000 +0200
++++ pbbuttonsd-0.7.8/src/Makefile.am 2006-09-06 02:15:26.000000000 +0200
+@@ -4,6 +4,11 @@
bin_PROGRAMS = pbbuttonsd
+if WITH_IBAM
+IBAM = ibam_stub.cpp ibam_stub.h ibam.hpp ibam.inl
++IBAM_LIBS = -lstdc++
+endif
+
pbbuttonsd_SOURCES = \
pbbuttonsd.c \
init.c init.h systems.h \
-@@ -20,8 +24,7 @@
+@@ -20,10 +25,9 @@
module_alsamixer.c module_alsamixer.h \
module_peep.c module_peep.h \
tcp.c tcp.h gettext_macros.h pbbinput.h \
@@ -32,5 +32,8 @@
- ibam_stub.cpp ibam_stub.h ibam.hpp ibam.inl
+ debug.h $(IBAM)
- pbbuttonsd_LDADD = -lpbb $(INTLLIBS) $(ALSA_LIBS) @PACKAGE_LIBS@
+-pbbuttonsd_LDADD = -lpbb $(INTLLIBS) $(ALSA_LIBS) @PACKAGE_LIBS@
++pbbuttonsd_LDADD = -lpbb $(INTLLIBS) $(ALSA_LIBS) $(IBAM_LIBS) @PACKAGE_LIBS@
pbbuttonsd_LDFLAGS = -L$(top_srcdir)/libpbbipc
+ ##pbbuttonsd_DEPENDENCIES = $(top_srcdir)/libpbbipc/libpbb.a
+