summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-19 20:35:56 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-19 20:35:56 +0000
commitcc1e4da737e47483b1e8b053352262e3e735cd5f (patch)
treeeb7d3d3f7ced480ee3968d150f1041a1955b8fef
parentnew bootstrap for x86 (diff)
downloadgentoo-2-cc1e4da737e47483b1e8b053352262e3e735cd5f.tar.gz
gentoo-2-cc1e4da737e47483b1e8b053352262e3e735cd5f.tar.bz2
gentoo-2-cc1e4da737e47483b1e8b053352262e3e735cd5f.zip
Fix hang from KDE bug 274940; find blas using PkgConfig
(Portage version: 2.1.10.3/cvs/Linux x86_64)
-rw-r--r--sci-libs/clapack/ChangeLog9
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r6.ebuild (renamed from sci-libs/clapack/clapack-3.2.1-r5.ebuild)5
-rw-r--r--sci-libs/clapack/files/clapack-3.2.1-findblas-r6.patch50
-rw-r--r--sci-libs/clapack/files/clapack-3.2.1-hang.patch15
4 files changed, 76 insertions, 3 deletions
diff --git a/sci-libs/clapack/ChangeLog b/sci-libs/clapack/ChangeLog
index 0f4ef282a336..1779b9333438 100644
--- a/sci-libs/clapack/ChangeLog
+++ b/sci-libs/clapack/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/clapack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/ChangeLog,v 1.14 2011/06/17 21:16:09 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/ChangeLog,v 1.15 2011/06/19 20:35:56 dilfridge Exp $
+
+*clapack-3.2.1-r6 (19 Jun 2011)
+
+ 19 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ -clapack-3.2.1-r5.ebuild, +clapack-3.2.1-r6.ebuild,
+ +files/clapack-3.2.1-findblas-r6.patch, +files/clapack-3.2.1-hang.patch:
+ Fix hang from KDE bug 274940; find blas using PkgConfig
*clapack-3.2.1-r5 (17 Jun 2011)
diff --git a/sci-libs/clapack/clapack-3.2.1-r5.ebuild b/sci-libs/clapack/clapack-3.2.1-r6.ebuild
index 6fc2fbe09d5c..64af0d5024d0 100644
--- a/sci-libs/clapack/clapack-3.2.1-r5.ebuild
+++ b/sci-libs/clapack/clapack-3.2.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/clapack-3.2.1-r5.ebuild,v 1.1 2011/06/17 21:16:09 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/clapack-3.2.1-r6.ebuild,v 1.1 2011/06/19 20:35:56 dilfridge Exp $
EAPI=4
@@ -24,7 +24,8 @@ S=${WORKDIR}/${P}-CMAKE
PATCHES=(
"${FILESDIR}/${P}-fix_include_file.patch"
"${FILESDIR}/${P}-noblasf2c.patch"
- "${FILESDIR}/${P}-findblas.patch"
+ "${FILESDIR}/${P}-hang.patch"
+ "${FILESDIR}/${P}-findblas-r6.patch"
)
src_configure() {
diff --git a/sci-libs/clapack/files/clapack-3.2.1-findblas-r6.patch b/sci-libs/clapack/files/clapack-3.2.1-findblas-r6.patch
new file mode 100644
index 000000000000..028dec609dd8
--- /dev/null
+++ b/sci-libs/clapack/files/clapack-3.2.1-findblas-r6.patch
@@ -0,0 +1,50 @@
+diff -ruN clapack-3.2.1-CMAKE.1.allexfb/CMakeLists.txt clapack-3.2.1-CMAKE/CMakeLists.txt
+--- clapack-3.2.1-CMAKE.1.allexfb/CMakeLists.txt 2011-06-19 22:13:27.000000000 +0200
++++ clapack-3.2.1-CMAKE/CMakeLists.txt 2011-06-19 22:23:14.000000000 +0200
+@@ -30,6 +30,29 @@
+
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
+
++if(BLAS_LIBRARIES)
++ include(CheckFortranFunctionExists)
++ set(CMAKE_REQUIRED_LIBRARIES ${BLAS_LIBRARIES})
++ CHECK_FORTRAN_FUNCTION_EXISTS("dgemm" BLAS_FOUND)
++ unset( CMAKE_REQUIRED_LIBRARIES )
++ if(BLAS_FOUND)
++ message(STATUS "--> BLAS supplied by user is WORKING, will use ${BLAS_LIBRARIES}.")
++ else(BLAS_FOUND)
++ message(ERROR "--> BLAS supplied by user is not WORKING, CANNOT USE ${BLAS_LIBRARIES}.")
++ message(ERROR "--> Will use REFERENCE BLAS (by default)")
++ message(ERROR "--> Or Correct your BLAS_LIBRARIES entry ")
++ message(ERROR "--> Or Consider checking USE_OPTIMIZED_BLAS")
++ endif(BLAS_FOUND)
++else(BLAS_LIBRARIES)
++ # User did not provide a BLAS Library
++ find_package(PkgConfig)
++ pkg_check_modules(BLAS blas)
++endif (BLAS_LIBRARIES)
++
++if(NOT BLAS_FOUND)
++ message(FATAL_ERROR "--> BLAS libraries needed but not found.")
++endif(NOT BLAS_FOUND)
++
+ add_subdirectory(SRC)
+
+ if(ENABLE_TESTS)
+@@ -44,4 +67,3 @@
+ ${CLAPACK_BINARY_DIR}/clapack-config-version.cmake @ONLY)
+ configure_file(${CLAPACK_SOURCE_DIR}/clapack-config.cmake.in
+ ${CLAPACK_BINARY_DIR}/clapack-config.cmake @ONLY)
+-
+diff -ruN clapack-3.2.1-CMAKE.1.allexfb/SRC/CMakeLists.txt clapack-3.2.1-CMAKE/SRC/CMakeLists.txt
+--- clapack-3.2.1-CMAKE.1.allexfb/SRC/CMakeLists.txt 2011-06-19 22:13:44.000000000 +0200
++++ clapack-3.2.1-CMAKE/SRC/CMakeLists.txt 2011-06-19 22:15:04.000000000 +0200
+@@ -380,7 +380,7 @@
+ endif()
+
+ add_library(clapack SHARED ${ALLOBJ} ${ALLXOBJ})
+-target_link_libraries(clapack blas f2c m)
++target_link_libraries(clapack ${BLAS_LIBRARIES} f2c m)
+ set_target_properties(clapack PROPERTIES SOVERSION "${CLAPACK_VERSION}")
+
+ install(
diff --git a/sci-libs/clapack/files/clapack-3.2.1-hang.patch b/sci-libs/clapack/files/clapack-3.2.1-hang.patch
new file mode 100644
index 000000000000..648516f78e34
--- /dev/null
+++ b/sci-libs/clapack/files/clapack-3.2.1-hang.patch
@@ -0,0 +1,15 @@
+Fix for https://bugs.kde.org/show_bug.cgi?id=274940
+
+diff -ruN clapack-3.2.1-CMAKE.orig/SRC/CMakeLists.txt clapack-3.2.1-CMAKE/SRC/CMakeLists.txt
+--- clapack-3.2.1-CMAKE.orig/SRC/CMakeLists.txt 2009-08-10 19:47:54.000000000 +0200
++++ clapack-3.2.1-CMAKE/SRC/CMakeLists.txt 2011-06-19 02:17:34.119752822 +0200
+@@ -355,6 +355,9 @@
+ zla_heamv.c zla_hercond_c.c zla_hercond_x.c zla_herpvgrw.c
+ zla_lin_berr.c zlarscl2.c zlascl2.c zla_wwaddw.c)
+
++if(CMAKE_COMPILER_IS_GNUCXX)
++ set_source_files_properties(dlamch.c slamch.c PROPERTIES COMPILE_FLAGS "-ffloat-store -O0")
++endif()
+
+ if( USEXBLAS)
+ set(ALLXOBJ ${SXLASRC} ${DXLASRC} ${CXLASRC} ${ZXLASRC} ${ALLXAUX})