summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-17 00:12:26 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-17 00:12:26 +0000
commitcc5130c85a845551e10fe84b48d1a3fbabbee248 (patch)
treef802349844915bbff49ddd96ba9a1a0dfff9029e
parentRevision bump: patch gpgsm-gencert.sh to actually work; remove openct and pcs... (diff)
downloadgentoo-2-cc5130c85a845551e10fe84b48d1a3fbabbee248.tar.gz
gentoo-2-cc5130c85a845551e10fe84b48d1a3fbabbee248.tar.bz2
gentoo-2-cc5130c85a845551e10fe84b48d1a3fbabbee248.zip
Initial import of scute (PKCS#11 provider for OpenPGP cards); ebuild thanks to Lucas Yamanishi in bug #363801.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
-rw-r--r--app-crypt/scute/ChangeLog12
-rw-r--r--app-crypt/scute/files/scute-1.2.0-noversion.patch14
-rw-r--r--app-crypt/scute/files/scute-1.4.0-tests.patch13
-rw-r--r--app-crypt/scute/metadata.xml27
-rw-r--r--app-crypt/scute/scute-1.4.0.ebuild51
5 files changed, 117 insertions, 0 deletions
diff --git a/app-crypt/scute/ChangeLog b/app-crypt/scute/ChangeLog
new file mode 100644
index 000000000000..c88bcf1c060e
--- /dev/null
+++ b/app-crypt/scute/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-crypt/scute
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/scute/ChangeLog,v 1.1 2011/04/17 00:12:26 flameeyes Exp $
+
+*scute-1.4.0 (17 Apr 2011)
+
+ 17 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/scute-1.2.0-noversion.patch, +scute-1.4.0.ebuild,
+ +files/scute-1.4.0-tests.patch, +metadata.xml:
+ Initial import of scute (PKCS#11 provider for OpenPGP cards); ebuild thanks
+ to Lucas Yamanishi in bug #363801.
+
diff --git a/app-crypt/scute/files/scute-1.2.0-noversion.patch b/app-crypt/scute/files/scute-1.2.0-noversion.patch
new file mode 100644
index 000000000000..41d188b5926a
--- /dev/null
+++ b/app-crypt/scute/files/scute-1.2.0-noversion.patch
@@ -0,0 +1,14 @@
+Index: scute-1.2.0/src/Makefile.am
+===================================================================
+--- scute-1.2.0.orig/src/Makefile.am
++++ scute-1.2.0/src/Makefile.am
+@@ -109,8 +109,7 @@ scute_deps =
+ endif
+
+ libscute_la_LDFLAGS = $(scute_res_ldflag) $(no_undefined) $(export_symbols) \
+- $(scute_version_script_cmd) -version-info \
+- @LIBSCUTE_LT_CURRENT@:@LIBSCUTE_LT_REVISION@:@LIBSCUTE_LT_AGE@
++ $(scute_version_script_cmd) -avoid-version
+ libscute_la_DEPENDENCIES = @LTLIBOBJS@ $(srcdir)/libscute.vers $(scute_deps)
+ libscute_la_LIBADD = @LTLIBOBJS@ @LIBASSUAN_LIBS@ @GPG_ERROR_LIBS@
+
diff --git a/app-crypt/scute/files/scute-1.4.0-tests.patch b/app-crypt/scute/files/scute-1.4.0-tests.patch
new file mode 100644
index 000000000000..f06591f77e4a
--- /dev/null
+++ b/app-crypt/scute/files/scute-1.4.0-tests.patch
@@ -0,0 +1,13 @@
+Index: scute-1.4.0/tests/Makefile.am
+===================================================================
+--- scute-1.4.0.orig/tests/Makefile.am
++++ scute-1.4.0/tests/Makefile.am
+@@ -35,7 +35,7 @@ TESTS = t-link t-getfunctionlist t-initi
+ t-opensession t-closeallsessions t-getsessioninfo \
+ t-findobjects t-getattribute t-auth
+
+-noinst_PROGRAMS = $(TESTS)
++check_PROGRAMS = $(TESTS)
+
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/src
+ LDADD = ../src/libscute.la
diff --git a/app-crypt/scute/metadata.xml b/app-crypt/scute/metadata.xml
new file mode 100644
index 000000000000..63ffc80126c3
--- /dev/null
+++ b/app-crypt/scute/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <maintainer>
+ <email>lamawithonel@aim.com</email>
+ <name>Lucas Yamanishi</name>
+ <description>Proxy maintainer.</description>
+ </maintainer>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ <description>Proxying maintainer.</description>
+ </maintainer>
+ <longdescription>
+ Scute is a PKCS #11 module that adds support for the OpenPGP
+ smartcard card to the Mozilla Network Security Services (NSS).
+ </longdescription>
+ <upstream>
+ <maintainer>
+ <email>mb@g10code.de</email>
+ <name>Marcus Brinkmann</name>
+ </maintainer>
+ <changelog>http://git.gnupg.org/cgi-bin/gitweb.cgi?p=scute.git;a=blob_plain;f=ChangeLog;hb=HEAD</changelog>
+ <doc lang="en">http://www.scute.org/documentation.xhtml</doc>
+ <bugs-to>https://bugs.g10code.com/gnupg/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/scute/scute-1.4.0.ebuild b/app-crypt/scute/scute-1.4.0.ebuild
new file mode 100644
index 000000000000..9fbc5ffdb9f3
--- /dev/null
+++ b/app-crypt/scute/scute-1.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/scute/scute-1.4.0.ebuild,v 1.1 2011/04/17 00:12:26 flameeyes Exp $
+
+EAPI=4
+
+inherit autotools eutils libtool multilib
+
+DESCRIPTION="A PKCS #11 module for OpenPGP smartcards"
+HOMEPAGE="http://www.scute.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/scute/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# configure script try to check the version of gpgsm and gpg-agent when
+# non-crosscompiling so we need to have them as build-time dependency as
+# well as runtime. Require a version of gnupg that is patched to have
+# gpgsm-gencert.sh working (as that's what the documentation describe).
+DEPEND="
+ >=dev-libs/libgpg-error-1.4
+ >=dev-libs/libassuan-2.0.0
+ >=app-crypt/pinentry-0.7.0
+ >=app-crypt/gnupg-2.0.17-r1[smartcard]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # We need no ABI versioning, reduce the number of symlinks installed
+ epatch "${FILESDIR}"/scute-1.2.0-noversion.patch
+ # Don't build tests during src_compile.
+ epatch "${FILESDIR}"/scute-1.4.0-tests.patch
+
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/pkcs11 \
+ --with-gpgsm=/usr/bin/gpgsm \
+ --with-gpg-agent=/usr/bin/gpg-agent
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ find "${D}" -name '*.la' -delete
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+