summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-06-09 11:15:40 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-06-09 11:15:40 +0000
commitcd52e46d9a2f7f365dc85e7f931d194fe77e418f (patch)
tree3e2ad0497399118c329076b27936f0f292ccef7a
parentRemove old versions. (diff)
downloadgentoo-2-cd52e46d9a2f7f365dc85e7f931d194fe77e418f.tar.gz
gentoo-2-cd52e46d9a2f7f365dc85e7f931d194fe77e418f.tar.bz2
gentoo-2-cd52e46d9a2f7f365dc85e7f931d194fe77e418f.zip
Version bump
(Portage version: 2.1.2.7)
-rw-r--r--dev-perl/AppConfig/AppConfig-1.65.ebuild22
-rw-r--r--dev-perl/AppConfig/ChangeLog9
-rw-r--r--dev-perl/AppConfig/files/AppConfig-1.52-gentoo.diff49
-rw-r--r--dev-perl/AppConfig/files/blockdiffs.patch83
-rw-r--r--dev-perl/AppConfig/files/digest-AppConfig-1.653
5 files changed, 116 insertions, 50 deletions
diff --git a/dev-perl/AppConfig/AppConfig-1.65.ebuild b/dev-perl/AppConfig/AppConfig-1.65.ebuild
new file mode 100644
index 000000000000..6bbaee604a0c
--- /dev/null
+++ b/dev-perl/AppConfig/AppConfig-1.65.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AppConfig/AppConfig-1.65.ebuild,v 1.1 2007/06/09 11:15:40 mcummings Exp $
+
+inherit perl-module eutils
+
+DESCRIPTION="Perl5 module for reading configuration files and parsing command line arguments."
+SRC_URI="mirror://cpan/authors/id/A/AB/ABW/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~abw/"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+PATCHES="${FILESDIR}/blockdiffs.patch"
+
+SRC_TEST="do"
+
+DEPEND=">=dev-perl/File-HomeDir-0.57
+ virtual/perl-Test-Simple
+ dev-lang/perl"
diff --git a/dev-perl/AppConfig/ChangeLog b/dev-perl/AppConfig/ChangeLog
index f6f3f7efe872..5603735dc0f9 100644
--- a/dev-perl/AppConfig/ChangeLog
+++ b/dev-perl/AppConfig/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-perl/AppConfig
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/AppConfig/ChangeLog,v 1.47 2007/05/05 17:30:58 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AppConfig/ChangeLog,v 1.48 2007/06/09 11:15:40 mcummings Exp $
+
+*AppConfig-1.65 (09 Jun 2007)
+
+ 09 Jun 2007; Michael Cummings <mcummings@gentoo.org>
+ -files/AppConfig-1.52-gentoo.diff, +files/blockdiffs.patch,
+ +AppConfig-1.65.ebuild:
+ Version bump
05 May 2007; Tobias Scherbaum <dertobi123@gentoo.org>
AppConfig-1.64.ebuild:
diff --git a/dev-perl/AppConfig/files/AppConfig-1.52-gentoo.diff b/dev-perl/AppConfig/files/AppConfig-1.52-gentoo.diff
deleted file mode 100644
index 949a8cbe1572..000000000000
--- a/dev-perl/AppConfig/files/AppConfig-1.52-gentoo.diff
+++ /dev/null
@@ -1,49 +0,0 @@
---- AppConfig-1.52/AppConfig.pm.orig Thu Oct 29 13:08:55 1998
-+++ AppConfig-1.52/AppConfig.pm Wed Aug 7 00:48:17 2002
-@@ -577,21 +577,21 @@
-
- Used to provide an argument specification string to pass to Getopt::Long
- via AppConfig::Getopt. E.g. "=i", ":s", "=s@". This can also be used to
--implicitly set the ARGCOUNT value (C</^!/> = ARGCOUNT_NONE, C</@/> =
--ARGCOUNT_LIST, C</%/ = ARGCOUNT_HASH, C</[=:].*/> = ARGCOUNT_ONE)
-+implicitly set the ARGCOUNT value (C</^!/> = ARGCOUNT_NONE, C</@/> =
-+ARGCOUNT_LIST, C</%/> = ARGCOUNT_HASH, C</[=:].*/> = ARGCOUNT_ONE)
-
- =item EXPAND
-
--Specifies which variable expansion policies should be used when parsing
-+Specifies which variable expansion policies should be used when parsing
- configuration files. Constants in C<:argcount> tag set define EXPAND_NONE
--- no expansion (default), EXPAND_VAR - expand C<$var> or C<$(var)> as
--other AppConfig variables, EXPAND_UID - expand C<~uid> as user's home
-+- no expansion (default), EXPAND_VAR - expand C<$var> or C<$(var)> as
-+other AppConfig variables, EXPAND_UID - expand C<~uid> as user's home
- directory, EXPAND_ENV - expand C<${var}> as environment variable,
- EXPAND_ALL - do all expansions. May be logically or'd.
-
- =item VALIDATE
-
--Regex which the intended variable value should match or code reference
-+Regex which the intended variable value should match or code reference
- which returns 1 to indicate successful validaton (variable may now be set).
-
- =item ACTION
-@@ -602,15 +602,15 @@
-
- =head2 COMPACT FORMAT DEFINITION
-
--Variables can be specified using a compact format. This is identical to
-+Variables can be specified using a compact format. This is identical to
- the specification format of Getopt::Long and is of the form:
-
- "name|alias|aliasE<lt>argopts<gt>"
-
--The first element indicates the variable name and subsequent ALIAS
-+The first element indicates the variable name and subsequent ALIAS
- values may be added, each separated by a vertical bar '|'.
-
--The E<lt>argopts<gt> element indicates the ARGCOUNT value and may be one of
-+The E<lt>argopts<gt> element indicates the ARGCOUNT value and may be one of
- the following;
-
- ! ARGCOUNT_NONE
diff --git a/dev-perl/AppConfig/files/blockdiffs.patch b/dev-perl/AppConfig/files/blockdiffs.patch
new file mode 100644
index 000000000000..2e30310a8884
--- /dev/null
+++ b/dev-perl/AppConfig/files/blockdiffs.patch
@@ -0,0 +1,83 @@
+diff -Naurp AppConfig-1.65.orig/lib/AppConfig/File.pm AppConfig-1.65/lib/AppConfig/File.pm
+--- AppConfig-1.65.orig/lib/AppConfig/File.pm 2007-05-30 07:24:09.000000000 -0400
++++ AppConfig-1.65/lib/AppConfig/File.pm 2007-06-09 07:08:21.000000000 -0400
+@@ -38,6 +38,7 @@ sub new {
+ STATE => $state, # AppConfig::State ref
+ DEBUG => $state->_debug(), # store local copy of debug
+ PEDANTIC => $state->_pedantic, # and pedantic flags
++ BLOCKSEP => $state->_blocksep, # and block separator
+ };
+
+ bless $self, $class;
+@@ -80,7 +81,7 @@ sub parse {
+ my $flag;
+
+ # take a local copy of the state to avoid much hash dereferencing
+- my ($state, $debug, $pedantic) = @$self{ qw( STATE DEBUG PEDANTIC ) };
++ my ($state, $debug, $pedantic, $blocksep) = @$self{ qw( STATE DEBUG PEDANTIC BLOCKSEP ) };
+
+ # we want to install a custom error handler into the AppConfig::State
+ # which appends filename and line info to error messages and then
+@@ -163,7 +164,7 @@ sub parse {
+ s/\s+$//;
+
+ # look for a [block] to set $prefix
+- if (/^\[([^\]]+)\]$/) {
++ if (/^\[\s*([^\]\s]+)\s*\]$/) {
+ $prefix = $1;
+ print STDERR "Entering [$prefix] block\n" if $debug;
+ next;
+@@ -194,7 +195,7 @@ sub parse {
+ $flag = $1;
+
+ # $variable gets any $prefix
+- $variable = $prefix . '_' . $variable
++ $variable = $prefix . $blocksep . $variable
+ if length $prefix;
+
+ # if the variable doesn't exist, we call set() to give
+diff -Naurp AppConfig-1.65.orig/lib/AppConfig/State.pm AppConfig-1.65/lib/AppConfig/State.pm
+--- AppConfig-1.65.orig/lib/AppConfig/State.pm 2007-05-30 07:24:20.000000000 -0400
++++ AppConfig-1.65/lib/AppConfig/State.pm 2007-06-09 07:11:16.000000000 -0400
+@@ -53,7 +53,7 @@ my %METHVARS;
+
+ # internal values that AUTOLOAD should provide access to
+ my %METHFLAGS;
+- @METHFLAGS{ qw( PEDANTIC ) } = ();
++ @METHFLAGS{ qw( PEDANTIC BLOCKSEP ) } = ();
+
+ # variable attributes that may be specified in GLOBAL;
+ my @GLOBAL_OK = qw( DEFAULT EXPAND VALIDATE ACTION ARGS ARGCOUNT );
+@@ -94,6 +94,7 @@ sub new {
+ PEDANTIC => 0, # return immediately on parse warnings
+ EHANDLER => undef, # error handler (let's hope we don't need it!)
+ ERROR => '', # error message
++ BLOCKSEP => '_', # separator between [block] and variable name
+ };
+
+ bless $self, $class;
+@@ -504,8 +505,8 @@ sub _configure {
+ next;
+ };
+
+- # CASE, CREATE and PEDANTIC are stored as they are
+- $opt =~ /^CASE|CREATE|PEDANTIC$/i && do {
++ # CASE, CREATE, PEDANTIC and BLOCKSEP are stored as they are
++ $opt =~ /^CASE|CREATE|PEDANTIC|BLOCKSEP$/i && do {
+ $self->{ uc $opt } = $cfg->{ $opt };
+ next;
+ };
+@@ -1015,6 +1016,13 @@ instantiated with a reference to an App:
+ DEBUG (and also PEDANTIC) values of the state at that time. Subsequent
+ changes to the AppConfig::State debug value will not affect them.
+
++=item BLOCKSEP
++
++When parsing configuration files that are grouped using constructions
++like [block], this string parameter determines what is used to
++separate the name of the block from the name of each variable
++contained within it. If unspecified, BLOCKSEP defaults to '_'.
++
+ =item GLOBAL
+
+ The GLOBAL option allows default values to be set for the DEFAULT, ARGCOUNT,
diff --git a/dev-perl/AppConfig/files/digest-AppConfig-1.65 b/dev-perl/AppConfig/files/digest-AppConfig-1.65
new file mode 100644
index 000000000000..ccb78f4fb5b0
--- /dev/null
+++ b/dev-perl/AppConfig/files/digest-AppConfig-1.65
@@ -0,0 +1,3 @@
+MD5 bb4726fe1acd64a8b33ba9515583ec75 AppConfig-1.65.tar.gz 64731
+RMD160 f4aee600d916a2b7921452168ebf8a49101091d9 AppConfig-1.65.tar.gz 64731
+SHA256 814880d834a6164efa5cd20874eefb3898d7aafe015895a178d9b049569f4543 AppConfig-1.65.tar.gz 64731