summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-11-24 17:28:49 +0000
committerJeroen Roovers <jer@gentoo.org>2011-11-24 17:28:49 +0000
commitd06ef0bd8e1913a0d2f4c955dfe2b278690c64e1 (patch)
treeb9831d22b33c852452b8d895c62e58c29c5cb647
parenthttp://my.opera.com/desktopteam/blog/2011/11/24/ragnarok-feather-html5-install (diff)
downloadgentoo-2-d06ef0bd8e1913a0d2f4c955dfe2b278690c64e1.tar.gz
gentoo-2-d06ef0bd8e1913a0d2f4c955dfe2b278690c64e1.tar.bz2
gentoo-2-d06ef0bd8e1913a0d2f4c955dfe2b278690c64e1.zip
Version bump by Michael (bug #391789).
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
-rw-r--r--net-analyzer/netio/ChangeLog9
-rw-r--r--net-analyzer/netio/netio-1.31.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/net-analyzer/netio/ChangeLog b/net-analyzer/netio/ChangeLog
index 7721305f4b78..f130b39d41a7 100644
--- a/net-analyzer/netio/ChangeLog
+++ b/net-analyzer/netio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/netio
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/ChangeLog,v 1.24 2010/08/09 17:47:54 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/ChangeLog,v 1.25 2011/11/24 17:28:49 jer Exp $
+
+*netio-1.31 (24 Nov 2011)
+
+ 24 Nov 2011; Jeroen Roovers <jer@gentoo.org> +netio-1.31.ebuild:
+ Version bump by Michael (bug #391789).
*netio-1.26-r1 (09 Aug 2010)
diff --git a/net-analyzer/netio/netio-1.31.ebuild b/net-analyzer/netio/netio-1.31.ebuild
new file mode 100644
index 000000000000..758412ef6249
--- /dev/null
+++ b/net-analyzer/netio/netio-1.31.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/netio-1.31.ebuild,v 1.1 2011/11/24 17:28:49 jer Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a network benchmarking tool that measures net throughput with NetBIOS and TCP/IP protocols."
+HOMEPAGE="http://www.ars.de/ars/ars.nsf/docs/netio"
+SRC_URI='http://www.ars.de/ars/ars.nsf/f24a6a0b94c22d82862566960071bf5a/aa577bc4be573b05c125706d004c75b5/$FILE/netio131.zip'
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ >=sys-apps/sed-4"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ edos2unix *.c *.h
+
+ sed -i Makefile \
+ -e 's|\(CFLAGS\)=|\1+=|g' \
+ -e 's|\(CC\)=|\1?=|g' \
+ -e "s|LFLAGS=\"\"|LFLAGS?=\"${LDFLAGS}\"|g" \
+ || die "sed Makefile failed"
+ epatch "${FILESDIR}"/${PN}-1.26-linux-include.patch
+}
+
+src_compile() {
+ emake linux \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin netio
+ dodoc netio.doc
+}