summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-04-23 22:51:06 +0000
committerAnant Narayanan <anant@gentoo.org>2007-04-23 22:51:06 +0000
commitd1167a962858c2f646827b1495bc939ff81b7dd1 (patch)
tree5e936f8312f99a393dfa4b1ab1c890b7dfbbdfc2
parentStable on Mips, bug 173327. (diff)
downloadgentoo-2-d1167a962858c2f646827b1495bc939ff81b7dd1.tar.gz
gentoo-2-d1167a962858c2f646827b1495bc939ff81b7dd1.tar.bz2
gentoo-2-d1167a962858c2f646827b1495bc939ff81b7dd1.zip
vBump to 7.0.1, closes bug #154259
(Portage version: 2.1.2.4)
-rw-r--r--media-libs/pdflib/ChangeLog7
-rw-r--r--media-libs/pdflib/files/digest-pdflib-7.0.13
-rw-r--r--media-libs/pdflib/pdflib-7.0.1.ebuild114
3 files changed, 123 insertions, 1 deletions
diff --git a/media-libs/pdflib/ChangeLog b/media-libs/pdflib/ChangeLog
index 20cdae829ba1..b9a31867d819 100644
--- a/media-libs/pdflib/ChangeLog
+++ b/media-libs/pdflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/pdflib
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.63 2007/03/16 22:45:29 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.64 2007/04/23 22:51:06 anant Exp $
+
+*pdflib-7.0.1 (23 Apr 2007)
+
+ 23 Apr 2007; Anant Narayanan <anant@gentoo.org> +pdflib-7.0.1.ebuild:
+ vBump to 7.0.1
16 Mar 2007; Luca Longinotti <chtekk@gentoo.org>
pdflib-5.0.4_p1-r1.ebuild, pdflib-6.0.3.ebuild, pdflib-6.0.3-r1.ebuild:
diff --git a/media-libs/pdflib/files/digest-pdflib-7.0.1 b/media-libs/pdflib/files/digest-pdflib-7.0.1
new file mode 100644
index 000000000000..3f5dd6896ca6
--- /dev/null
+++ b/media-libs/pdflib/files/digest-pdflib-7.0.1
@@ -0,0 +1,3 @@
+MD5 ac47f3f4b9d769c84ad211b76a33ef20 PDFlib-Lite-7.0.1.tar.gz 5350886
+RMD160 b0d7431c07d96df484cd45980fcde9b7df2f200f PDFlib-Lite-7.0.1.tar.gz 5350886
+SHA256 61b79378f5138c83d7b87675e58d82880f9d408c6d1c504b3d617104471db87f PDFlib-Lite-7.0.1.tar.gz 5350886
diff --git a/media-libs/pdflib/pdflib-7.0.1.ebuild b/media-libs/pdflib/pdflib-7.0.1.ebuild
new file mode 100644
index 000000000000..3e9b6365570c
--- /dev/null
+++ b/media-libs/pdflib/pdflib-7.0.1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-7.0.1.ebuild,v 1.1 2007/04/23 22:51:06 anant Exp $
+
+# eutils must be inherited since get_libdir() is only
+# globally available on baselayout-1.11 (still on ~arch)
+inherit base eutils java-pkg-opt-2 flag-o-matic
+
+MY_PN="${PN/pdf/PDF}-Lite"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A library for generating PDF on the fly."
+HOMEPAGE="http://www.pdflib.com/"
+SRC_URI="http://www.pdflib.com/binaries/${PN/pdf/PDF}/${PV//./}/${MY_P}.tar.gz"
+LICENSE="Aladdin"
+SLOT="5"
+KEYWORDS="~x86"
+IUSE="doc tcl perl python java"
+
+COMMON_DEP="
+ >=sys-apps/sed-4
+ tcl? ( >=dev-lang/tcl-8.2 )
+ perl? ( >=dev-lang/perl-5.1 )
+ python? ( >=dev-lang/python-2.2 )"
+
+DEPEND="
+ ${COMMON_DEP}
+ java? ( >=virtual/jdk-1.4 )"
+
+RDEPEND="
+ ${COMMON_DEP}
+ java? ( >=virtual/jre-1.4 )"
+
+src_compile() {
+ local myconf
+
+ # Bug #87004
+ filter-flags -mcpu=*
+ filter-flags -mtune=*
+
+ PYVER="$(/usr/bin/python -V 2>&1 | cut -d ' ' -f 2 | cut -d '.' -f 1,2)"
+ # Necessary for multilib on amd64. Please keep this in future releases.
+ # BUG #81197
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/02/14
+ TCLVER="$(echo 'puts [info tclversion]' | $(type -P tclsh))"
+ use tcl \
+ && myconf="--with-tclpkg=/usr/$(get_libdir)/tcl${TCLVER}/" \
+ || myconf="--with-tcl=no"
+ use perl || myconf="${myconf} --with-perl=no"
+ use python \
+ && myconf="${myconf} --with-py=/usr --with-pyincl=/usr/include/python${PYVER}" \
+ || myconf="${myconf} --with-py=no"
+ use java \
+ && myconf="${myconf} --with-java=${JAVA_HOME}" \
+ || myconf="${myconf} --with-java=no"
+
+ econf \
+ --enable-cxx \
+ ${myconf} || die
+
+ JAVACFLAGS="$(java-pkg_javac-args)" emake || die "emake failed"
+ if use java && use doc; then
+ cd ./bind/pdflib/java || die
+ emake javadoc || die "Failed to generate javadoc"
+ fi
+}
+
+src_install() {
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ "${S}/bind/pdflib/perl/Makefile" \
+ || die "sed bind/pdflib/perl/Makefile failed"
+
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ "${S}/bind/pdflib/python/Makefile" \
+ || die "sed bind/pdflib/python/Makefile failed"
+
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ "${S}/bind/pdflib/tcl/Makefile" \
+ || die "sed bind/pdflib/tcl/Makefile failed"
+
+ # ok, this should create the correct lib dirs for perl and python.
+ # yes, i know it is messy, but as i see it, a ebuild should be generic
+ # ... ie. you should be able to just use cp to update it
+ if use perl && [ -x /usr/bin/perl ] ; then
+ local perlmajver="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 4 |cut -d '.' -f 1`"
+ local perlver="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 4`"
+ local perlarch="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 7`"
+ dodir /usr/$(get_libdir)/perl${perlmajver/v/}/site_perl/${perlver/v/}/${perlarch}
+ fi
+ if use python && [ -x /usr/bin/python ] ; then
+ dodir /usr/$(get_libdir)/python${PYVER}/lib-dynload
+ fi
+ #next line required for proper install
+ dodir /usr/bin
+ einstall || die
+
+ dodoc readme.txt doc/*
+ docinto pdflib
+ dodoc doc/pdflib/*
+
+ # seemant: seems like the makefiles for pdflib generate the .jar file
+ # anyway
+ use java && java-pkg_dojar bind/pdflib/java/pdflib.jar
+ if use java && use doc; then
+ java-pkg_dojavadoc ./bind/pdflib/java/javadoc
+ fi
+}