summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-12-06 21:02:25 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-12-06 21:02:25 +0000
commitd6e8f1973c8df679b7f316e93b6a04e6f7d71449 (patch)
treed9920e5326bfdf86fb472fccf7ad7e9cc3cfaebf
parentAdd fix for ebuilds that error out on unknown src_configure error (diff)
downloadgentoo-2-d6e8f1973c8df679b7f316e93b6a04e6f7d71449.tar.gz
gentoo-2-d6e8f1973c8df679b7f316e93b6a04e6f7d71449.tar.bz2
gentoo-2-d6e8f1973c8df679b7f316e93b6a04e6f7d71449.zip
bump to 2.20.2
(Portage version: 2.1.4_rc7)
-rw-r--r--www-client/epiphany/ChangeLog8
-rw-r--r--www-client/epiphany/epiphany-2.20.2.ebuild77
-rw-r--r--www-client/epiphany/files/digest-epiphany-2.20.23
3 files changed, 87 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 7cae690ed74e..6436283e1331 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.140 2007/12/04 20:20:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.141 2007/12/06 21:02:24 eva Exp $
+
+*epiphany-2.20.2 (06 Dec 2007)
+
+ 06 Dec 2007; Gilles Dartiguelongue <eva@gentoo.org>
+ +epiphany-2.20.2.ebuild:
+ bump to 2.20.2
04 Dec 2007; Jeroen Roovers <jer@gentoo.org> epiphany-2.20.1.ebuild:
Stable for HPPA (bug #199740).
diff --git a/www-client/epiphany/epiphany-2.20.2.ebuild b/www-client/epiphany/epiphany-2.20.2.ebuild
new file mode 100644
index 000000000000..51d2432eef23
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.20.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.20.2.ebuild,v 1.1 2007/12/06 21:02:24 eva Exp $
+
+inherit gnome2 eutils multilib
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc python xulrunner spell"
+
+# FIXME: add webkit/gecko switch possibility
+# dang: *after* webkit actually works.
+
+RDEPEND=">=dev-libs/glib-2.13.4
+ >=x11-libs/gtk+-2.11.6
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/gnome-vfs-2.9.2
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ !xulrunner? ( >=www-client/mozilla-firefox-1.5 )
+ xulrunner? ( net-libs/xulrunner )
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6 )
+ spell? ( app-text/enchant )
+ x11-themes/gnome-icon-theme"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.3.2
+ >=gnome-base/gnome-common-2.12.0
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --with-engine=mozilla
+ $(use_enable spell spell-checker)
+ $(use_enable python)"
+
+ if use xulrunner; then
+ G2CONF="${G2CONF} --with-gecko=xulrunner"
+ else
+ G2CONF="${G2CONF} --with-gecko=firefox"
+ fi
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/xulrunner/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+
+ gnome2_src_compile
+}
diff --git a/www-client/epiphany/files/digest-epiphany-2.20.2 b/www-client/epiphany/files/digest-epiphany-2.20.2
new file mode 100644
index 000000000000..225a4cf758d3
--- /dev/null
+++ b/www-client/epiphany/files/digest-epiphany-2.20.2
@@ -0,0 +1,3 @@
+MD5 587325089ee4bf21f7406d56b9add4ca epiphany-2.20.2.tar.bz2 4893519
+RMD160 52705c8352f0107a7103da018772319e16582416 epiphany-2.20.2.tar.bz2 4893519
+SHA256 1f48d127769a54dec1f4a67a1e267260f3519fb667d661d933f00b007f047fbd epiphany-2.20.2.tar.bz2 4893519