summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-04-10 16:28:05 +0000
committerJeroen Roovers <jer@gentoo.org>2012-04-10 16:28:05 +0000
commitd90e78526c88513d1e57febeeb59ee855c6f4b0c (patch)
treeeb9bc24ec879e85c3e6f5430d847ad69ab875001
parentBeta channel bump. (diff)
downloadgentoo-2-d90e78526c88513d1e57febeeb59ee855c6f4b0c.tar.gz
gentoo-2-d90e78526c88513d1e57febeeb59ee855c6f4b0c.tar.bz2
gentoo-2-d90e78526c88513d1e57febeeb59ee855c6f4b0c.zip
Fix building with USE="gtk -pcap" by Andreas Schürch (bug #411175).
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.6.6-gtk-pcap.patch30
-rw-r--r--net-analyzer/wireshark/wireshark-1.6.6.ebuild8
3 files changed, 41 insertions, 3 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 57d316ff6ea7..4c0ce914f2f4 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.330 2012/04/07 15:27:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.331 2012/04/10 16:28:05 jer Exp $
+
+ 10 Apr 2012; Jeroen Roovers <jer@gentoo.org> wireshark-1.6.6.ebuild,
+ +files/wireshark-1.6.6-gtk-pcap.patch:
+ Fix building with USE="gtk -pcap" by Andreas Schürch (bug #411175).
07 Apr 2012; Jeroen Roovers <jer@gentoo.org> wireshark-1.6.6.ebuild:
Stable for HPPA (bug #410871).
diff --git a/net-analyzer/wireshark/files/wireshark-1.6.6-gtk-pcap.patch b/net-analyzer/wireshark/files/wireshark-1.6.6-gtk-pcap.patch
new file mode 100644
index 000000000000..0727aa2f8ebe
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.6.6-gtk-pcap.patch
@@ -0,0 +1,30 @@
+--- a/gtk/main.c
++++ b/gtk/main.c
+@@ -2834,7 +2834,9 @@
+
+ color_filters_init();
+ decode_as_init();
++#ifdef HAVE_LIBPCAP
+ capture_filter_init();
++#endif
+
+ /* the window can be sized only, if it's not already shown, so do it now! */
+ main_load_window_geometry(top_level);--- a/gtk/capture_dlg.c
++++ b/gtk/capture_dlg.c
+@@ -371,6 +371,7 @@
+
+ /** Initialize background capture filter syntax checking
+ */
++#ifdef HAVE_LIBPCAP
+ void capture_filter_init(void) {
+ cfc_data.filter_text = NULL;
+ cfc_data.filter_te = NULL;
+@@ -383,6 +384,7 @@
+ g_thread_create(check_capture_filter_syntax, NULL, FALSE, NULL);
+ #endif
+ }
++#endif
+
+ static void
+ capture_filter_check_syntax_cb(GtkWidget *w _U_, gpointer user_data _U_)
+
diff --git a/net-analyzer/wireshark/wireshark-1.6.6.ebuild b/net-analyzer/wireshark/wireshark-1.6.6.ebuild
index af78ebef5b84..388db0fd6e0d 100644
--- a/net-analyzer/wireshark/wireshark-1.6.6.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.6.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.6.6.ebuild,v 1.3 2012/04/07 15:27:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.6.6.ebuild,v 1.4 2012/04/10 16:28:05 jer Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit libtool flag-o-matic eutils toolchain-funcs python
+inherit eutils flag-o-matic libtool python toolchain-funcs
[[ -n ${PV#*_rc} && ${PV#*_rc} != ${PV} ]] && MY_P=${PN}-${PV/_} || MY_P=${P}
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
@@ -102,6 +102,10 @@ pkg_setup() {
enewgroup wireshark
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gtk-pcap.patch
+}
+
src_configure() {
local myconf