summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-01-26 17:47:05 +0000
committerPacho Ramos <pacho@gentoo.org>2015-01-26 17:47:05 +0000
commite2215c22a46c2870323783816d985ed34cf7648f (patch)
tree324e51db452997551f612d548f89e9ca25d7bda4
parentclean old; tidy patching (diff)
downloadgentoo-2-e2215c22a46c2870323783816d985ed34cf7648f.tar.gz
gentoo-2-e2215c22a46c2870323783816d985ed34cf7648f.tar.bz2
gentoo-2-e2215c22a46c2870323783816d985ed34cf7648f.zip
Missing gdbus-codegen DEPEND (#537874 by Jan Vesely), apply some upstream patches for 3.14.x branch, drop old
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--x11-terms/gnome-terminal/ChangeLog12
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-3.14.2-fix-crash.patch26
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-3.14.2-title-option.patch166
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.14.2-r2.ebuild (renamed from x11-terms/gnome-terminal/gnome-terminal-3.14.2-r1.ebuild)13
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.14.2.ebuild69
5 files changed, 215 insertions, 71 deletions
diff --git a/x11-terms/gnome-terminal/ChangeLog b/x11-terms/gnome-terminal/ChangeLog
index 09d6bad66f47..67c420a6424b 100644
--- a/x11-terms/gnome-terminal/ChangeLog
+++ b/x11-terms/gnome-terminal/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-terms/gnome-terminal
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/ChangeLog,v 1.294 2015/01/23 09:35:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/ChangeLog,v 1.295 2015/01/26 17:47:05 pacho Exp $
+
+*gnome-terminal-3.14.2-r2 (26 Jan 2015)
+
+ 26 Jan 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/gnome-terminal-3.14.2-fix-crash.patch,
+ +files/gnome-terminal-3.14.2-title-option.patch,
+ +gnome-terminal-3.14.2-r2.ebuild, -gnome-terminal-3.14.2-r1.ebuild,
+ -gnome-terminal-3.14.2.ebuild:
+ Missing gdbus-codegen DEPEND (#537874 by Jan Vesely), apply some upstream
+ patches for 3.14.x branch, drop old
*gnome-terminal-3.14.2-r1 (23 Jan 2015)
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-3.14.2-fix-crash.patch b/x11-terms/gnome-terminal/files/gnome-terminal-3.14.2-fix-crash.patch
new file mode 100644
index 000000000000..40ddbc0e2d8f
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-3.14.2-fix-crash.patch
@@ -0,0 +1,26 @@
+From 664f1e9e8b224658c3f01a062517ad386129d953 Mon Sep 17 00:00:00 2001
+From: Egmont Koblinger <egmont@gmail.com>
+Date: Thu, 8 Jan 2015 14:33:13 +0100
+Subject: screen: Fix crash with empty child process command line
+
+https://bugzilla.gnome.org/show_bug.cgi?id=742560
+(cherry picked from commit 1c7ed77b003f14bb94527c8fe548c6c414c0da9e)
+
+diff --git a/src/terminal-screen.c b/src/terminal-screen.c
+index ad78388..9f63239 100644
+--- a/src/terminal-screen.c
++++ b/src/terminal-screen.c
+@@ -1904,7 +1904,9 @@ terminal_screen_has_foreground_process (TerminalScreen *screen,
+ if (process_name)
+ gs_transfer_out_value (process_name, &name);
+
+- for (i = 0; i < len - 1; i++)
++ if (len > 0 && data[len - 1] == '\0')
++ len--;
++ for (i = 0; i < len; i++)
+ {
+ if (data[i] == '\0')
+ data[i] = ' ';
+--
+cgit v0.10.1
+
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-3.14.2-title-option.patch b/x11-terms/gnome-terminal/files/gnome-terminal-3.14.2-title-option.patch
new file mode 100644
index 000000000000..1e3ddd3d94b4
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-3.14.2-title-option.patch
@@ -0,0 +1,166 @@
+From c730504aa3893978cdb667d7fcf1357d2951841e Mon Sep 17 00:00:00 2001
+From: Christian Persch <chpe@gnome.org>
+Date: Sat, 15 Nov 2014 21:11:08 +0100
+Subject: client: Hide obsolete --title option
+
+Accept it for compatibility, but ignore it.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=740188
+(cherry picked from commit 0033eca2909ddccf3358c1f089bce05d3473b123)
+
+diff --git a/src/gterminal.vala b/src/gterminal.vala
+index cf1ffae..7e55678 100644
+--- a/src/gterminal.vala
++++ b/src/gterminal.vala
+@@ -233,7 +233,6 @@ namespace GTerminal
+
+ public static string? working_directory = null;
+ public static string? profile = null;
+- public static string? title = null;
+ public static double zoom = 1.0;
+
+ private static bool option_profile (string option_name,
+@@ -269,8 +268,6 @@ namespace GTerminal
+ { "profile", 0, 0, OptionArg.CALLBACK, (void*) option_profile,
+ N_("Use the given profile instead of the default profile"),
+ N_("UUID") },
+- { "title", 0, 0, OptionArg.STRING, ref title,
+- N_("Set the terminal title"), N_("TITLE") },
+ { "cwd", 0, 0, OptionArg.FILENAME, ref working_directory,
+ N_("Set the working directory"), N_("DIRNAME") },
+ { "zoom", 0, 0, OptionArg.CALLBACK, (void*) option_zoom,
+@@ -418,7 +415,7 @@ namespace GTerminal
+ OpenOptions.geometry,
+ OpenOptions.role,
+ OpenOptions.profile,
+- OpenOptions.title,
++ null /* title */,
+ OpenOptions.maximise,
+ OpenOptions.fullscreen);
+ if (OpenOptions.show_menubar_set)
+diff --git a/src/terminal-options.c b/src/terminal-options.c
+index 75fc64d..0280f11 100644
+--- a/src/terminal-options.c
++++ b/src/terminal-options.c
+@@ -96,7 +96,6 @@ initial_tab_new (char *profile /* adopts */)
+
+ it->profile = profile;
+ it->exec_argv = NULL;
+- it->title = NULL;
+ it->working_dir = NULL;
+ it->zoom = 1.0;
+ it->zoom_set = FALSE;
+@@ -110,7 +109,6 @@ initial_tab_free (InitialTab *it)
+ {
+ g_free (it->profile);
+ g_strfreev (it->exec_argv);
+- g_free (it->title);
+ g_free (it->working_dir);
+ g_slice_free (InitialTab, it);
+ }
+@@ -596,30 +594,6 @@ option_load_config_cb (const gchar *option_name,
+ }
+
+ static gboolean
+-option_title_callback (const gchar *option_name,
+- const gchar *value,
+- gpointer data,
+- GError **error)
+-{
+- TerminalOptions *options = data;
+-
+- if (options->initial_windows)
+- {
+- InitialTab *it = ensure_top_tab (options);
+-
+- g_free (it->title);
+- it->title = g_strdup (value);
+- }
+- else
+- {
+- g_free (options->default_title);
+- options->default_title = g_strdup (value);
+- }
+-
+- return TRUE;
+-}
+-
+-static gboolean
+ option_working_directory_callback (const gchar *option_name,
+ const gchar *value,
+ gpointer data,
+@@ -789,7 +763,6 @@ terminal_options_parse (const char *working_directory,
+ options->initial_windows = NULL;
+ options->default_role = NULL;
+ options->default_geometry = NULL;
+- options->default_title = NULL;
+ options->zoom = 1.0;
+ options->zoom_set = FALSE;
+
+@@ -928,7 +901,6 @@ terminal_options_merge_config (TerminalOptions *options,
+ /* it->width = g_key_file_get_integer (key_file, tab_group, TERMINAL_CONFIG_TERMINAL_PROP_WIDTH, NULL);
+ it->height = g_key_file_get_integer (key_file, tab_group, TERMINAL_CONFIG_TERMINAL_PROP_HEIGHT, NULL);*/
+ it->working_dir = terminal_util_key_file_get_string_unescape (key_file, tab_group, TERMINAL_CONFIG_TERMINAL_PROP_WORKING_DIRECTORY, NULL);
+- it->title = g_key_file_get_string (key_file, tab_group, TERMINAL_CONFIG_TERMINAL_PROP_TITLE, NULL);
+
+ if (g_key_file_has_key (key_file, tab_group, TERMINAL_CONFIG_TERMINAL_PROP_COMMAND, NULL) &&
+ !(it->exec_argv = terminal_util_key_file_get_argv (key_file, tab_group, TERMINAL_CONFIG_TERMINAL_PROP_COMMAND, NULL, error)))
+@@ -985,7 +957,6 @@ terminal_options_free (TerminalOptions *options)
+ g_free (options->default_role);
+ g_free (options->default_geometry);
+ g_free (options->default_working_dir);
+- g_free (options->default_title);
+ g_free (options->default_profile);
+
+ g_strfreev (options->exec_argv);
+@@ -1156,11 +1127,10 @@ get_goption_context (TerminalOptions *options)
+ {
+ "title",
+ 't',
+- 0,
++ G_OPTION_FLAG_HIDDEN,
+ G_OPTION_ARG_CALLBACK,
+- option_title_callback,
+- N_("Set the terminal title"),
+- N_("TITLE")
++ unsupported_option_callback,
++ NULL, NULL
+ },
+ {
+ "working-directory",
+diff --git a/src/terminal-options.h b/src/terminal-options.h
+index a1e645b..17f42b4 100644
+--- a/src/terminal-options.h
++++ b/src/terminal-options.h
+@@ -75,7 +75,6 @@ typedef struct
+ char *default_role;
+ char *default_geometry;
+ char *default_working_dir;
+- char *default_title;
+ char **exec_argv;
+ char *default_profile;
+ gboolean default_profile_is_id;
+@@ -95,7 +94,6 @@ typedef struct
+ char *profile;
+ gboolean profile_is_id;
+ char **exec_argv;
+- char *title;
+ char *working_dir;
+ double zoom;
+ guint zoom_set : 1;
+diff --git a/src/terminal.c b/src/terminal.c
+index 2dd5a6d..b6a6f5e 100644
+--- a/src/terminal.c
++++ b/src/terminal.c
+@@ -102,7 +102,7 @@ handle_options (TerminalFactory *factory,
+ iw->geometry,
+ iw->role,
+ it->profile ? it->profile : options->default_profile,
+- it->title ? it->title : options->default_title,
++ NULL /* title */,
+ iw->start_maximized,
+ iw->start_fullscreen);
+
+--
+cgit v0.10.1
+
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.14.2-r1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.14.2-r2.ebuild
index 54aac5ca1987..f444ef361f53 100644
--- a/x11-terms/gnome-terminal/gnome-terminal-3.14.2-r1.ebuild
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.14.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-3.14.2-r1.ebuild,v 1.1 2015/01/23 09:35:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-3.14.2-r2.ebuild,v 1.1 2015/01/26 17:47:05 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -33,6 +33,7 @@ RDEPEND="
DEPEND="${RDEPEND}
app-text/yelp-tools
dev-util/appdata-tools
+ dev-util/gdbus-codegen
|| ( dev-util/gtk-builder-convert <=x11-libs/gtk+-2.24.10:2 )
>=dev-util/intltool-0.50
sys-devel/gettext
@@ -43,6 +44,16 @@ DOC_CONTENTS="To get previous working directory inherited in new opened
tab you will need to add the following line to your ~/.bashrc:\n
. /etc/profile.d/vte.sh"
+src_prepare() {
+ # client: Hide obsolete --title option (from '3.14')
+ epatch "${FILESDIR}/${P}-title-option.patch"
+
+ # screen: Fix crash with empty child process command line (from '3.14')
+ epatch "${FILESDIR}/${P}-fix-crash.patch"
+
+ gnome2_src_prepare
+}
+
src_configure() {
gnome2_src_configure \
--disable-static \
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.14.2.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.14.2.ebuild
deleted file mode 100644
index 99455f428dbd..000000000000
--- a/x11-terms/gnome-terminal/gnome-terminal-3.14.2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-3.14.2.ebuild,v 1.1 2014/12/23 23:31:46 eva Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2 readme.gentoo
-
-DESCRIPTION="The Gnome Terminal"
-HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"
-
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="debug +gnome-shell +nautilus"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
-
-# FIXME: automagic dependency on gtk+[X]
-RDEPEND="
- >=dev-libs/glib-2.40:2
- >=x11-libs/gtk+-3.10:3[X]
- >=x11-libs/vte-0.38:2.91
- >=gnome-base/dconf-0.14
- >=gnome-base/gconf-2.31.3
- >=gnome-base/gsettings-desktop-schemas-0.1.0
- sys-apps/util-linux
- x11-libs/libSM
- x11-libs/libICE
- gnome-shell? ( gnome-base/gnome-shell )
- nautilus? ( >=gnome-base/nautilus-3 )
-"
-# gtk+:2 needed for gtk-builder-convert, bug 356239
-DEPEND="${RDEPEND}
- app-text/yelp-tools
- dev-util/appdata-tools
- || ( dev-util/gtk-builder-convert <=x11-libs/gtk+-2.24.10:2 )
- >=dev-util/intltool-0.50
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-DOC_CONTENTS="To get previous working directory inherited in new opened
- tab you will need to add the following line to your ~/.bashrc:\n
- . /etc/profile.d/vte.sh"
-
-src_configure() {
- gnome2_src_configure \
- --disable-static \
- --enable-migration \
- $(use_enable debug) \
- $(use_enable gnome-shell search-provider) \
- $(use_with nautilus nautilus-extension) \
- VALAC=$(type -P true)
- # Docs are broken in this release.
- #ITSTOOL=$(type -P true) \
- #XMLLINT=$(type -P true)
-}
-
-src_install() {
- DOCS="AUTHORS ChangeLog HACKING NEWS"
- gnome2_src_install
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- readme.gentoo_print_elog
-}