summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-11-30 17:44:23 +0000
committerMike Gilbert <floppym@gentoo.org>2013-11-30 17:44:23 +0000
commite3f34e17945cbff744f010c074ae1ad5fe96045b (patch)
tree8fe6d9442c763681d640f22c4b848b0388c6a5dd
parentRemoved un-bundling of cglib/asm from mockito as it creates troubles with oth... (diff)
downloadgentoo-2-e3f34e17945cbff744f010c074ae1ad5fe96045b.tar.gz
gentoo-2-e3f34e17945cbff744f010c074ae1ad5fe96045b.tar.bz2
gentoo-2-e3f34e17945cbff744f010c074ae1ad5fe96045b.zip
Convert to distutils-r1. Feel free to copy me on any related bugs.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
-rw-r--r--x11-apps/fusion-icon/ChangeLog10
-rw-r--r--x11-apps/fusion-icon/fusion-icon-0.1-r4.ebuild47
2 files changed, 54 insertions, 3 deletions
diff --git a/x11-apps/fusion-icon/ChangeLog b/x11-apps/fusion-icon/ChangeLog
index 8fb6c10139e0..15217e4c8f63 100644
--- a/x11-apps/fusion-icon/ChangeLog
+++ b/x11-apps/fusion-icon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/fusion-icon
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/fusion-icon/ChangeLog,v 1.15 2012/09/07 08:26:41 pinkbyte Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/fusion-icon/ChangeLog,v 1.16 2013/11/30 17:44:23 floppym Exp $
+
+*fusion-icon-0.1-r4 (30 Nov 2013)
+
+ 30 Nov 2013; Mike Gilbert <floppym@gentoo.org> +fusion-icon-0.1-r4.ebuild:
+ Convert to distutils-r1. Feel free to copy me on any related bugs.
07 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> fusion-icon-0.1-r2.ebuild,
fusion-icon-0.1-r3.ebuild:
@@ -69,4 +74,3 @@
27 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+metadata.xml, +fusion-icon-0.1.ebuild:
Initial import of fusion-icon to the tree.
-
diff --git a/x11-apps/fusion-icon/fusion-icon-0.1-r4.ebuild b/x11-apps/fusion-icon/fusion-icon-0.1-r4.ebuild
new file mode 100644
index 000000000000..bb692090326d
--- /dev/null
+++ b/x11-apps/fusion-icon/fusion-icon-0.1-r4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/fusion-icon/fusion-icon-0.1-r4.ebuild,v 1.1 2013/11/30 17:44:23 floppym Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 eutils gnome2-utils
+
+MINIMUM_COMPIZ_RELEASE=0.6.0
+
+DESCRIPTION="Compiz Fusion Tray Icon and Manager"
+HOMEPAGE="http://compiz.org"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk qt4"
+
+REQUIRED_USE="|| ( gtk qt4 )"
+
+RDEPEND="
+ >=dev-python/compizconfig-python-${MINIMUM_COMPIZ_RELEASE}
+ >=x11-wm/compiz-${MINIMUM_COMPIZ_RELEASE}
+ x11-apps/xvinfo
+ gtk? ( >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}] )
+ qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${P}-qt4-interface-subprocess-call.patch )
+
+python_install() {
+ distutils-r1_python_install
+ use gtk || rm -r "${D}$(python_get_sitedir)/FusionIcon/interface_gtk" || die
+ use qt4 || rm -r "${D}$(python_get_sitedir)/FusionIcon/interface_qt4" || die
+}
+
+pkg_postinst() {
+ use gtk && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && gnome2_icon_cache_update
+}