summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-03-15 03:53:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-03-15 03:53:59 +0000
commite9d7e0c11383831f7a9d43a2600ee16ffed3d287 (patch)
treebc17cc6772c850301b00baa5b57eb1809159c26e
parentFix use flags, add ~x86 (tsunam) (diff)
downloadgentoo-2-e9d7e0c11383831f7a9d43a2600ee16ffed3d287.tar.gz
gentoo-2-e9d7e0c11383831f7a9d43a2600ee16ffed3d287.tar.bz2
gentoo-2-e9d7e0c11383831f7a9d43a2600ee16ffed3d287.zip
version bump
(Portage version: 2.1.4.4)
-rw-r--r--games-puzzle/monsterz/ChangeLog10
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch20
-rw-r--r--games-puzzle/monsterz/monsterz-0.7.1.ebuild43
3 files changed, 71 insertions, 2 deletions
diff --git a/games-puzzle/monsterz/ChangeLog b/games-puzzle/monsterz/ChangeLog
index 517925ba822e..70ec7e54218d 100644
--- a/games-puzzle/monsterz/ChangeLog
+++ b/games-puzzle/monsterz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/monsterz
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.14 2007/06/25 15:50:32 jer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.15 2008/03/15 03:53:58 mr_bones_ Exp $
+
+*monsterz-0.7.1 (15 Mar 2008)
+
+ 15 Mar 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/monsterz-0.7.1-gentoo.patch, +monsterz-0.7.1.ebuild:
+ version bump
25 Jun 2007; Jeroen Roovers <jer@gentoo.org> monsterz-0.7.0.ebuild:
Stable for HPPA too.
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch
new file mode 100644
index 000000000000..652450bf190b
--- /dev/null
+++ b/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch
@@ -0,0 +1,20 @@
+--- monsterz.py.orig 2006-05-12 18:55:51.000000000 -0400
++++ monsterz.py 2006-05-12 18:57:44.000000000 -0400
+@@ -1907,7 +1906,7 @@
+ print ' (C) Mike Kershaw <dragorn@kismetwireless.net>'
+
+ print 'This program is free software; you can redistribute it and/or modify it under'
+- print 'the terms of the Do What The Fuck You Want To Public License, Version 2, as'
++ print 'the terms of the WTFPL, Version 2, as'
+ print 'published by Sam Hocevar. See http://sam.zoy.org/wtfpl/ for more details.'
+ print 'The sound effects are released under their own licences: applause.wav and'
+ print 'pop.wav are covered by the LGPL, the others are covered by the GPL.'
+@@ -1932,7 +1931,7 @@
+ global system, data, settings, fonter, monsterz
+ override = {}
+ scorefile = None
+- sharedir = dirname(argv[0])
++ sharedir = "GENTOO_DATADIR"
+ outfd = None
+ try:
+ long = ['help', 'version', 'music', 'sound', 'fullscreen',
diff --git a/games-puzzle/monsterz/monsterz-0.7.1.ebuild b/games-puzzle/monsterz/monsterz-0.7.1.ebuild
new file mode 100644
index 000000000000..df9383ebc599
--- /dev/null
+++ b/games-puzzle/monsterz/monsterz-0.7.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/monsterz-0.7.1.ebuild,v 1.1 2008/03/15 03:53:58 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="a little puzzle game, similar to the famous Bejeweled or Zookeeper"
+HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
+SRC_URI="http://sam.zoy.org/projects/monsterz/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygame"
+
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer mikmod ; then
+ die "${PN} requires that media-libs/sdl-mixer be built with USE=mikmod"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ monsterz.py || die "sed failed"
+}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/${PN}
+ insinto "${dir}"
+ doins -r graphics sound || die "doins failed"
+ newgamesbin monsterz.py ${PN} || die "newgamesbin failed"
+ newicon graphics/icon.png ${PN}.png
+ make_desktop_entry ${PN} Monsterz
+ dodoc README AUTHORS TODO
+ prepgamesdirs
+}