summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-16 04:59:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-16 04:59:03 +0000
commitebd9f45a6c5a6856b527faecd75fe53590e036f3 (patch)
tree997b8205810b50387e037a5270c1526687c9bdfe
parentapp-laptop moves for ppc dependancy fix (Manifest recommit) (diff)
downloadgentoo-2-ebd9f45a6c5a6856b527faecd75fe53590e036f3.tar.gz
gentoo-2-ebd9f45a6c5a6856b527faecd75fe53590e036f3.tar.bz2
gentoo-2-ebd9f45a6c5a6856b527faecd75fe53590e036f3.zip
clean extra ebuilds
-rw-r--r--app-admin/amanda/ChangeLog6
-rw-r--r--app-admin/amanda/amanda-2.4.4-r1.ebuild337
-rw-r--r--app-admin/amanda/amanda-2.4.4-r2.ebuild335
-rw-r--r--app-admin/amanda/amanda-2.4.4.ebuild233
-rw-r--r--app-admin/amanda/files/digest-amanda-2.4.41
-rw-r--r--app-admin/amanda/files/digest-amanda-2.4.4-r11
-rw-r--r--app-admin/amanda/files/digest-amanda-2.4.4-r21
7 files changed, 5 insertions, 909 deletions
diff --git a/app-admin/amanda/ChangeLog b/app-admin/amanda/ChangeLog
index c146b78de24e..33006f854df1 100644
--- a/app-admin/amanda/ChangeLog
+++ b/app-admin/amanda/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/amanda
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/amanda/ChangeLog,v 1.11 2004/01/07 08:59:07 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/amanda/ChangeLog,v 1.12 2004/03/16 04:59:03 mr_bones_ Exp $
+
+ 15 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> amanda-2.4.4-r1.ebuild,
+ amanda-2.4.4-r2.ebuild, amanda-2.4.4.ebuild:
+ clean extra ebuilds
*amanda-2.4.4-r3 (07 Jan 2004)
diff --git a/app-admin/amanda/amanda-2.4.4-r1.ebuild b/app-admin/amanda/amanda-2.4.4-r1.ebuild
deleted file mode 100644
index be5acfd0bfb4..000000000000
--- a/app-admin/amanda/amanda-2.4.4-r1.ebuild
+++ /dev/null
@@ -1,337 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/amanda/amanda-2.4.4-r1.ebuild,v 1.13 2004/01/07 08:59:07 robbat2 Exp $
-
-inherit eutils
-
-DESCRIPTION="The Advanced Maryland Automatic Network Disk Archiver"
-HOMEPAGE="http://www.amanda.org/"
-SRC_URI="mirror://sourceforge/amanda/${P}.tar.gz"
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="x86 ~ppc -sparc"
-DEPEND="sys-libs/readline
- virtual/inetd
- virtual/mta
- app-arch/mt-st
- net-mail/mailx
- media-gfx/gnuplot
- sys-apps/gawk
- app-arch/tar
- sys-devel/autoconf
- sys-devel/automake
- dev-lang/perl
- sys-apps/mtx
- app-arch/dump
- net-mail/mailx
- samba? ( net-fs/samba )
- berkdb? ( sys-libs/db )
- gdbm? ( sys-libs/gdbm )
- xfs? ( sys-fs/xfsdump )"
-
-IUSE="pic debug gdbm berkdb samba xfs"
-
-S=${WORKDIR}/${P}
-MYFILESDIR=${WORKDIR}/files
-MYTMPDIR=${WORKDIR}/tmp
-ENVDIR="/etc/env.d"
-ENVDFILE="97amanda"
-TMPENVFILE="${MYTMPDIR}/${ENVDFILE}"
-
-amanda_variable_setup() {
-
- # Setting vars
- local currentamanda
-
- # Grab the current settings
- currentamanda="$(set | egrep "^AMANDA_" | xargs)"
- use debug && einfo "Current settings: ${currentamanda}"
- #for i in ${currentamanda}; do
- # eval `eval echo ${i}`
- # echo "Setting: ${i}"
- #done;
-
- # First we set the defaults
- [ -z "${AMANDA_GROUP_GID}" ] && AMANDA_GROUP_GID=87
- [ -z "${AMANDA_GROUP_NAME}" ] && AMANDA_GROUP_NAME=amanda
- [ -z "${AMANDA_USER_NAME}" ] && AMANDA_USER_NAME=amanda
- [ -z "${AMANDA_USER_UID}" ] && AMANDA_USER_UID=87
- [ -z "${AMANDA_USER_SH}" ] && AMANDA_USER_SH=/bin/false
- [ -z "${AMANDA_USER_HOMEDIR}" ] && AMANDA_USER_HOMEDIR=/var/spool/amanda
- [ -z "${AMANDA_USER_GROUPS}" ] && AMANDA_USER_GROUPS=${AMANDA_GROUP_NAME}
- # This installs Amanda, with the server. However, it could be a client,
- # just specify an alternate server name in AMANDA_SERVER.
- [ -z "${AMANDA_SERVER}" ] && AMANDA_SERVER=localhost
- [ -z "${AMANDA_SERVER_TAPE}" ] && AMANDA_SERVER_TAPE="${AMANDA_SERVER}"
- [ -z "${AMANDA_SERVER_INDEX}" ] && AMANDA_SERVER_INDEX="${AMANDA_SERVER}"
- [ -z "${AMANDA_TAR_LISTDIR}" ] && AMANDA_TAR_LISTDIR=${AMANDA_USER_HOMEDIR}/tar-lists
- [ -z "${AMANDA_CONFIG_NAME}" ] && AMANDA_CONFIG_NAME=DailySet1
- [ -z "${AMANDA_TMPDIR}" ] && AMANDA_TMPDIR=${AMANDA_USER_HOMEDIR}/tmp
- # These are left empty by default
- [ -z "${AMANDA_PORTS_UDP}" ] && AMANDA_PORTS_UDP=
- [ -z "${AMANDA_PORTS_TCP}" ] && AMANDA_PORTS_TCP=
- [ -z "${AMANDA_PORTS_BOTH}" ] && AMANDA_PORTS_BOTH=
- [ -z "${AMANDA_PORTS}" ] && AMANDA_PORTS=
-
- # This one is a little more complicated
- # The priority list is this:
- # 1. 'Berkely DB style' (only if USE="berkdb")
- # 2. 'GDBM style' (only if USE="gdbm")
- # 3. 'Text style'
- [ -z "${AMANDA_DBMODE}" ] && use berkdb && AMANDA_DBMODE=db
- [ -z "${AMANDA_DBMODE}" ] && use gdbm && AMANDA_DBMODE=gdbm
- [ -z "${AMANDA_DBMODE}" ] && AMANDA_DBMODE=text
-
- # Now pull in the old stuff
- if [ -f "${ENVDFILE}" ]; then
- # We don't just source it as we don't want everything in there.
- eval $(egrep "^AMANDA_" ${ENVDIR}/${ENVDFILE})
- fi
-
- # Re-apply the new settings if any
- [ -n "${currentamanda}" ] && eval `echo "${currentamanda}"`
-
-}
-
-pkg_setup() {
- # Now add users if needed
- amanda_variable_setup
- enewgroup ${AMANDA_GROUP_NAME} ${AMANDA_GROUP_GID}
- enewuser ${AMANDA_USER_NAME} ${AMANDA_USER_UID} ${AMANDA_USER_SH} ${AMANDA_USER_HOMEDIR} ${AMANDA_USER_GROUPS}
-}
-
-src_unpack() {
- unpack ${A}
- amanda_variable_setup
- # places for us to work in
- mkdir -p ${MYFILESDIR} ${MYTMPDIR}
- # Now we store the settings we just created
- set | egrep "^AMANDA_" > ${TMPENVFILE}
-}
-
-src_compile() {
- # fix bug #36316
- addpredict /var/cache/samba/gencache.tdb
-
- [ ! -f "${TMPENVFILE}" ] && die "Variable setting file (${TMPENVFILE}) should exist!"
- source ${TMPENVFILE}
- local myconf
- cd ${S}
-
- einfo "Using '${AMANDA_DBMODE}' style database"
- myconf="${myconf} --with-db=${AMANDA_DBMODE}"
-
- einfo "Using ${AMANDA_SERVER_TAPE} for tape server."
- myconf="${myconf} --with-tape-server=${AMANDA_SERVER_TAPE}"
- einfo "Using ${AMANDA_SERVER_INDEX} for index server."
- myconf="${myconf} --with-index-server=${AMANDA_SERVER_TAPE}"
- einfo "Using ${AMANDA_USER_NAME} for amanda user."
- myconf="${myconf} --with-user=${AMANDA_USER_NAME}"
- einfo "Using ${AMANDA_GROUP_NAME} for amanda group."
- myconf="${myconf} --with-group=${AMANDA_GROUP_NAME}"
- einfo "Using ${AMANDA_TAR_LISTDIR} as tar listdir."
- myconf="${myconf} --with-gnutar-listdir=${AMANDA_TAR_LISTDIR}"
- einfo "Using ${AMANDA_CONFIG_NAME} as default config name."
- myconf="${myconf} --with-config=${AMANDA_CONFIG_NAME}"
- einfo "Using ${AMANDA_TMPDIR} as Amanda temporary directory."
- myconf="${myconf} --with-tmpdir=${AMANDA_TMPDIR}"
-
- if [ -n "${AMANDA_PORTS_UDP}" ] && [ -n "${AMANDA_PORTS_TCP}" ] && [ -z "${AMANDA_PORTS_BOTH}" ] ; then
- eerror "If you want _both_ UDP and TCP ports, please use only the"
- eerror "AMANDA_PORTS environment variable for identical ports, or set"
- eerror "AMANDA_PORTS_BOTH."
- die "Bad port setup!"
- fi
- if [ -n "${AMANDA_PORTS_UDP}" ]; then
- einfo "Using UDP ports ${AMANDA_PORTS_UDP/,/-}"
- myconf="${myconf} --with-udpportrange=${AMANDA_PORTS_UDP}"
- fi
- if [ -n "${AMANDA_PORTS_TCP}" ]; then
- einfo "Using TCP ports ${AMANDA_PORTS_TCP/,/-}"
- myconf="${myconf} --with-tcpportrange=${AMANDA_PORTS_TCP}"
- fi
- if [ -n "${AMANDA_PORTS}" ]; then
- einfo "Using ports ${AMANDA_PORTS/,/-}"
- myconf="${myconf} --with-portrange=${AMANDA_PORTS}"
- fi
-
- # Extras
- # Speed option
- myconf="${myconf} --with-buffered-dump"
- # Debug
- myconf="${myconf} `use_with debug debugging`"
- # PIC
- myconf="${myconf} `use_with pic`"
- # Where to put our files
- myconf="${myconf} --localstatedir=${AMANDA_USER_HOMEDIR}"
-
- # Samba support
- use samba && myconf="${myconf} --with-smbclient=/usr/bin/smbclient" || myconf="${myconf} --without-smbclient"
-
- econf ${myconf} || die "econf failed!"
- emake || die "emake failed!"
-
- # Compile the tapetype program too
- # This is deprecated, use amtapetype instead!
- # cd tape-src
- # emake tapetype || die "emake tapetype failed!"
-
- # Only needed if you we do versioning
- #dosed "s,/usr/local/bin/perl,/usr/bin/perl," ${S}/contrib/set_prod_link.pl
- #perl ${S}/contrib/set_prod_link.pl
-
-}
-
-
-src_install() {
- [ ! -f "${TMPENVFILE}" ] && die "Variable setting file (${TMPENVFILE}) should exist!"
- source ${TMPENVFILE}
-
- einfo "Doing stock install"
- make DESTDIR=${D} install || die
-
- # Prepare our custom files
- einfo "Building custom configuration files"
- cp ${FILESDIR}/amanda-* ${MYFILESDIR}
- local i # our iterator
- local sedexpr # var for sed expr
- sedexpr=''
- for i in AMANDA_GROUP_GID AMANDA_GROUP_NAME AMANDA_USER_NAME AMANDA_USER_UID AMANDA_USER_SH AMANDA_USER_HOMEDIR AMANDA_USER_GROUPS AMANDA_SERVER AMANDA_SERVER_TAPE AMANDA_SERVER_INDEX AMANDA_TAR_LISTDIR AMANDA_CONFIG_NAME AMANDA_TMPDIR AMANDA_PORTS_UDP AMANDA_PORTS_TCP AMANDA_PORTS_BOTH AMANDA_PORTS; do
- local val
- eval "val=\"\${${i}}\""
- sedexpr="${sedexpr}s|__${i}__|${val}|g;"
- done
- #einfo "Compiled SED expression: '${sedexpr}'"
-
- # now apply the sed expr
- for i in ${FILESDIR}/amanda-* ; do
- local filename
- filename=`basename ${i}`
- #einfo "Applying compiled SED expression to ${filename}"
- sed -re "${sedexpr}" <${i} >${MYFILESDIR}/${filename}
- done
-
-
-
- # Build the envdir file
- # Don't forget this..
- einfo "Building environment file"
- echo "# These settings are what was present in the environment when this" >>${MYFILESDIR}/${ENVDFILE}
- echo "# Amanda was compiled. Changing anything below this comment will" >>${MYFILESDIR}/${ENVDFILE}
- echo "# have no effect on your application, but it merely exists to" >>${MYFILESDIR}/${ENVDFILE}
- echo "# preserve them for your next emerge of Amanda" >>${MYFILESDIR}/${ENVDFILE}
- cat ${TMPENVFILE} | sed "s,=\$,='',g" >>${MYFILESDIR}/${ENVDFILE}
-
- into /usr
-
- # Depreacted, use amtapetype instead
- #einfo "Installing tapetype utility"
- #newsbin tape-src/tapetype tapetype
-
- # docs
- einfo "Installing documentation"
- dodoc AUTHORS C* INSTALL NEWS README
- # Clean up some bits
- dodoc ${D}/usr/share/amanda/*
- rm -rf ${D}/usr/share/amanda
- # our inetd sample
- einfo "Installing standard inetd sample"
- dodoc ${MYFILESDIR}/amanda-inetd.amanda.sample
- # Stock extra docs
- docinto docs
- dodoc ${S}/docs/*
- # Labels
- einfo "Installing labels"
- docinto labels
- dodoc ${S}/example/3hole.ps
- dodoc ${S}/example/8.5x11.ps
- dodoc ${S}/example/DIN-A4.ps
- dodoc ${S}/example/DLT.ps
- dodoc ${S}/example/EXB-8500.ps
- dodoc ${S}/example/HP-DAT.ps
- # Amanda example configs
- einfo "Installing example configurations"
- docinto example
- dodoc ${S}/example/*
- docinto example1
- newdoc ${FILESDIR}/example_amanda.conf amanda.conf
- newdoc ${FILESDIR}/example_disklist disklist
- newdoc ${FILESDIR}/example_global.conf global.conf
- docinto example2
- newdoc ${S}/example/amanda.conf amanda.conf
- newdoc ${S}/example/disklist disklist
- # Compress it all
- prepalldocs
-
- # Just make sure it exists for XFS to work...
- use xfs && keepdir ${D}/var/xfsdump/inventory
-
- insinto /etc/amanda
- einfo "Installing .amandahosts File for ${AMANDA_USER_NAME} user"
- newins ${MYFILESDIR}/amanda-amandahosts amandahosts
- dosym /etc/amanda/amandahosts ${AMANDA_USER_HOMEDIR}/.amandahosts
- insinto ${AMANDA_USER_HOMEDIR}
- einfo "Installing .profile for ${AMANDA_USER_NAME} user"
- newins ${MYFILESDIR}/amanda-profile .profile
-
- einfo "Installing Sample Daily Cron Job for Amanda"
- CRONDIR=/etc/cron.daily/
- exeinto ${CRONDIR}
- newexe ${MYFILESDIR}/amanda-cron amanda
- # Not excetuable by default
- fperms 644 ${CRONDIR}/amanda
-
- insinto /etc/amanda/${AMANDA_CONFIG_NAME}
- keepdir /etc/amanda
- keepdir /etc/amanda/${AMANDA_CONFIG_NAME}
-
- local i
- for i in ${AMANDA_USER_HOMEDIR} ${AMANDA_TAR_LISTDIR} ${AMANDA_TMPDIR} ${AMANDA_TMPDIR}/dumps ${AMANDA_USER_HOMEDIR}/${AMANDA_CONFIG_NAME} /etc/amanda /etc/amanda/${AMANDA_CONFIG_NAME}; do
- einfo "Securing directory (${i})"
- dodir ${i}
- keepdir ${i}
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${i}
- fperms 700 ${i}
- done
-
- for i in amandates dumpdates; do
- einfo "Creating inital Amanda file (${i})"
- touch ${D}/etc/${i}
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} /etc/${i}
- fperms 600 /etc/${i}
- done
-
- # DevFS
- einfo "Installing DevFS config file"
- insinto /etc/devfs.d
- newins ${MYFILESDIR}/amanda-devfs amanda
-
- # Env.d
- einfo "Installing environment config file"
- insinto /etc/env.d
- doins ${MYFILESDIR}/${ENVDFILE}
-
- # Installing Amanda Xinetd Services Definition
- einfo "Installing xinetd service file"
- insinto /etc/xinetd.d
- newins ${MYFILESDIR}/amanda-xinetd amanda
-
-}
-
-pkg_postinst() {
- einfo "You should configure Amanda in /etc/amanda now."
- echo
- einfo "If you use xinetd, Don't forget to check /etc/xinetd.d/amanda"
- einfo "and restart xinetd afterwards!"
- echo
- einfo "Otherwise, please look at /usr/share/doc/${P}/inetd.amanda.sample"
- einfo "as an example of how to configure your inetd."
- echo
- einfo "NOTICE: If you need raw acces to partitions you need to add the"
- einfo "amanda user to the 'disk' group and uncomment following lines in"
- einfo "your /etc/devfs.d/amanda:"
- einfo "SCSI:"
- einfo "REGISTER ^scsi/host.*/bus.*/target.*/lun.*/part[0-9] PERMISSIONS root.disk 660"
- einfo "IDE:"
- einfo "REGISTER ^ide/host.*/bus.*/target.*/lun.*/part[0-9] PERMISSIONS root.disk 660"
-}
diff --git a/app-admin/amanda/amanda-2.4.4-r2.ebuild b/app-admin/amanda/amanda-2.4.4-r2.ebuild
deleted file mode 100644
index 34dc9b1f1bb3..000000000000
--- a/app-admin/amanda/amanda-2.4.4-r2.ebuild
+++ /dev/null
@@ -1,335 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/amanda/amanda-2.4.4-r2.ebuild,v 1.8 2004/01/07 08:59:07 robbat2 Exp $
-
-inherit eutils
-
-DESCRIPTION="The Advanced Maryland Automatic Network Disk Archiver"
-HOMEPAGE="http://www.amanda.org/"
-SRC_URI="mirror://sourceforge/amanda/${P}.tar.gz"
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="x86 ~ppc -sparc"
-DEPEND="sys-libs/readline
- virtual/inetd
- app-arch/mt-st
- media-gfx/gnuplot
- sys-apps/gawk
- app-arch/tar
- sys-devel/autoconf
- sys-devel/automake
- dev-lang/perl
- sys-apps/mtx
- app-arch/dump
- net-mail/mailx
- samba? ( net-fs/samba )
- berkdb? ( sys-libs/db )
- gdbm? ( sys-libs/gdbm )
- xfs? ( sys-fs/xfsdump )"
-
-IUSE="pic debug gdbm berkdb samba xfs"
-
-S=${WORKDIR}/${P}
-MYFILESDIR=${WORKDIR}/files
-MYTMPDIR=${WORKDIR}/tmp
-ENVDIR="/etc/env.d"
-ENVDFILE="97amanda"
-TMPENVFILE="${MYTMPDIR}/${ENVDFILE}"
-
-amanda_variable_setup() {
-
- # Setting vars
- local currentamanda
-
- # Grab the current settings
- currentamanda="$(set | egrep "^AMANDA_" | xargs)"
- use debug && einfo "Current settings: ${currentamanda}"
- #for i in ${currentamanda}; do
- # eval `eval echo ${i}`
- # echo "Setting: ${i}"
- #done;
-
- # First we set the defaults
- [ -z "${AMANDA_GROUP_GID}" ] && AMANDA_GROUP_GID=87
- [ -z "${AMANDA_GROUP_NAME}" ] && AMANDA_GROUP_NAME=amanda
- [ -z "${AMANDA_USER_NAME}" ] && AMANDA_USER_NAME=amanda
- [ -z "${AMANDA_USER_UID}" ] && AMANDA_USER_UID=87
- [ -z "${AMANDA_USER_SH}" ] && AMANDA_USER_SH=/bin/false
- [ -z "${AMANDA_USER_HOMEDIR}" ] && AMANDA_USER_HOMEDIR=/var/spool/amanda
- [ -z "${AMANDA_USER_GROUPS}" ] && AMANDA_USER_GROUPS=${AMANDA_GROUP_NAME}
- # This installs Amanda, with the server. However, it could be a client,
- # just specify an alternate server name in AMANDA_SERVER.
- [ -z "${AMANDA_SERVER}" ] && AMANDA_SERVER=localhost
- [ -z "${AMANDA_SERVER_TAPE}" ] && AMANDA_SERVER_TAPE="${AMANDA_SERVER}"
- [ -z "${AMANDA_SERVER_INDEX}" ] && AMANDA_SERVER_INDEX="${AMANDA_SERVER}"
- [ -z "${AMANDA_TAR_LISTDIR}" ] && AMANDA_TAR_LISTDIR=${AMANDA_USER_HOMEDIR}/tar-lists
- [ -z "${AMANDA_CONFIG_NAME}" ] && AMANDA_CONFIG_NAME=DailySet1
- [ -z "${AMANDA_TMPDIR}" ] && AMANDA_TMPDIR=${AMANDA_USER_HOMEDIR}/tmp
- # These are left empty by default
- [ -z "${AMANDA_PORTS_UDP}" ] && AMANDA_PORTS_UDP=
- [ -z "${AMANDA_PORTS_TCP}" ] && AMANDA_PORTS_TCP=
- [ -z "${AMANDA_PORTS_BOTH}" ] && AMANDA_PORTS_BOTH=
- [ -z "${AMANDA_PORTS}" ] && AMANDA_PORTS=
-
- # This one is a little more complicated
- # The priority list is this:
- # 1. 'Berkely DB style' (only if USE="berkdb")
- # 2. 'GDBM style' (only if USE="gdbm")
- # 3. 'Text style'
- [ -z "${AMANDA_DBMODE}" ] && use berkdb && AMANDA_DBMODE=db
- [ -z "${AMANDA_DBMODE}" ] && use gdbm && AMANDA_DBMODE=gdbm
- [ -z "${AMANDA_DBMODE}" ] && AMANDA_DBMODE=text
-
- # Now pull in the old stuff
- if [ -f "${ENVDIR}/${ENVDFILE}" ]; then
- # We don't just source it as we don't want everything in there.
- eval $(egrep "^AMANDA_" ${ENVDIR}/${ENVDFILE})
- fi
-
- # Re-apply the new settings if any
- [ -n "${currentamanda}" ] && eval `echo "${currentamanda}"`
-
-}
-
-pkg_setup() {
- # Now add users if needed
- amanda_variable_setup
- enewgroup ${AMANDA_GROUP_NAME} ${AMANDA_GROUP_GID}
- enewuser ${AMANDA_USER_NAME} ${AMANDA_USER_UID} ${AMANDA_USER_SH} ${AMANDA_USER_HOMEDIR} ${AMANDA_USER_GROUPS}
-}
-
-src_unpack() {
- unpack ${A}
- amanda_variable_setup
- # places for us to work in
- mkdir -p ${MYFILESDIR} ${MYTMPDIR}
- # Now we store the settings we just created
- set | egrep "^AMANDA_" > ${TMPENVFILE}
-}
-
-src_compile() {
- # fix bug #36316
- addpredict /var/cache/samba/gencache.tdb
-
- [ ! -f "${TMPENVFILE}" ] && die "Variable setting file (${TMPENVFILE}) should exist!"
- source ${TMPENVFILE}
- local myconf
- cd ${S}
-
- einfo "Using '${AMANDA_DBMODE}' style database"
- myconf="${myconf} --with-db=${AMANDA_DBMODE}"
-
- einfo "Using ${AMANDA_SERVER_TAPE} for tape server."
- myconf="${myconf} --with-tape-server=${AMANDA_SERVER_TAPE}"
- einfo "Using ${AMANDA_SERVER_INDEX} for index server."
- myconf="${myconf} --with-index-server=${AMANDA_SERVER_TAPE}"
- einfo "Using ${AMANDA_USER_NAME} for amanda user."
- myconf="${myconf} --with-user=${AMANDA_USER_NAME}"
- einfo "Using ${AMANDA_GROUP_NAME} for amanda group."
- myconf="${myconf} --with-group=${AMANDA_GROUP_NAME}"
- einfo "Using ${AMANDA_TAR_LISTDIR} as tar listdir."
- myconf="${myconf} --with-gnutar-listdir=${AMANDA_TAR_LISTDIR}"
- einfo "Using ${AMANDA_CONFIG_NAME} as default config name."
- myconf="${myconf} --with-config=${AMANDA_CONFIG_NAME}"
- einfo "Using ${AMANDA_TMPDIR} as Amanda temporary directory."
- myconf="${myconf} --with-tmpdir=${AMANDA_TMPDIR}"
-
- if [ -n "${AMANDA_PORTS_UDP}" ] && [ -n "${AMANDA_PORTS_TCP}" ] && [ -z "${AMANDA_PORTS_BOTH}" ] ; then
- eerror "If you want _both_ UDP and TCP ports, please use only the"
- eerror "AMANDA_PORTS environment variable for identical ports, or set"
- eerror "AMANDA_PORTS_BOTH."
- die "Bad port setup!"
- fi
- if [ -n "${AMANDA_PORTS_UDP}" ]; then
- einfo "Using UDP ports ${AMANDA_PORTS_UDP/,/-}"
- myconf="${myconf} --with-udpportrange=${AMANDA_PORTS_UDP}"
- fi
- if [ -n "${AMANDA_PORTS_TCP}" ]; then
- einfo "Using TCP ports ${AMANDA_PORTS_TCP/,/-}"
- myconf="${myconf} --with-tcpportrange=${AMANDA_PORTS_TCP}"
- fi
- if [ -n "${AMANDA_PORTS}" ]; then
- einfo "Using ports ${AMANDA_PORTS/,/-}"
- myconf="${myconf} --with-portrange=${AMANDA_PORTS}"
- fi
-
- # Extras
- # Speed option
- myconf="${myconf} --with-buffered-dump"
- # Debug
- myconf="${myconf} `use_with debug debugging`"
- # PIC
- myconf="${myconf} `use_with pic`"
- # Where to put our files
- myconf="${myconf} --localstatedir=${AMANDA_USER_HOMEDIR}"
-
- # Samba support
- use samba && myconf="${myconf} --with-smbclient=/usr/bin/smbclient" || myconf="${myconf} --without-smbclient"
-
- econf ${myconf} || die "econf failed!"
- emake || die "emake failed!"
-
- # Compile the tapetype program too
- # This is deprecated, use amtapetype instead!
- # cd tape-src
- # emake tapetype || die "emake tapetype failed!"
-
- # Only needed if you we do versioning
- #dosed "s,/usr/local/bin/perl,/usr/bin/perl," ${S}/contrib/set_prod_link.pl
- #perl ${S}/contrib/set_prod_link.pl
-
-}
-
-
-src_install() {
- [ ! -f "${TMPENVFILE}" ] && die "Variable setting file (${TMPENVFILE}) should exist!"
- source ${TMPENVFILE}
-
- einfo "Doing stock install"
- make DESTDIR=${D} install || die
-
- # Prepare our custom files
- einfo "Building custom configuration files"
- cp ${FILESDIR}/amanda-* ${MYFILESDIR}
- local i # our iterator
- local sedexpr # var for sed expr
- sedexpr=''
- for i in AMANDA_GROUP_GID AMANDA_GROUP_NAME AMANDA_USER_NAME AMANDA_USER_UID AMANDA_USER_SH AMANDA_USER_HOMEDIR AMANDA_USER_GROUPS AMANDA_SERVER AMANDA_SERVER_TAPE AMANDA_SERVER_INDEX AMANDA_TAR_LISTDIR AMANDA_CONFIG_NAME AMANDA_TMPDIR AMANDA_PORTS_UDP AMANDA_PORTS_TCP AMANDA_PORTS_BOTH AMANDA_PORTS; do
- local val
- eval "val=\"\${${i}}\""
- sedexpr="${sedexpr}s|__${i}__|${val}|g;"
- done
- #einfo "Compiled SED expression: '${sedexpr}'"
-
- # now apply the sed expr
- for i in ${FILESDIR}/amanda-* ; do
- local filename
- filename=`basename ${i}`
- #einfo "Applying compiled SED expression to ${filename}"
- sed -re "${sedexpr}" <${i} >${MYFILESDIR}/${filename}
- done
-
-
-
- # Build the envdir file
- # Don't forget this..
- einfo "Building environment file"
- echo "# These settings are what was present in the environment when this" >>${MYFILESDIR}/${ENVDFILE}
- echo "# Amanda was compiled. Changing anything below this comment will" >>${MYFILESDIR}/${ENVDFILE}
- echo "# have no effect on your application, but it merely exists to" >>${MYFILESDIR}/${ENVDFILE}
- echo "# preserve them for your next emerge of Amanda" >>${MYFILESDIR}/${ENVDFILE}
- cat ${TMPENVFILE} | sed "s,=\$,='',g" >>${MYFILESDIR}/${ENVDFILE}
-
- into /usr
-
- # Depreacted, use amtapetype instead
- #einfo "Installing tapetype utility"
- #newsbin tape-src/tapetype tapetype
-
- # docs
- einfo "Installing documentation"
- dodoc AUTHORS C* INSTALL NEWS README
- # Clean up some bits
- dodoc ${D}/usr/share/amanda/*
- rm -rf ${D}/usr/share/amanda
- # our inetd sample
- einfo "Installing standard inetd sample"
- dodoc ${MYFILESDIR}/amanda-inetd.amanda.sample
- # Stock extra docs
- docinto docs
- dodoc ${S}/docs/*
- # Labels
- einfo "Installing labels"
- docinto labels
- dodoc ${S}/example/3hole.ps
- dodoc ${S}/example/8.5x11.ps
- dodoc ${S}/example/DIN-A4.ps
- dodoc ${S}/example/DLT.ps
- dodoc ${S}/example/EXB-8500.ps
- dodoc ${S}/example/HP-DAT.ps
- # Amanda example configs
- einfo "Installing example configurations"
- docinto example
- dodoc ${S}/example/*
- docinto example1
- newdoc ${FILESDIR}/example_amanda.conf amanda.conf
- newdoc ${FILESDIR}/example_disklist disklist
- newdoc ${FILESDIR}/example_global.conf global.conf
- docinto example2
- newdoc ${S}/example/amanda.conf amanda.conf
- newdoc ${S}/example/disklist disklist
- # Compress it all
- prepalldocs
-
- # Just make sure it exists for XFS to work...
- use xfs && keepdir ${D}/var/xfsdump/inventory
-
- insinto /etc/amanda
- einfo "Installing .amandahosts File for ${AMANDA_USER_NAME} user"
- newins ${MYFILESDIR}/amanda-amandahosts amandahosts
- dosym /etc/amanda/amandahosts ${AMANDA_USER_HOMEDIR}/.amandahosts
- insinto ${AMANDA_USER_HOMEDIR}
- einfo "Installing .profile for ${AMANDA_USER_NAME} user"
- newins ${MYFILESDIR}/amanda-profile .profile
-
- einfo "Installing Sample Daily Cron Job for Amanda"
- CRONDIR=/etc/cron.daily/
- exeinto ${CRONDIR}
- newexe ${MYFILESDIR}/amanda-cron amanda
- # Not excetuable by default
- fperms 644 ${CRONDIR}/amanda
-
- insinto /etc/amanda/${AMANDA_CONFIG_NAME}
- keepdir /etc/amanda
- keepdir /etc/amanda/${AMANDA_CONFIG_NAME}
-
- local i
- for i in ${AMANDA_USER_HOMEDIR} ${AMANDA_TAR_LISTDIR} ${AMANDA_TMPDIR} ${AMANDA_TMPDIR}/dumps ${AMANDA_USER_HOMEDIR}/${AMANDA_CONFIG_NAME} /etc/amanda /etc/amanda/${AMANDA_CONFIG_NAME}; do
- einfo "Securing directory (${i})"
- dodir ${i}
- keepdir ${i}
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${i}
- fperms 700 ${i}
- done
-
- for i in amandates dumpdates; do
- einfo "Creating inital Amanda file (${i})"
- touch ${D}/etc/${i}
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} /etc/${i}
- fperms 600 /etc/${i}
- done
-
- # DevFS
- einfo "Installing DevFS config file"
- insinto /etc/devfs.d
- newins ${MYFILESDIR}/amanda-devfs amanda
-
- # Env.d
- einfo "Installing environment config file"
- insinto /etc/env.d
- doins ${MYFILESDIR}/${ENVDFILE}
-
- # Installing Amanda Xinetd Services Definition
- einfo "Installing xinetd service file"
- insinto /etc/xinetd.d
- newins ${MYFILESDIR}/amanda-xinetd amanda
-
-}
-
-pkg_postinst() {
- einfo "You should configure Amanda in /etc/amanda now."
- echo
- einfo "If you use xinetd, Don't forget to check /etc/xinetd.d/amanda"
- einfo "and restart xinetd afterwards!"
- echo
- einfo "Otherwise, please look at /usr/share/doc/${P}/inetd.amanda.sample"
- einfo "as an example of how to configure your inetd."
- echo
- einfo "NOTICE: If you need raw acces to partitions you need to add the"
- einfo "amanda user to the 'disk' group and uncomment following lines in"
- einfo "your /etc/devfs.d/amanda:"
- einfo "SCSI:"
- einfo "REGISTER ^scsi/host.*/bus.*/target.*/lun.*/part[0-9] PERMISSIONS root.disk 660"
- einfo "IDE:"
- einfo "REGISTER ^ide/host.*/bus.*/target.*/lun.*/part[0-9] PERMISSIONS root.disk 660"
-}
diff --git a/app-admin/amanda/amanda-2.4.4.ebuild b/app-admin/amanda/amanda-2.4.4.ebuild
deleted file mode 100644
index b8107dc89c5d..000000000000
--- a/app-admin/amanda/amanda-2.4.4.ebuild
+++ /dev/null
@@ -1,233 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/amanda/amanda-2.4.4.ebuild,v 1.12 2004/01/07 08:59:07 robbat2 Exp $
-
-inherit eutils
-DESCRIPTION="The Advanced Maryland Automatic Network Disk Archiver"
-HOMEPAGE="http://www.amanda.org/"
-SRC_URI="mirror://sourceforge/amanda/${P}.tar.gz"
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="x86 ~ppc -sparc"
-DEPEND="sys-libs/readline
- virtual/inetd
- virtual/mta
- app-arch/mt-st
- net-mail/mailx
- media-gfx/gnuplot
- sys-apps/gawk
- app-arch/tar
- sys-devel/autoconf
- sys-devel/automake
- dev-lang/perl
- sys-apps/mtx
- app-arch/dump
- net-mail/mailx
- samba? ( net-fs/samba )
- berkdb? ( sys-libs/db )
- gdbm? ( sys-libs/gdbm )
- xfs? ( sys-fs/xfsdump )"
-
-IUSE="pic debug gdbm berkdb samba xfs"
-
-S=${WORKDIR}/${P}
-
-[ -z "${AMANDA_GROUP_GID}" ] && AMANDA_GROUP_GID=87
-[ -z "${AMANDA_GROUP_NAME}" ] && AMANDA_GROUP_NAME=amanda
-[ -z "${AMANDA_USER_NAME}" ] && AMANDA_USER_NAME=amanda
-[ -z "${AMANDA_USER_UID}" ] && AMANDA_USER_UID=87
-[ -z "${AMANDA_USER_SH}" ] && AMANDA_USER_SH=/bin/false
-[ -z "${AMANDA_USER_HOMEDIR}" ] && AMANDA_USER_HOMEDIR=/var/spool/amanda
-[ -z "${AMANDA_USER_GROUPS}" ] && AMANDA_USER_GROUPS=${AMANDA_GROUP_NAME}
-# This installs Amanda, with the server. However, it could be a client,
-# just specify an alternate server name in AMANDA_SERVER.
-[ -z "${AMANDA_SERVER}" ] && AMANDA_SERVER=localhost
-[ -z "${AMANDA_SERVER_TAPE}" ] && AMANDA_SERVER_TAPE="${AMANDA_SERVER}"
-[ -z "${AMANDA_SERVER_INDEX}" ] && AMANDA_SERVER_INDEX="${AMANDA_SERVER}"
-[ -z "${AMANDA_TAR_LISTDIR}" ] && AMANDA_TAR_LISTDIR=${AMANDA_USER_HOMEDIR}/tar-lists
-[ -z "${AMANDA_CONFIG_NAME}" ] && AMANDA_CONFIG_NAME=DailySet1
-[ -z "${AMANDA_TMPDIR}" ] && AMANDA_TMPDIR=${AMANDA_USER_HOMEDIR}/tmp
-
-pkg_setup() {
- enewgroup ${AMANDA_GROUP_NAME} ${AMANDA_GROUP_GID}
- enewuser ${AMANDA_USER_NAME} ${AMANDA_USER_UID} ${AMANDA_USER_SH} ${AMANDA_USER_HOMEDIR} ${AMANDA_USER_GROUPS}
- echo >/dev/null
-}
-
-src_compile() {
- # fix bug #36316
- addpredict /var/cache/samba/gencache.tdb
-
- local myconf
- cd ${S}
-
- [ -z "${AMANDA_DBMODE}" ] || use gdbm && AMANDA_DBMODE=gdbm
- use berkdb && AMANDA_DBMODE=db
- [ -z "${AMANDA_DBMODE}" ] && AMANDA_DBMODE=text
- einfo "Using '${AMANDA_DBMODE}' style database"
- myconf="${myconf} --with-db=${AMANDA_DBMODE}"
-
- einfo "Using ${AMANDA_SERVER_TAPE} for tape server."
- myconf="${myconf} --with-tape-server=${AMANDA_SERVER_TAPE}"
- einfo "Using ${AMANDA_SERVER_INDEX} for index server."
- myconf="${myconf} --with-index-server=${AMANDA_SERVER_TAPE}"
- einfo "Using ${AMANDA_USER_NAME} for amanda user."
- myconf="${myconf} --with-user=${AMANDA_USER_NAME}"
- einfo "Using ${AMANDA_GROUP_NAME} for amanda group."
- myconf="${myconf} --with-group=${AMANDA_GROUP_NAME}"
- einfo "Using ${AMANDA_TAR_LISTDIR} as tar listdir."
- myconf="${myconf} --with-gnutar-listdir=${AMANDA_TAR_LISTDIR}"
- einfo "Using ${AMANDA_CONFIG_NAME} as default config name."
- myconf="${myconf} --with-config=${AMANDA_CONFIG_NAME}"
- einfo "Using ${AMANDA_TMPDIR} as Amanda temporary directory."
- myconf="${myconf} --with-tmpdir=${AMANDA_TMPDIR}"
-
- if [ -n "${AMANDA_PORTS_UDP}" ] && [ -n "${AMANDA_PORTS_TCP}" ] && [ -z "${AMANDA_PORTS_BOTH}" ] ; then
- eerror "If you want _both_ UDP and TCP ports, please use only the"
- eerror "AMANDA_PORTS environment variable for identical ports, or set"
- eerror "AMANDA_PORTS_BOTH."
- die "Bad port setup!"
- fi
- if [ -n "${AMANDA_PORTS_UDP}" ]; then
- einfo "Using UDP ports ${AMANDA_PORTS_UDP/,/-}"
- myconf="${myconf} --with-udpportrange=${AMANDA_PORTS_UDP}"
- fi
- if [ -n "${AMANDA_PORTS_TCP}" ]; then
- einfo "Using TCP ports ${AMANDA_PORTS_TCP/,/-}"
- myconf="${myconf} --with-tcpportrange=${AMANDA_PORTS_TCP}"
- fi
- if [ -n "${AMANDA_PORTS}" ]; then
- einfo "Using ports ${AMANDA_PORTS/,/-}"
- myconf="${myconf} --with-portrange=${AMANDA_PORTS}"
- fi
-
- # Extras
- # Speed option
- myconf="${myconf} --with-buffered-dump"
- # Debug
- myconf="${myconf} `use_with debug debugging`"
- # PIC
- myconf="${myconf} `use_with pic`"
- myconf="${myconf} --localstatedir=${AMANDA_USER_HOMEDIR}"
-
- use samba && myconf="${myconf} --with-smbclient=/usr/bin/smbclient" || myconf="${myconf} --without-smbclient"
-
- econf ${myconf} || die "econf failed!"
- emake || die "emake failed!"
-
- # Compile the tapetype program too
- cd tape-src
- emake tapetype || "emake tapetype failed!"
-
- dosed "s,/usr/local/bin/perl,/usr/bin/perl," ${S}/contrib/set_prod_link.pl
- perl ${S}/contrib/set_prod_link.pl
-
-}
-
-
-src_install() {
- make DESTDIR=${D} install || die
-
- into /usr
- newsbin tape-src/tapetype tapetype
-
- dodoc AUTHORS C* INSTALL NEWS README
- docinto example
- dodoc ${S}/example/*
- docinto docs
- dodoc ${S}/docs/*
- prepalldocs
-
- if use xfs; then
- dodir ${D}/var/xfsdump/inventory
- mkdir -p ${D}/var/xfsdump/inventory
- fi
-
- # einfo "Installing Amandahosts File for ${AMANDA_SERVER}"
- insinto ${AMANDA_USER_HOMEDIR}
- newins ${FILESDIR}/amanda-amandahosts .amandahosts
- dosed "s/__AMANDA_SERVER__/${AMANDA_SERVER}/" ${AMANDA_USER_HOMEDIR}/.amandahosts
- newins ${FILESDIR}/amanda-profile .profile
-
- # einfo "Installing Sample Daily Cron Job for Amanda"
- CRONDIR=/etc/cron.daily/
- exeinto ${CDRONDIR}
- newexe ${FILESDIR}/amanda-cron amanda
- dosed "s,__AMANDA_CONFIG_NAME__,${AMANDA_CONFIG_NAME},g" ${CRONDIR}/amanda
- fperms 644 ${CRONDIR}/amanda
-
- insinto /etc/amanda/lbl
- newins ${S}/example/3hole.ps 3hole.ps
- newins ${S}/example/8.5x11.ps 8.5x11.ps
- newins ${S}/example/DIN-A4.ps DIN-A4.ps
- newins ${S}/example/DLT.ps DLT.ps
- newins ${S}/example/EXB-8500.ps EXB-8500.ps
- newins ${S}/example/HP-DAT.ps HP-DAT.ps
-
- # Amanda example configs
- insinto /etc/amanda/example
- newins ${FILESDIR}/example_amanda.conf amanda.conf
- newins ${FILESDIR}/example_disklist disklist
- newins ${FILESDIR}/example_global.conf global.conf
- insinto /etc/amanda/example2
- newins ${S}/example/amanda.conf amanda.conf
- newins ${S}/example/disklist disklist
-
- # einfo "Installing Sample Daily Backup Configuration"
- insinto /etc/amanda/${AMANDA_CONFIG_NAME}
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} /etc/amanda
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} /etc/amanda/${AMANDA_CONFIG_NAME}
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} /etc/amanda/${AMANDA_CONFIG_NAME}/*
- fperms 700 /etc/amanda
- fperms 700 /etc/amanda/${AMANDA_CONFIG_NAME}
-
- local i
- for i in amandates dumpdates; do
- touch ${D}/etc/${i}
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} /etc/${i}
- fperms 600 /etc/${i}
- done
-
- dodir ${AMANDA_TAR_LISTDIR}
- dodir ${AMANDA_TMPDIR}
- dodir ${AMANDA_TMPDIR}/dumps
- dodir ${AMANDA_USER_HOMEDIR}/${AMANDA_CONFIG_NAME}
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${AMANDA_USER_HOMEDIR}
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${AMANDA_TAR_LISTDIR}
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${AMANDA_TMPDIR}
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${AMANDA_TMPDIR}/dumps
- fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${AMANDA_USER_HOMEDIR}/${AMANDA_CONFIG_NAME}
- fperms 700 ${AMANDA_USER_HOMEDIR}
-
- # DevFS
- insinto /etc/devfs.d
- newins ${FILESDIR}/amanda-devfs amanda
-
- if [ -x "/usr/sbin/xinetd" ]; then
- # Installing Amanda Xinetd Services Definition
- insinto /etc/xinetd.d
- newins ${FILESDIR}/amanda-xinetd amanda
- dosed "s/__AMANDA_SERVER__/${AMANDA_SERVER}/g" /etc/xinetd.d/amanda
- else
- echo > ${D}/etc/amanda/inetd.amanda "amanda dgram udp wait amanda /usr/libexec/amanda/amandad amandad"
- echo >> ${D}/etc/amanda/inetd.amanda "amandaidx stream tcp nowait amanda /usr/libexec/amanda/amindexd amindexd"
- echo >> ${D}/etc/amanda/inetd.amanda "amidxtape stream tcp nowait amanda /usr/libexec/amanda/amidxtaped amidxtaped"
- fi
-}
-
-pkg_postinst() {
- einfo "You should configure Amanda in /etc/amanda now."
- if [ -x "/usr/sbin/xinetd" ]; then
- einfo "Don't forget to check /etc/xinetd.d/amanda and restart"
- einfo "xinetd afterwards!"
- else
- einfo "No xinetd found. Config example for inetd is in /etc/amanda/inetd.amanda"
- fi
- einfo "NOTICE: If you need raw acces to partitions you need to add the"
- einfo "amanda user to the 'disk' group and uncomment following lines in"
- einfo "your /etc/devfs.d/amanda:"
- einfo "SCSI:"
- einfo "REGISTER ^scsi/host.*/bus.*/target.*/lun.*/part[0-9] PERMISSIONS root.disk 660"
- einfo "IDE:"
- einfo "REGISTER ^ide/host.*/bus.*/target.*/lun.*/part[0-9] PERMISSIONS root.disk 660"
-}
diff --git a/app-admin/amanda/files/digest-amanda-2.4.4 b/app-admin/amanda/files/digest-amanda-2.4.4
deleted file mode 100644
index 0744e0686521..000000000000
--- a/app-admin/amanda/files/digest-amanda-2.4.4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1f5f0c636707994eb7b5e74b19528323 amanda-2.4.4.tar.gz 1220934
diff --git a/app-admin/amanda/files/digest-amanda-2.4.4-r1 b/app-admin/amanda/files/digest-amanda-2.4.4-r1
deleted file mode 100644
index 0744e0686521..000000000000
--- a/app-admin/amanda/files/digest-amanda-2.4.4-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1f5f0c636707994eb7b5e74b19528323 amanda-2.4.4.tar.gz 1220934
diff --git a/app-admin/amanda/files/digest-amanda-2.4.4-r2 b/app-admin/amanda/files/digest-amanda-2.4.4-r2
deleted file mode 100644
index 0744e0686521..000000000000
--- a/app-admin/amanda/files/digest-amanda-2.4.4-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1f5f0c636707994eb7b5e74b19528323 amanda-2.4.4.tar.gz 1220934