summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-03-02 20:37:21 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-03-02 20:37:21 +0000
commited0d072dc43b075c2bfc654a8acbc60450fc1772 (patch)
tree0e297a1cfd77432894aa7905d69b26c761ca717d
parentMove Qt dependencies to the new category (diff)
downloadgentoo-2-ed0d072dc43b075c2bfc654a8acbc60450fc1772.tar.gz
gentoo-2-ed0d072dc43b075c2bfc654a8acbc60450fc1772.tar.bz2
gentoo-2-ed0d072dc43b075c2bfc654a8acbc60450fc1772.zip
Version bump: EAPI 5, use base eclass, add ~amd64-linux and ~x86-linux keywords, set new HOMEPAGE and SRC_URI, assign myself as maintainer
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
-rw-r--r--app-misc/clockywock/ChangeLog11
-rw-r--r--app-misc/clockywock/clockywock-0.3.1a.ebuild33
-rw-r--r--app-misc/clockywock/files/clockywock-0.3.1a-makefile.patch10
-rw-r--r--app-misc/clockywock/metadata.xml7
4 files changed, 56 insertions, 5 deletions
diff --git a/app-misc/clockywock/ChangeLog b/app-misc/clockywock/ChangeLog
index ef2127a55c94..02d14ce11f6d 100644
--- a/app-misc/clockywock/ChangeLog
+++ b/app-misc/clockywock/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/clockywock
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/clockywock/ChangeLog,v 1.16 2012/05/10 15:10:08 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/clockywock/ChangeLog,v 1.17 2013/03/02 20:37:21 pinkbyte Exp $
+
+*clockywock-0.3.1a (02 Mar 2013)
+
+ 02 Mar 2013; Sergey Popov <pinkbyte@gentoo.org> +clockywock-0.3.1a.ebuild,
+ +files/clockywock-0.3.1a-makefile.patch, metadata.xml:
+ Version bump: EAPI 5, use base eclass, add ~amd64-linux and ~x86-linux
+ keywords, set new HOMEPAGE and SRC_URI, assign myself as maintainer
10 May 2012; Agostino Sarubbo <ago@gentoo.org> -clockywock-0.2.3.ebuild:
Remove old
diff --git a/app-misc/clockywock/clockywock-0.3.1a.ebuild b/app-misc/clockywock/clockywock-0.3.1a.ebuild
new file mode 100644
index 000000000000..102a1b639f3a
--- /dev/null
+++ b/app-misc/clockywock/clockywock-0.3.1a.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/clockywock/clockywock-0.3.1a.ebuild,v 1.1 2013/03/02 20:37:21 pinkbyte Exp $
+
+EAPI="5"
+
+inherit base toolchain-funcs
+
+DESCRIPTION="ncurses based analog clock"
+HOMEPAGE="http://soomka.com/clockywock"
+SRC_URI="http://soomka.com/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_prepare() {
+ # Respect compiler
+ tc-export CXX
+
+ base_src_prepare
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.7
+ dodoc README CREDITS
+}
diff --git a/app-misc/clockywock/files/clockywock-0.3.1a-makefile.patch b/app-misc/clockywock/files/clockywock-0.3.1a-makefile.patch
new file mode 100644
index 000000000000..30bb487c6402
--- /dev/null
+++ b/app-misc/clockywock/files/clockywock-0.3.1a-makefile.patch
@@ -0,0 +1,10 @@
+--- Makefile
++++ Makefile
+@@ -1,5 +1,6 @@
++LIBS += -lncurses -lpthread
+ all:
+- g++ -O3 -Wall -o clockywock clockywock.cpp -lncurses -lpthread
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o clockywock clockywock.cpp $(LIBS)
+
+ # install is done completely lazily
+ install:
diff --git a/app-misc/clockywock/metadata.xml b/app-misc/clockywock/metadata.xml
index 1470e032181b..b6b8956cde34 100644
--- a/app-misc/clockywock/metadata.xml
+++ b/app-misc/clockywock/metadata.xml
@@ -1,7 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>maintainer-needed@gentoo.org</email>
- </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
</pkgmetadata>