summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-07-28 10:03:15 +0000
committerDan Armak <danarmak@gentoo.org>2002-07-28 10:03:15 +0000
commitee1e014ea58e5eb21d612528319b27ce1f699083 (patch)
treef18059defedef7cf43490cf54da5d26db64c7d9d
parentPortage 2.0.21 (masked for testing) (diff)
downloadgentoo-2-ee1e014ea58e5eb21d612528319b27ce1f699083.tar.gz
gentoo-2-ee1e014ea58e5eb21d612528319b27ce1f699083.tar.bz2
gentoo-2-ee1e014ea58e5eb21d612528319b27ce1f699083.zip
new kde3 version with many nice new features, closes bugs #5601, #4990.
-rw-r--r--app-editors/quanta/ChangeLog9
-rw-r--r--app-editors/quanta/files/digest-quanta-3.0_pre15
-rw-r--r--app-editors/quanta/quanta-2.0.1.ebuild6
-rw-r--r--app-editors/quanta/quanta-3.0_pre1.ebuild32
4 files changed, 48 insertions, 4 deletions
diff --git a/app-editors/quanta/ChangeLog b/app-editors/quanta/ChangeLog
index f873405d8e45..eb5fbfe7aa19 100644
--- a/app-editors/quanta/ChangeLog
+++ b/app-editors/quanta/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/quanta
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/quanta/ChangeLog,v 1.2 2002/05/08 08:43:22 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/quanta/ChangeLog,v 1.3 2002/07/28 10:03:15 danarmak Exp $
+
+*quanta-3.0_pre1 (28 Jul 2002)
+
+ 28 Jul 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ New version: a 3.0 prereleasse which compiles against kde3 and has many
+ nice new features.
*quanta-2.0.1 (7 May 2002)
7 May 2002; Spider <spider@gentoo.org> quanta-2.0.1.ebuild :
diff --git a/app-editors/quanta/files/digest-quanta-3.0_pre1 b/app-editors/quanta/files/digest-quanta-3.0_pre1
new file mode 100644
index 000000000000..b17204a2a19d
--- /dev/null
+++ b/app-editors/quanta/files/digest-quanta-3.0_pre1
@@ -0,0 +1,5 @@
+MD5 420b54d483c4b27955e3ae40a6a8e271 quanta-3.0pr1.tar.bz2 1615242
+MD5 9134a94af4c783c740cc0ad5806e4b51 css.tar.bz2 121295
+MD5 0cc3234c4b3df88d4115340ce05e0053 html.tar.bz2 93345
+MD5 eea6e25a1c25af1f5a0c33e32e52c136 javascript.tar.bz2 336563
+MD5 8ae86e900874549c3749ee5940756817 php.tar.bz2 378461
diff --git a/app-editors/quanta/quanta-2.0.1.ebuild b/app-editors/quanta/quanta-2.0.1.ebuild
index 4dccc591e89a..bcce84469904 100644
--- a/app-editors/quanta/quanta-2.0.1.ebuild
+++ b/app-editors/quanta/quanta-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/quanta/quanta-2.0.1.ebuild,v 1.10 2002/07/27 10:44:29 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/quanta/quanta-2.0.1.ebuild,v 1.11 2002/07/28 10:03:15 danarmak Exp $
inherit kde-base || die
@@ -26,9 +26,9 @@ src_install() {
kde_src_install
- dodir ${KDEDIR}/share/apps/quanta/doc/
+ dodir ${PREFIX}/share/apps/quanta/doc/
for x in css html javascript php; do
- cp -a ${WORKDIR}/${x}/*.docrc ${WORKDIR}/${x}/${x} ${D}/${KDEDIR}/share/apps/quanta/doc/
+ cp -a ${WORKDIR}/${x}/*.docrc ${WORKDIR}/${x}/${x} ${D}/${PREFIX}/share/apps/quanta/doc/
done
}
diff --git a/app-editors/quanta/quanta-3.0_pre1.ebuild b/app-editors/quanta/quanta-3.0_pre1.ebuild
new file mode 100644
index 000000000000..5bde68ff32a4
--- /dev/null
+++ b/app-editors/quanta/quanta-3.0_pre1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-editors/quanta/quanta-3.0_pre1.ebuild,v 1.1 2002/07/28 10:03:15 danarmak Exp $
+inherit kde-base
+
+need-kde 3
+
+DESCRIPTION="Quanta - HTML editor for KDE2"
+
+SRC_URI="mirror://sourceforge/quanta/quanta-3.0pr1.tar.bz2
+ mirror://sourceforge/quanta/css.tar.bz2
+ mirror://sourceforge/quanta/html.tar.bz2
+ mirror://sourceforge/quanta/javascript.tar.bz2
+ mirror://sourceforge/quanta/php.tar.bz2"
+
+HOMEPAGE="http://quanta.sourceforge.net"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+S=${WORKDIR}/quanta-3.0pr1
+
+src_install() {
+
+ kde_src_install
+
+ dodir ${PREFIX}/share/apps/quanta/doc/
+ for x in css html javascript php; do
+ cp -a ${WORKDIR}/${x}/*.docrc ${WORKDIR}/${x}/${x} ${D}/${PREFIX}/share/apps/quanta/doc/
+ done
+
+}