summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-25 14:40:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-25 14:40:27 +0000
commitf5a654ce3b414e6094df3fb6125eb3c5ec65ec9b (patch)
tree0b6206a2588ea3575a5048184a54d8cf85d606fc
parentstable x86, bug 268190 (diff)
downloadgentoo-2-f5a654ce3b414e6094df3fb6125eb3c5ec65ec9b.tar.gz
gentoo-2-f5a654ce3b414e6094df3fb6125eb3c5ec65ec9b.tar.bz2
gentoo-2-f5a654ce3b414e6094df3fb6125eb3c5ec65ec9b.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 14155-svn/cvs/Linux x86_64)
-rw-r--r--dev-python/logilab-common/ChangeLog11
-rw-r--r--dev-python/logilab-common/files/logilab-common-0.39.0-recursion.patch12
-rw-r--r--dev-python/logilab-common/files/logilab-common-0.39.0-remove-broken-tests.patch29
-rw-r--r--dev-python/logilab-common/logilab-common-0.39.0-r1.ebuild79
-rw-r--r--dev-python/logilab-common/logilab-common-0.41.0.ebuild76
-rw-r--r--dev-python/logilab-common/logilab-common-0.44.0.ebuild88
6 files changed, 98 insertions, 197 deletions
diff --git a/dev-python/logilab-common/ChangeLog b/dev-python/logilab-common/ChangeLog
index efa3b90bbef8..c91fc87b6322 100644
--- a/dev-python/logilab-common/ChangeLog
+++ b/dev-python/logilab-common/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/logilab-common
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.43 2009/07/24 21:48:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.44 2009/08/25 14:40:26 arfrever Exp $
+
+*logilab-common-0.44.0 (25 Aug 2009)
+
+ 25 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -logilab-common-0.39.0-r1.ebuild,
+ -files/logilab-common-0.39.0-recursion.patch,
+ -files/logilab-common-0.39.0-remove-broken-tests.patch,
+ -logilab-common-0.41.0.ebuild, +logilab-common-0.44.0.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
*logilab-common-0.43.0 (24 Jul 2009)
diff --git a/dev-python/logilab-common/files/logilab-common-0.39.0-recursion.patch b/dev-python/logilab-common/files/logilab-common-0.39.0-recursion.patch
deleted file mode 100644
index 1ae05ac538b5..000000000000
--- a/dev-python/logilab-common/files/logilab-common-0.39.0-recursion.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- logilab-common-0.39.0/modutils.py 2009-03-25 09:47:08.000000000 +0100
-+++ logilab-common-0.39.0/modutils.py 2009-04-18 22:03:10.000000000 +0200
-@@ -622,7 +622,7 @@ def _has_init(directory):
- else return None
- """
- mod_or_pack = join(directory, '__init__')
-- for ext in PY_SOURCE_EXTS + ('.pyc', '.pyo'):
-+ for ext in PY_SOURCE_EXTS + ('pyc', 'pyo'):
- if exists(mod_or_pack + '.' + ext):
-- return mod_or_pack + ext
-+ return mod_or_pack + '.' + ext
- return None
diff --git a/dev-python/logilab-common/files/logilab-common-0.39.0-remove-broken-tests.patch b/dev-python/logilab-common/files/logilab-common-0.39.0-remove-broken-tests.patch
deleted file mode 100644
index cda1f63340b8..000000000000
--- a/dev-python/logilab-common/files/logilab-common-0.39.0-remove-broken-tests.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- test/unittest_modutils.py.old 2009-04-14 13:00:50.116522533 +0200
-+++ test/unittest_modutils.py 2009-04-14 13:20:41.727764570 +0200
-@@ -120,16 +120,6 @@ class file_from_modpath_tc(TestCase):
- self.assertEqual(path.realpath(modutils.file_from_modpath(['os', 'path']).replace('.pyc', '.py')),
- path.realpath(path.__file__.replace('.pyc', '.py')))
-
-- def test_knownValues_file_from_modpath_3(self):
-- try:
-- # don't fail if pyxml isn't installed
-- from xml.dom import ext
-- except ImportError:
-- pass
-- else:
-- self.assertEqual(path.realpath(modutils.file_from_modpath(['xml', 'dom', 'ext']).replace('.pyc', '.py')),
-- path.realpath(ext.__file__.replace('.pyc', '.py')))
--
- def test_knownValues_file_from_modpath_4(self):
- self.assertEqual(modutils.file_from_modpath(['sys']),
- None)
-@@ -165,9 +155,6 @@ class is_standard_module_tc(TestCase):
- def test_knownValues_is_standard_module_3(self):
- self.assertEqual(modutils.is_standard_module('unknown'), False)
-
-- def test_knownValues_is_standard_module_4(self):
-- self.assertEqual(modutils.is_standard_module('StringIO'), True)
--
- def test_knownValues_is_standard_module_5(self):
- self.assertEqual(modutils.is_standard_module('data.module', (DATADIR,)), True)
- self.assertEqual(modutils.is_standard_module('data.module', (path.abspath(DATADIR),)), True) \ No newline at end of file
diff --git a/dev-python/logilab-common/logilab-common-0.39.0-r1.ebuild b/dev-python/logilab-common/logilab-common-0.39.0-r1.ebuild
deleted file mode 100644
index 689674b259d9..000000000000
--- a/dev-python/logilab-common/logilab-common-0.39.0-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.39.0-r1.ebuild,v 1.1 2009/04/18 21:20:34 patrick Exp $
-
-inherit distutils eutils python
-
-#DESCRIPTION="Several modules providing low level functionality shared among some python projects developed by logilab"
-DESCRIPTION="useful miscellaneous modules used by Logilab projects"
-HOMEPAGE="http://www.logilab.org/projects/common/"
-SRC_URI="ftp://ftp.logilab.org/pub/common/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="test"
-
-DEPEND="test? ( dev-python/egenix-mx-base )"
-RDEPEND=""
-
-PYTHON_MODNAME="logilab"
-
-# Extra documentation (html/pdf) needs some love
-src_unpack() {
- distutils_src_unpack
-
- epatch "${FILESDIR}/${P}-recursion.patch"
-}
-
-src_test() {
- python_version
-
- # Install temporarily.
- local tpath="${T}/test"
- local lpath="${tpath}/lib/python"
-
- # setuptools would fail if the directory doesn't exist.
- mkdir -p "${lpath}" || die
-
- # We also have to add ${lpath} to PYTHONPATH else the installation would
- # fail.
- PYTHONPATH="${lpath}" ${python} setup.py install --home="${tpath}" || \
- die "test copy failed"
-
- # Get a rid of precompiled files to ensure we run our _modified_ tests
- find ${lpath} -type f -name '*.pyc' -exec rm {} ';'
-
- # Remove a botched tests.
- # To support test w/o setuptools.
- if [[ -d "${lpath}/${PN/-//}" ]]; then
- pushd "${lpath}/${PN/-//}" >/dev/null || die
- else
- pushd "${lpath}/${P/-/_}-py${PYVER}.egg/${PN/-//}" >/dev/null || die
- fi
-
- epatch "${FILESDIR}/${P}-remove-broken-tests.patch"
-
- # Bug 223079
- if ! has userpriv ${FEATURES}; then
- rm test/unittest_fileutils.py || die
- fi
-
- popd >/dev/null || die
-
- # It picks up the tests relative to the current dir, so cd in. Do
- # not cd in too far though (to logilab/common for example) or some
- # relative/absolute module location tests fail.
- pushd "${lpath}" >/dev/null || die
- PYTHONPATH="${lpath}" ${python} "${tpath}/bin/pytest" -v || die "tests failed"
- popd >/dev/null || die
-}
-
-src_install() {
- distutils_src_install
-
- doman doc/pytest.1 || die "doman failed"
-
- # Remove unittests since they're just needed during build-time
- rm -rf "${D}/$(python_get_sitedir)/${PN/-//}/test" || die
-}
diff --git a/dev-python/logilab-common/logilab-common-0.41.0.ebuild b/dev-python/logilab-common/logilab-common-0.41.0.ebuild
deleted file mode 100644
index 48ea06257d88..000000000000
--- a/dev-python/logilab-common/logilab-common-0.41.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.41.0.ebuild,v 1.1 2009/06/04 13:01:39 idl0r Exp $
-
-inherit distutils eutils python
-
-DESCRIPTION="useful miscellaneous modules used by Logilab projects"
-HOMEPAGE="http://www.logilab.org/projects/common/"
-SRC_URI="ftp://ftp.logilab.org/pub/common/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="test"
-
-DEPEND="test? ( dev-python/egenix-mx-base )"
-RDEPEND=""
-
-PYTHON_MODNAME="logilab"
-# Extra documentation (html/pdf) needs some love
-
-src_unpack() {
- distutils_src_unpack
-
- epatch "${FILESDIR}/${P}-remove-broken-tests.patch"
-}
-
-src_test() {
- python_version
-
- # Install temporarily.
- local tpath="${T}/test"
- local lpath="${tpath}/lib/python"
-
- # setuptools would fail if the directory doesn't exist.
- mkdir -p "${lpath}" || die
-
- # We also have to add ${lpath} to PYTHONPATH else the installation would
- # fail.
- PYTHONPATH="${lpath}" ${python} setup.py install --home="${tpath}" || \
- die "test copy failed"
-
- # Get a rid of precompiled files to ensure we run our _modified_ tests
- find ${lpath} -type f -name '*.pyc' -exec rm {} ';'
-
- # Remove a botched tests.
- # To support test w/o setuptools.
- if [[ -d "${lpath}/${PN/-//}" ]]; then
- pushd "${lpath}/${PN/-//}" >/dev/null || die
- else
- pushd "${lpath}/${P/-/_}-py${PYVER}.egg/${PN/-//}" >/dev/null || die
- fi
-
- # Bug 223079
- if ! has userpriv ${FEATURES}; then
- rm test/unittest_fileutils.py || die
- fi
-
- popd >/dev/null || die
-
- # It picks up the tests relative to the current dir, so cd in. Do
- # not cd in too far though (to logilab/common for example) or some
- # relative/absolute module location tests fail.
- pushd "${lpath}" >/dev/null || die
- PYTHONPATH="${lpath}" ${python} "${tpath}/bin/pytest" -v || die "tests failed"
- popd >/dev/null || die
-}
-
-src_install() {
- distutils_src_install
-
- doman doc/pytest.1 || die "doman failed"
-
- # Remove unittests since they're just needed during build-time
- rm -rf "${D}/$(python_get_sitedir)/${PN/-//}/test" || die
-}
diff --git a/dev-python/logilab-common/logilab-common-0.44.0.ebuild b/dev-python/logilab-common/logilab-common-0.44.0.ebuild
new file mode 100644
index 000000000000..ac82cbf21d86
--- /dev/null
+++ b/dev-python/logilab-common/logilab-common-0.44.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.44.0.ebuild,v 1.1 2009/08/25 14:40:26 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils python
+
+DESCRIPTION="useful miscellaneous modules used by Logilab projects"
+HOMEPAGE="http://www.logilab.org/projects/common/"
+SRC_URI="ftp://ftp.logilab.org/pub/common/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/egenix-mx-base )"
+RDEPEND=""
+
+RESTRICT_PYTHON_ABIS="3*"
+
+PYTHON_MODNAME="logilab"
+# Extra documentation (html/pdf) needs some love
+
+pkg_setup() {
+ # Tests using dev-python/psycopg are skipped when dev-python/psycopg isn't installed.
+ if use test && has_version dev-python/psycopg && ! has_version dev-python/psycopg[mxdatetime]; then
+ die "dev-python/psycopg should be installed with USE=\"mxdatetime\""
+ fi
+}
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${PN}-0.41.0-remove-broken-tests.patch"
+}
+
+src_test() {
+ testing() {
+ # Install temporarily.
+ local tpath="${T}/test-${PYTHON_ABI}"
+ local lpath="${tpath}/lib/python"
+
+ # setuptools would fail if the directory doesn't exist.
+ mkdir -p "${lpath}" || die
+
+ # We also have to add ${lpath} to PYTHONPATH else the installation would
+ # fail.
+ PYTHONPATH="${lpath}" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --home="${tpath}" || die "test copy failed"
+
+ # Get a rid of precompiled files to ensure we run our _modified_ tests
+ find ${lpath} -type f -name '*.pyc' -exec rm {} ';'
+
+ # Remove a botched tests.
+ # To support test w/o setuptools.
+ if [[ -d "${lpath}/${PN/-//}" ]]; then
+ pushd "${lpath}/${PN/-//}" >/dev/null || die
+ else
+ pushd "${lpath}/${P/-/_}-py${PYTHON_ABI}.egg/${PN/-//}" >/dev/null || die
+ fi
+
+ # Bug 223079
+ if [[ "${EUID}" -eq 0 ]]; then
+ rm test/unittest_fileutils.py || die
+ fi
+
+ popd >/dev/null || die
+
+ # It picks up the tests relative to the current dir, so cd in. Do
+ # not cd in too far though (to logilab/common for example) or some
+ # relative/absolute module location tests fail.
+ pushd "${lpath}" >/dev/null || die
+ PYTHONPATH="${lpath}" "$(PYTHON)" "${tpath}/bin/pytest" -v || die "tests failed"
+ popd >/dev/null || die
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ doman doc/pytest.1 || die "doman failed"
+
+ # Remove unittests since they're just needed during build-time
+ rm -rf "${D}"usr/lib*/python*/site-packages/${PN/-//}/test || die
+}