summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-08-15 19:55:14 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-08-15 19:55:14 +0000
commitfcea190067d6964b86fe34dcfd925ce6f925f130 (patch)
tree2287cfdd03378dde8d149f599e6fda4c87f0d585
parent Update Makefiles for sed 4.1.4 -- patch courtesy of TGL (Bug #131883) (diff)
downloadgentoo-2-fcea190067d6964b86fe34dcfd925ce6f925f130.tar.gz
gentoo-2-fcea190067d6964b86fe34dcfd925ce6f925f130.tar.bz2
gentoo-2-fcea190067d6964b86fe34dcfd925ce6f925f130.zip
Adds missing configure option to disable xinerama, rediffed the patch.
(Portage version: 2.1.1_pre5-r1)
-rw-r--r--media-plugins/vdr-softdevice/ChangeLog8
-rw-r--r--media-plugins/vdr-softdevice/files/softdevice-cvs-libcle266mpegdec-0.2.patch104
-rw-r--r--media-plugins/vdr-softdevice/files/softdevice-cvs-xinerama-configure-opts.patch19
-rw-r--r--media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild3
4 files changed, 76 insertions, 58 deletions
diff --git a/media-plugins/vdr-softdevice/ChangeLog b/media-plugins/vdr-softdevice/ChangeLog
index 46f1b9867464..bf295269a4ff 100644
--- a/media-plugins/vdr-softdevice/ChangeLog
+++ b/media-plugins/vdr-softdevice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-softdevice
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.14 2006/08/15 08:43:43 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.15 2006/08/15 19:55:14 zzam Exp $
+
+ 15 Aug 2006; Matthias Schwarzott <zzam@gentoo.org>
+ files/softdevice-cvs-libcle266mpegdec-0.2.patch,
+ +files/softdevice-cvs-xinerama-configure-opts.patch,
+ vdr-softdevice-0.2.3.20060814.ebuild:
+ Adds missing configure option to disable xinerama, rediffed the patch.
*vdr-softdevice-0.2.3.20060814 (15 Aug 2006)
diff --git a/media-plugins/vdr-softdevice/files/softdevice-cvs-libcle266mpegdec-0.2.patch b/media-plugins/vdr-softdevice/files/softdevice-cvs-libcle266mpegdec-0.2.patch
index cb32a8a28198..a003d67567ef 100644
--- a/media-plugins/vdr-softdevice/files/softdevice-cvs-libcle266mpegdec-0.2.patch
+++ b/media-plugins/vdr-softdevice/files/softdevice-cvs-libcle266mpegdec-0.2.patch
@@ -1,56 +1,48 @@
-Index: configure
-===================================================================
-RCS file: /cvsroot/softdevice/softdevice/configure,v
-retrieving revision 1.20
-diff -u -r1.20 configure
---- configure 10 Jul 2006 19:40:25 -0000 1.20
-+++ configure 13 Jul 2006 11:38:08 -0000
-@@ -299,15 +299,17 @@
- #
- if test "${dfb}" = "yes" ; then
- echo -n "Checking for libcle266mpegdec ... "
-- cle266_cflags=`PKG_CONFIG_PATH=$PKG_CONFIG_PATH pkg-config --cflags libcle266mpegdec 2>>config.log` || cle266="no"
-+ cle266_version=`PKG_CONFIG_PATH=$PKG_CONFIG_PATH pkg-config --modversion libcle266mpegdec 2>>config.log` || cle266="no"
- if test "${cle266}" = "yes" ; then
-+ cle266_cflags=`PKG_CONFIG_PATH=$PKG_CONFIG_PATH pkg-config --cflags libcle266mpegdec`
- cle266_libs=`PKG_CONFIG_PATH=$PKG_CONFIG_PATH pkg-config --libs libcle266mpegdec`
- cle266_opts="${cle266_cflags} ${cle266_libs}"
- fi
-
-- if test "${cle266}" = "yes" ; then
-+ if test "${cle266}" = "yes" && test "${cle266_version}" = "0.2"; then
- echo "Enabled cle266 hardware decoding."
- else
-+ cle266="no"
- echo "Not found."
- fi
- else
-Index: mpeg2decoder.c
-===================================================================
-RCS file: /cvsroot/softdevice/softdevice/mpeg2decoder.c,v
-retrieving revision 1.66
-diff -u -r1.66 mpeg2decoder.c
---- mpeg2decoder.c 17 Jun 2006 16:27:34 -0000 1.66
-+++ mpeg2decoder.c 13 Jul 2006 11:38:08 -0000
-@@ -757,7 +757,7 @@
- };
-
- #ifdef HAVE_CLE266_MPEG_DECODER
--float aspect_ratio_values[5]={1.0, 1.0, 4.0/3.0, 16.0/9.0, 221.0/110 };
-+float aspect_ratio_values[5]={1.0, 1.0, 4.0/3.0, 16.0/9.0, 2.21 };
-
- int cVideoStreamDecoder::DecodePicture_cle266(sPicBuffer *&pic,
- int &got_picture,uint8_t *data, int length, int64_t pkt_pts) {
-@@ -790,9 +790,9 @@
- pic->width = decoder.width;
- pic->height = decoder.height;
- pic->pts = pkt_pts;
-- pic->edge_width=pic->edge_height=0;
-- pic->dtg_active_format = 0; // currently not parsed
-- pic->interlaced_frame = true; // FIXME Do we have that information?
-+ pic->edge_width = pic->edge_height = 0;
-+ pic->dtg_active_format = decoder.dtg_active_format;
-+ pic->interlaced_frame = decoder.progressive_sequence ? false : true;
- pic->aspect_ratio = ( decoder.aspect_ratio_info >= 0
- && decoder.aspect_ratio_info < 5 ) ?
- aspect_ratio_values[decoder.aspect_ratio_info] : 1.0;
+diff -ru softdevice-cvs-20060814/configure softdevice-cvs-20060814-try1/configure
+--- softdevice-cvs-20060814/configure 2006-08-14 20:50:22.000000000 +0200
++++ softdevice-cvs-20060814-try1/configure 2006-08-15 21:40:58.000000000 +0200
+@@ -328,15 +328,17 @@
+ #
+ if test "${dfb}" = "yes" ; then
+ echo -n "Checking for libcle266mpegdec ... "
+- cle266_cflags=`PKG_CONFIG_PATH=$PKG_CONFIG_PATH pkg-config --cflags libcle266mpegdec 2>>config.log` || cle266="no"
++ cle266_version=`PKG_CONFIG_PATH=$PKG_CONFIG_PATH pkg-config --modversion libcle266mpegdec 2>>config.log` || cle266="no"
+ if test "${cle266}" = "yes" ; then
++ cle266_cflags=`PKG_CONFIG_PATH=$PKG_CONFIG_PATH pkg-config --cflags libcle266mpegdec`
+ cle266_libs=`PKG_CONFIG_PATH=$PKG_CONFIG_PATH pkg-config --libs libcle266mpegdec`
+ cle266_opts="${cle266_cflags} ${cle266_libs}"
+ fi
+
+- if test "${cle266}" = "yes" ; then
++ if test "${cle266}" = "yes" && test "${cle266_version}" = "0.2"; then
+ echo "Enabled cle266 hardware decoding."
+ else
++ cle266="no"
+ echo "Not found."
+ fi
+ elsediff -ru softdevice-cvs-20060814/mpeg2decoder.c softdevice-cvs-20060814-try1/mpeg2decoder.c
+--- softdevice-cvs-20060814/mpeg2decoder.c 2006-08-14 20:50:22.000000000 +0200
++++ softdevice-cvs-20060814-try1/mpeg2decoder.c 2006-08-15 21:40:58.000000000 +0200
+@@ -757,7 +757,7 @@
+ };
+
+ #ifdef HAVE_CLE266_MPEG_DECODER
+-float aspect_ratio_values[5]={1.0, 1.0, 4.0/3.0, 16.0/9.0, 221.0/110 };
++float aspect_ratio_values[5]={1.0, 1.0, 4.0/3.0, 16.0/9.0, 2.21 };
+
+ int cVideoStreamDecoder::DecodePicture_cle266(sPicBuffer *&pic,
+ int &got_picture,uint8_t *data, int length, int64_t pkt_pts) {
+@@ -790,9 +790,9 @@
+ pic->width = decoder.width;
+ pic->height = decoder.height;
+ pic->pts = pkt_pts;
+- pic->edge_width=pic->edge_height=0;
+- pic->dtg_active_format = 0; // currently not parsed
+- pic->interlaced_frame = true; // FIXME Do we have that information?
++ pic->edge_width = pic->edge_height = 0;
++ pic->dtg_active_format = decoder.dtg_active_format;
++ pic->interlaced_frame = decoder.progressive_sequence ? false : true;
+ pic->aspect_ratio = ( decoder.aspect_ratio_info >= 0
+ && decoder.aspect_ratio_info < 5 ) ?
+ aspect_ratio_values[decoder.aspect_ratio_info] : 1.0;
+
diff --git a/media-plugins/vdr-softdevice/files/softdevice-cvs-xinerama-configure-opts.patch b/media-plugins/vdr-softdevice/files/softdevice-cvs-xinerama-configure-opts.patch
new file mode 100644
index 000000000000..f8fe212feb29
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/softdevice-cvs-xinerama-configure-opts.patch
@@ -0,0 +1,19 @@
+diff -ru softdevice-cvs-20060814/configure softdevice-cvs-20060814-try1/configure
+--- softdevice-cvs-20060814/configure 2006-08-14 20:50:22.000000000 +0200
++++ softdevice-cvs-20060814-try1/configure 2006-08-15 21:49:28.000000000 +0200
+@@ -51,6 +51,7 @@
+ echo " --disable-mmx"
+ echo " --disable-mmx2"
+ echo " --disable-alsa"
++ echo " --disable-xinerama"
+ echo " --with-ffmpeg-path YOUR_FFMPEG_PATH"
+ echo " --with-vidix-path YOUR_VIDIX_PATH"
+ echo " --help"
+@@ -71,6 +72,7 @@
+ --disable-mmx) shift; with_mmx="no";;
+ --disable-mmx2) shift; with_mmx2="no";;
+ --disable-alsa) shift; alsa="no";;
++ --disable-xinerama) shift; xinerama="no";;
+ --with-ffmpeg-path) shift;
+ ffmpeg_path=$1 ;
+ ffmpeg_use_path="yes" ;
diff --git a/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild b/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild
index 21bb0dce227f..0c6818fa8d85 100644
--- a/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild
+++ b/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild,v 1.1 2006/08/15 08:43:43 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060814.ebuild,v 1.2 2006/08/15 19:55:14 zzam Exp $
inherit vdr-plugin versionator
@@ -47,6 +47,7 @@ S=${WORKDIR}/${VDRPLUGIN}-cvs-${MY_PV}
PATCHES="
${FILESDIR}/vdr-softdevice-0.2.3-shm-key-init.diff
${FILESDIR}/vdr-softdevice-0.2.3-shm-fullscreen.diff
+ ${FILESDIR}/softdevice-cvs-xinerama-configure-opts.patch
${FILESDIR}/softdevice-cvs-libcle266mpegdec-0.2.patch"
pkg_setup() {