summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-01 16:30:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-01 16:30:48 +0000
commitfe586917518b3561829e2ba4cf2fd119f922c401 (patch)
treec5de12987227a7041ee2b7ae17a0f453af601507
parentppc stable #270440 (diff)
downloadgentoo-2-fe586917518b3561829e2ba4cf2fd119f922c401.tar.gz
gentoo-2-fe586917518b3561829e2ba4cf2fd119f922c401.tar.bz2
gentoo-2-fe586917518b3561829e2ba4cf2fd119f922c401.zip
Fixed automagic dependency issue. ( bug 236341 ). Fixed rpath issues ( bug 235819 , bug 271870 )
(Portage version: 2.2_rc33/cvs/Linux x86_64)
-rw-r--r--dev-python/PyQt4/ChangeLog11
-rw-r--r--dev-python/PyQt4/PyQt4-4.4.4-r5.ebuild107
-rw-r--r--dev-python/PyQt4/files/configure.py.patch29
-rw-r--r--dev-python/PyQt4/metadata.xml11
4 files changed, 150 insertions, 8 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 6541f4a9553f..9b1706a7578b 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.56 2009/05/20 23:01:26 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.57 2009/06/01 16:30:48 hwoarang Exp $
+
+*PyQt4-4.4.4-r5 (01 Jun 2009)
+
+ 01 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.4.4-r5.ebuild,
+ files/configure.py.patch, metadata.xml:
+ Fixed automagic dependency issue. ( bug 236341 ). Fixed rpath issues ( bug
+ 235819 , bug 271870 ). Thanks to Davide Pesavento <davidepesa@gmail.com>
+ for
+ the ebuilds and the rpath patch.
20 May 2009; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4-r1.ebuild,
-PyQt4-4.4.4-r1.ebuild, -PyQt4-4.4.4-r3.ebuild, PyQt4-4.4.4-r4.ebuild:
diff --git a/dev-python/PyQt4/PyQt4-4.4.4-r5.ebuild b/dev-python/PyQt4/PyQt4-4.4.4-r5.ebuild
new file mode 100644
index 000000000000..d3e47508c7fa
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.4.4-r5.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.4.4-r5.ebuild,v 1.1 2009/06/01 16:30:48 hwoarang Exp $
+
+EAPI="2"
+
+inherit distutils qt4
+
+MY_P=PyQt-x11-gpl-${PV}
+QTVER="4.4.2"
+
+DESCRIPTION="A set of Python bindings for the Qt toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="X assistant +dbus debug doc examples opengl phonon +qt3support sql svg webkit xmlpatterns"
+
+DEPEND=">=dev-python/sip-4.7.8
+ >=x11-libs/qt-core-${QTVER}:4[qt3support?]
+ >=x11-libs/qt-script-${QTVER}:4
+ >=x11-libs/qt-test-${QTVER}:4
+ X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?,qt3support?] )
+ assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
+ dbus? (
+ >=dev-python/dbus-python-0.80
+ >=x11-libs/qt-dbus-${QTVER}:4
+ )
+ opengl? ( >=x11-libs/qt-opengl-${QTVER}:4[qt3support?] )
+ phonon? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
+ qt3support? ( >=x11-libs/qt-qt3support-${QTVER}:4 )
+ sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
+ svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
+ webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
+ xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/configure.py.patch"
+ "${FILESDIR}/${P}-qgraphicsproxywidget-avoid-event-callback-loop.patch"
+ "${FILESDIR}/fix_license_check.patch"
+)
+
+pyqt4_use_enable() {
+ use $1 && echo "--enable=${2:-$1}"
+}
+
+src_prepare() {
+ if ! use dbus; then
+ sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
+ "${S}"/configure.py || die
+ fi
+ qt4_src_prepare
+}
+
+src_configure() {
+ distutils_python_version
+
+ local myconf="${python} configure.py
+ --confirm-license
+ --bindir=/usr/bin
+ --destdir=/usr/$(get_libdir)/python${PYVER}/site-packages
+ --sipdir=/usr/share/sip
+ $(use debug && echo '--debug')
+ --enable=QtCore
+ --enable=QtNetwork
+ --enable=QtScript
+ --enable=QtTest
+ --enable=QtXml
+ $(pyqt4_use_enable X QtGui)
+ $(pyqt4_use_enable X QtDesigner)
+ $(pyqt4_use_enable assistant QtAssistant)
+ $(pyqt4_use_enable assistant QtHelp)
+ $(pyqt4_use_enable opengl QtOpenGL)
+ $(pyqt4_use_enable phonon)
+ $(pyqt4_use_enable sql QtSql)
+ $(pyqt4_use_enable svg QtSvg)
+ $(pyqt4_use_enable webkit QtWebKit)
+ $(pyqt4_use_enable xmlpatterns QtXmlPatterns)"
+ echo ${myconf}
+ ${myconf} || die "configuration failed"
+
+ # Fix insecure runpath
+ sed -i -e "/^LFLAGS/s:-Wl,-rpath,${S}/qpy/QtDesigner::" \
+ "${S}"/QtDesigner/Makefile || die
+}
+
+src_install() {
+ # INSTALL_ROOT is needed for the QtDesigner module,
+ # the other Makefiles use DESTDIR.
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "installation failed"
+
+ dodoc ChangeLog NEWS THANKS || die
+
+ if use doc; then
+ dohtml -r doc/html/* || die
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+ fi
+}
diff --git a/dev-python/PyQt4/files/configure.py.patch b/dev-python/PyQt4/files/configure.py.patch
index 11160b99be87..4c3387883c3b 100644
--- a/dev-python/PyQt4/files/configure.py.patch
+++ b/dev-python/PyQt4/files/configure.py.patch
@@ -1,7 +1,26 @@
diff -Naur PyQt-x11-gpl-4.4.4~orig/configure.py PyQt-x11-gpl-4.4.4/configure.py
---- PyQt-x11-gpl-4.4.4~orig/configure.py 2009-03-26 01:01:43.000000000 +0100
-+++ PyQt-x11-gpl-4.4.4/configure.py 2009-03-26 01:09:50.000000000 +0100
-@@ -666,6 +666,7 @@
+--- PyQt-x11-gpl-4.4.4~orig/configure.py 2009-06-01 01:54:27.000000000 +0200
++++ PyQt-x11-gpl-4.4.4/configure.py 2009-06-01 01:55:57.000000000 +0200
+@@ -300,7 +300,8 @@
+ check_module("QtWebKit", "qwebpage.h", "new QWebPage()")
+ check_module("QtXml", "qdom.h", "new QDomDocument()")
+ check_module("QtXmlPatterns", "qxmlname.h", "new QXmlName()")
+- check_module("phonon", "phonon", "new Phonon::VideoWidget()")
++ check_module("phonon", "videowidget.h", "new Phonon::VideoWidget()",
++ extra_include_dirs=["/usr/include/phonon"])
+ check_module("QtAssistant", "qassistantclient.h",
+ "new QAssistantClient(\"foo\")", extra_lib_dirs=ass_lib_dirs,
+ extra_libs=ass_libs)
+@@ -394,7 +395,7 @@
+ generate_code("QtXmlPatterns")
+
+ if "phonon" in pyqt_modules:
+- generate_code("phonon")
++ generate_code("phonon", extra_include_dirs=["/usr/include/phonon"])
+
+ if "QtAssistant" in pyqt_modules:
+ generate_code("QtAssistant")
+@@ -666,6 +667,7 @@
install_dir=pydbusmoddir,
qt=["QtCore"],
debug=opts.debug,
@@ -9,7 +28,7 @@ diff -Naur PyQt-x11-gpl-4.4.4~orig/configure.py PyQt-x11-gpl-4.4.4/configure.py
universal=sipcfg.universal
)
-@@ -1350,6 +1351,7 @@
+@@ -1350,6 +1352,7 @@
warnings=1,
static=opts.static,
debug=opts.debug,
@@ -17,7 +36,7 @@ diff -Naur PyQt-x11-gpl-4.4.4~orig/configure.py PyQt-x11-gpl-4.4.4/configure.py
universal=sipcfg.universal
)
-@@ -1510,7 +1512,7 @@
+@@ -1510,7 +1513,7 @@
# The Qt binary installer has macx-xcode as the default.
args = "-spec macx-g++ " + args
diff --git a/dev-python/PyQt4/metadata.xml b/dev-python/PyQt4/metadata.xml
index ce808a4242ee..21beed1e3bd7 100644
--- a/dev-python/PyQt4/metadata.xml
+++ b/dev-python/PyQt4/metadata.xml
@@ -4,7 +4,14 @@
<herd>python</herd>
<herd>qt</herd>
<use>
- <flag name='qt3support'>enable the Qt3Support libraries for Qt4</flag>
- <flag name='webkit'>enable WebKit support</flag>
+ <flag name='X'>Build the QtGui and QtDesigner modules</flag>
+ <flag name='assistant'>Build the QtHelp and QtAssistant modules</flag>
+ <flag name='opengl'>Build the QtOpenGL module</flag>
+ <flag name='phonon'>Build the phonon module</flag>
+ <flag name='qt3support'>Enable the Qt3Support libraries for Qt4</flag>
+ <flag name='sql'>Build the QtSql module</flag>
+ <flag name='svg'>Build the QtSvg module</flag>
+ <flag name='webkit'>Build the QtWebKit module</flag>
+ <flag name='xmlpatterns'>Build the QtXmlPatterns module</flag>
</use>
</pkgmetadata>