summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-02 16:14:25 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-02 16:14:25 +0000
commitff956192c28a62dc8c7409fac4062ef9f2b7d1c5 (patch)
treef66359f172d405055d7a63764386e6aec88214d0
parentnew portage bug fix release (diff)
downloadgentoo-2-ff956192c28a62dc8c7409fac4062ef9f2b7d1c5.tar.gz
gentoo-2-ff956192c28a62dc8c7409fac4062ef9f2b7d1c5.tar.bz2
gentoo-2-ff956192c28a62dc8c7409fac4062ef9f2b7d1c5.zip
*** empty log message ***
-rw-r--r--berlin-base/omniORB/files/digest-omniORB-3031
-rw-r--r--berlin-base/omniORB/omniORB-303.ebuild6
-rwxr-xr-xbootstrap.sh25
-rw-r--r--files/build-20010501.packages2
-rw-r--r--files/sys-20010501.packages2
-rw-r--r--profiles/default/packages4
-rw-r--r--sys-apps/iproute2/iproute2-2.2.4-r2.ebuild12
-rw-r--r--sys-devel/gcc/gcc-2.95.3.ebuild4
8 files changed, 39 insertions, 17 deletions
diff --git a/berlin-base/omniORB/files/digest-omniORB-303 b/berlin-base/omniORB/files/digest-omniORB-303
new file mode 100644
index 000000000000..6162c1bb669d
--- /dev/null
+++ b/berlin-base/omniORB/files/digest-omniORB-303
@@ -0,0 +1 @@
+MD5 221e68ca295c9bbcf2e23491a0d0dc2c omniORB_303.tar.gz
diff --git a/berlin-base/omniORB/omniORB-303.ebuild b/berlin-base/omniORB/omniORB-303.ebuild
index 819cb1ad038d..91eadd3e0949 100644
--- a/berlin-base/omniORB/omniORB-303.ebuild
+++ b/berlin-base/omniORB/omniORB-303.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/berlin-base/omniORB/omniORB-303.ebuild,v 1.1 2001/05/02 15:00:56 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/berlin-base/omniORB/omniORB-303.ebuild,v 1.2 2001/05/02 16:14:25 achim Exp $
A=${PN}_${PV}.tar.gz
S=${WORKDIR}/omni
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.uk.research.att.com/omniORB/"
DEPEND=""
-PLT="i686_linux_2.4_glibc2.2"
+PLT="i586_linux_2.0_glibc2.1"
src_unpack() {
@@ -59,7 +59,7 @@ src_install () {
cp -af lib/python/* ${D}/usr/lib/python2.0/
doman man/man[15]/*.[15]
- dodoc CHANGES* COPYING* CREDITS PORTING README* ReleaseNote_omniORB_302 THIS_IS_omniORB_3_0_2
+ dodoc CHANGES* COPYING* CREDITS PORTING README* ReleaseNote_omniORB_303 THIS_IS_omniORB_3_0_3
cd doc
docinto ps
dodoc *.ps
diff --git a/bootstrap.sh b/bootstrap.sh
new file mode 100755
index 000000000000..05cbfe52f38f
--- /dev/null
+++ b/bootstrap.sh
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+LIST=$1
+
+myGETTEXT=`grep "sys-devel/gettext" $1`
+myBINUTILS=`grep "sys-devel/binutils" $1`
+myGCC=`grep "sys-devel/gcc" $1`
+myGLIBC=`grep "sys-libs/glibc" $1`
+
+echo "Using BINUTILS $myBINUTILS"
+echo "Using GCC $myGCC"
+echo "Using GETTEXT $myGETTEXT"
+echo "Using GLIBC $myGLIBC"
+
+export USE="build"
+export STEPS="clean unpack compile install qmerge"
+cd /usr/portage
+ebuild $myBINUTILS $STEPS || exit
+ebuild $myGCC $STEPS || exit
+ebuild $myGETTEXT $STEPS || exit
+unset USE
+ebuild $myGLIBC $STEPS || exit
+ebuild $myGETTEXT $STEPS || exit
+ebuild $myBINUTILS $STEPS || exit
+ebuild $myGCC $STEPS || exit
diff --git a/files/build-20010501.packages b/files/build-20010501.packages
index c9b4881bf5af..78f1d8b1c358 100644
--- a/files/build-20010501.packages
+++ b/files/build-20010501.packages
@@ -10,7 +10,7 @@
./sys-apps/gawk/gawk-3.0.6-r3.ebuild
./sys-apps/grep/grep-2.4.2-r3.ebuild
./sys-apps/gzip/gzip-1.2.4a-r3.ebuild
-./sys-apps/portage/portage-1.5-r4.ebuild
+./sys-apps/portage/portage-1.5-r5.ebuild
./sys-apps/sed/sed-3.02.80-r2.ebuild
./sys-apps/sh-utils/sh-utils-2.0j-r3.ebuild
./sys-apps/tar/tar-1.13.18-r4.ebuild
diff --git a/files/sys-20010501.packages b/files/sys-20010501.packages
index ed26cef5c2a0..5cb3e8e0fe40 100644
--- a/files/sys-20010501.packages
+++ b/files/sys-20010501.packages
@@ -48,7 +48,7 @@
./sys-apps/most/most-4.9.0-r2.ebuild
./sys-apps/net-tools/net-tools-1.59.ebuild
./sys-apps/netkit-base/netkit-base-0.17-r2.ebuild
-./sys-apps/portage/portage-1.5-r4.ebuild
+./sys-apps/portage/portage-1.5-r5.ebuild
./sys-apps/procps/procps-2.0.6-r1.ebuild
./sys-apps/psmisc/psmisc-19-r2.ebuild
./sys-apps/raidtools/raidtools-0.90-r2.ebuild
diff --git a/profiles/default/packages b/profiles/default/packages
index 4bc2b22c0198..fd5c0e296185 100644
--- a/profiles/default/packages
+++ b/profiles/default/packages
@@ -11,10 +11,7 @@ sys-libs/ncurses
sys-libs/pam
sys-libs/readline
sys-libs/zlib
-
sys-apps/at
-#Hmmm... having baselayout in here may not be a good idea
-sys-apps/baselayout
sys-apps/bash
sys-apps/bzip2
sys-apps/console-data
@@ -61,7 +58,6 @@ sys-apps/setserial
sys-apps/sh-utils
sys-apps/shadow
sys-apps/sharutils
-sys-apps/shtool
sys-apps/star
sys-apps/sysklogd
sys-apps/sysvinit
diff --git a/sys-apps/iproute2/iproute2-2.2.4-r2.ebuild b/sys-apps/iproute2/iproute2-2.2.4-r2.ebuild
index 4335df0b12a1..1d33a8246c2b 100644
--- a/sys-apps/iproute2/iproute2-2.2.4-r2.ebuild
+++ b/sys-apps/iproute2/iproute2-2.2.4-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.2.4-r2.ebuild,v 1.1 2001/03/03 04:32:08 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.2.4-r2.ebuild,v 1.2 2001/05/02 16:14:25 achim Exp $
A=iproute2-2.2.4-now-ss001007.tar.gz
S=${WORKDIR}/iproute2
@@ -13,11 +13,11 @@ DEPEND="virtual/glibc tex? ( app-text/tetex )"
src_unpack() {
unpack ${A}
cd ${S}
- cp Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/g" Makefile.orig > Makefile
- #this next thing is required to enable diffserv (ATM support doesn't compile right now)
- cp Config Config.orig
- sed -e 's/DIFFSERV=n/DIFFSERV=y/g' Config.orig > Config
+# cp Makefile Makefile.orig
+# sed -e "s/-O2/${CFLAGS}/g" Makefile.orig > Makefile
+# #this next thing is required to enable diffserv (ATM support doesn't compile right now)
+# cp Config Config.orig
+# sed -e 's/DIFFSERV=n/DIFFSERV=y/g' Config.orig > Config
}
src_compile() {
diff --git a/sys-devel/gcc/gcc-2.95.3.ebuild b/sys-devel/gcc/gcc-2.95.3.ebuild
index 0fdc58a5fce9..a28de612a3ef 100644
--- a/sys-devel/gcc/gcc-2.95.3.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3.ebuild,v 1.3 2001/05/01 10:13:55 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3.ebuild,v 1.4 2001/05/02 16:14:25 achim Exp $
SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.gz"
@@ -22,7 +22,7 @@ T=/usr
DESCRIPTION="Modern GCC C/C++ compiler"
HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
if [ -z "`use build`" ] ; then
- DEPEND="nls? ( sys-devel/gettext )"
+ DEPEND="nls? ( sys-devel/gettext ) sys-apps/texinfo"
fi