summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-31 16:40:32 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-31 16:40:32 +0000
commitbfc983d0f32eb8caa85806d57ee7e38213f4718c (patch)
tree8acf23c90f0c67b4269bd14a64c456549b084933 /app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild
parentversion bump (diff)
downloadgentoo-2-bfc983d0f32eb8caa85806d57ee7e38213f4718c.tar.gz
gentoo-2-bfc983d0f32eb8caa85806d57ee7e38213f4718c.tar.bz2
gentoo-2-bfc983d0f32eb8caa85806d57ee7e38213f4718c.zip
version bump
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild')
-rw-r--r--app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild b/app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild
new file mode 100644
index 000000000000..3471918523bd
--- /dev/null
+++ b/app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild,v 1.1 2013/03/31 16:40:31 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib python-single-r1
+
+DESCRIPTION="Speech Recognition (Training Module)"
+HOMEPAGE="http://cmusphinx.sourceforge.net/html/cmusphinx.php"
+SRC_URI="mirror://sourceforge/cmusphinx/sphinxtrain-${PV}.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-accessibility/sphinxbase
+ dev-lang/perl
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/sphinxtrain-${PV}
+
+src_install() {
+ default
+ dodoc README etc/*cfg
+
+ python_fix_shebang "${D}"/usr/bin/sphinxtrain
+ python_optimize "${D}"/usr/$(get_libdir)/sphinxtrain/python/cmusphinx
+}
+
+pkg_postinst() {
+ elog "Detailed usage and training instructions can be found at"
+ elog "http://cmusphinx.sourceforge.net/wiki/"
+}