summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-09-07 03:46:25 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-09-07 03:46:25 +0000
commitb17bb18ecf51dc88b75c61cd5df4a4d2a4b7d589 (patch)
tree2fb7bd5d8b33115052d9326d70242514706797c3 /app-accessibility/dasher
parentgnome 2.16 (diff)
downloadgentoo-2-b17bb18ecf51dc88b75c61cd5df4a4d2a4b7d589.tar.gz
gentoo-2-b17bb18ecf51dc88b75c61cd5df4a4d2a4b7d589.tar.bz2
gentoo-2-b17bb18ecf51dc88b75c61cd5df4a4d2a4b7d589.zip
gnome 2.16
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'app-accessibility/dasher')
-rw-r--r--app-accessibility/dasher/ChangeLog8
-rw-r--r--app-accessibility/dasher/dasher-4.2.0.ebuild67
-rw-r--r--app-accessibility/dasher/files/dasher-4.1.10-as-needed.patch50
-rw-r--r--app-accessibility/dasher/files/digest-dasher-4.2.03
4 files changed, 127 insertions, 1 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index bf3142241738..672585c9680d 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.70 2006/08/16 13:01:21 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.71 2006/09/07 03:46:25 dang Exp $
+
+*dasher-4.2.0 (07 Sep 2006)
+
+ 07 Sep 2006; Daniel Gryniewicz <dang@gentoo.org>
+ +files/dasher-4.1.10-as-needed.patch, +dasher-4.2.0.ebuild:
+ New version for gnome 2.16
16 Aug 2006; Markus Rothe <corsair@gentoo.org> dasher-4.0.2.ebuild:
Stable on ppc64
diff --git a/app-accessibility/dasher/dasher-4.2.0.ebuild b/app-accessibility/dasher/dasher-4.2.0.ebuild
new file mode 100644
index 000000000000..353a1edc40b1
--- /dev/null
+++ b/app-accessibility/dasher/dasher-4.2.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.2.0.ebuild,v 1.1 2006/09/07 03:46:25 dang Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
+HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="accessibility gnome cairo"
+
+# The package claims to support 'qte', but it hasn't been tested.
+# Any patches from someone who can test it are welcome.
+# <leonardop@gentoo.org>
+RDEPEND="dev-libs/expat
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=dev-libs/glib-2.6
+ >=x11-libs/libwnck-1
+ || ( (
+ x11-libs/libX11 )
+ virtual/x11 )
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2 )
+ accessibility? (
+ app-accessibility/gnome-speech
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-extra/at-spi-1 )
+ cairo? (
+ x11-libs/cairo
+ >=x11-libs/gtk+-2.8 )"
+
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libXt )
+ virtual/x11 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+
+pkg_setup() {
+ G2CONF="$(use_with gnome) \
+ $(use_enable accessibility a11y) \
+ $(use_enable accessibility speech) \
+ $(use_with cairo)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ sed -i -e 's:gtk-update-icon-cache:true:' ./Data/Makefile.am ./Data/Makefile.in
+ epatch ${FILESDIR}/${PN}-4.1.10-as-needed.patch
+}
diff --git a/app-accessibility/dasher/files/dasher-4.1.10-as-needed.patch b/app-accessibility/dasher/files/dasher-4.1.10-as-needed.patch
new file mode 100644
index 000000000000..0d2b15ce969a
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.1.10-as-needed.patch
@@ -0,0 +1,50 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN dasher-4.1.10.orig/Src/Makefile.am dasher-4.1.10/Src/Makefile.am
+--- dasher-4.1.10.orig/Src/Makefile.am 2006-08-21 17:25:30.000000000 -0400
++++ dasher-4.1.10/Src/Makefile.am 2006-09-04 22:33:46.000000000 -0400
+@@ -24,16 +24,16 @@
+ -DPACKAGE_LOCALE_DIR=\"$(datadir)/locale\"
+
+ dasher_LDADD = \
+- $(GTK2BUILD_LIBS) \
+- -lexpat \
+- $(POPT_LIBS) \
+- $(GPELIB) \
+ Common/libdashermisc.a \
+ Gtk2/libdashergtk.a \
+ Gtk2/libdashercontrol.a \
+ DasherCore/libdashercore.a \
+ DasherCore/LanguageModelling/libdasherlm.a \
+- DasherCore/Alphabet/libdasheralphabet.a
++ DasherCore/Alphabet/libdasheralphabet.a \
++ $(GTK2BUILD_LIBS) \
++ -lexpat \
++ $(POPT_LIBS) \
++ $(GPELIB)
+ endif
+
+ if DOQTE
+diff --exclude-from=/home/dang/.diffrc -u -ruN dasher-4.1.10.orig/Src/Makefile.in dasher-4.1.10/Src/Makefile.in
+--- dasher-4.1.10.orig/Src/Makefile.in 2006-08-21 17:25:30.000000000 -0400
++++ dasher-4.1.10/Src/Makefile.in 2006-09-04 22:41:26.000000000 -0400
+@@ -299,16 +299,16 @@
+ @DOGTK2_TRUE@ -DPACKAGE_LOCALE_DIR=\"$(datadir)/locale\"
+
+ @DOGTK2_TRUE@dasher_LDADD = \
+-@DOGTK2_TRUE@ $(GTK2BUILD_LIBS) \
+-@DOGTK2_TRUE@ -lexpat \
+-@DOGTK2_TRUE@ $(POPT_LIBS) \
+-@DOGTK2_TRUE@ $(GPELIB) \
+ @DOGTK2_TRUE@ Common/libdashermisc.a \
+ @DOGTK2_TRUE@ Gtk2/libdashergtk.a \
+ @DOGTK2_TRUE@ Gtk2/libdashercontrol.a \
+ @DOGTK2_TRUE@ DasherCore/libdashercore.a \
+ @DOGTK2_TRUE@ DasherCore/LanguageModelling/libdasherlm.a \
+-@DOGTK2_TRUE@ DasherCore/Alphabet/libdasheralphabet.a
++@DOGTK2_TRUE@ DasherCore/Alphabet/libdasheralphabet.a \
++@DOGTK2_TRUE@ $(GTK2BUILD_LIBS) \
++@DOGTK2_TRUE@ -lexpat \
++@DOGTK2_TRUE@ $(POPT_LIBS) \
++@DOGTK2_TRUE@ $(GPELIB)
+
+ @DOQTE_TRUE@QTDIR = /usr/share/qte2
+ all: all-recursive
diff --git a/app-accessibility/dasher/files/digest-dasher-4.2.0 b/app-accessibility/dasher/files/digest-dasher-4.2.0
new file mode 100644
index 000000000000..0b3d64dde564
--- /dev/null
+++ b/app-accessibility/dasher/files/digest-dasher-4.2.0
@@ -0,0 +1,3 @@
+MD5 9db6f0ac46041300e7126a073a40530e dasher-4.2.0.tar.bz2 5632602
+RMD160 a557b1041ee3fa34627b916e62b4e705469769d2 dasher-4.2.0.tar.bz2 5632602
+SHA256 1664de06b3090b762ae5292a6ccf01681e857a8f8e320fb552aad810256e76ca dasher-4.2.0.tar.bz2 5632602