summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-07-11 05:14:31 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-07-11 05:14:31 +0000
commit705556e2e4adff76b4d1a07429ec8138997730c8 (patch)
tree679a9215d16185b29fc1230bfc24104fdff4f21b /app-accessibility/espeak
parentAccidentally inherited unneeded versionator eclass (diff)
downloadgentoo-2-705556e2e4adff76b4d1a07429ec8138997730c8.tar.gz
gentoo-2-705556e2e4adff76b4d1a07429ec8138997730c8.tar.bz2
gentoo-2-705556e2e4adff76b4d1a07429ec8138997730c8.zip
version bump for bug #476462
(Portage version: 2.2.0_alpha188/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'app-accessibility/espeak')
-rw-r--r--app-accessibility/espeak/ChangeLog7
-rw-r--r--app-accessibility/espeak/espeak-1.47.11.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index e57a92c435d9..6e5ce725d308 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/espeak
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.106 2013/02/02 22:17:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.107 2013/07/11 05:14:31 williamh Exp $
+
+*espeak-1.47.11 (11 Jul 2013)
+
+ 11 Jul 2013; William Hubbs <williamh@gentoo.org> +espeak-1.47.11.ebuild:
+ version bump for bug #476462
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> espeak-1.46.01.ebuild:
Add ~arm, wrt bug #449220
diff --git a/app-accessibility/espeak/espeak-1.47.11.ebuild b/app-accessibility/espeak/espeak-1.47.11.ebuild
new file mode 100644
index 000000000000..56019e372401
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.47.11.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.47.11.ebuild,v 1.1 2013/07/11 05:14:31 williamh Exp $
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="portaudio pulseaudio"
+RDEPEND="media-sound/sox
+ pulseaudio? ( media-sound/pulseaudio )
+ portaudio? ( >=media-libs/portaudio-19_pre20071207 )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+get_audio() {
+ if use portaudio && use pulseaudio; then
+ echo runtime
+ elif use portaudio; then
+ echo portaudio
+ elif use pulseaudio; then
+ echo pulseaudio
+ else
+ echo none
+ fi
+}
+
+src_prepare() {
+ cd src
+ # gentoo uses portaudio 19.
+ mv -f portaudio19.h portaudio.h
+}
+
+src_compile() {
+ cd src
+ emake PREFIX="${EPREFIX}/usr" AUDIO="$(get_audio)" \
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" all
+
+ einfo "Fixing byte order of phoneme data files"
+ cd "${S}/platforms/big_endian"
+ make
+ ./espeak-phoneme-data "${S}/espeak-data"
+ cp -f phondata phonindex phontab "${S}/espeak-data"
+}
+
+src_install() {
+ cd src
+ make DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="\$(PREFIX)/$(get_libdir)" AUDIO="$(get_audio)" install
+
+ cd ..
+ insinto /usr/share/espeak-data
+ doins -r dictsource
+ dodoc ChangeLog.txt ReadMe
+ dohtml -r docs/*
+}
+
+pkg_preinst() {
+ local voicedir="${ROOT}/usr/share/${PN}-data/voices/en"
+ local errormsg="${voicedir} not empty. Please remove it manually."
+ if [ -d "${voicedir}" ]; then
+ rmdir "${voicedir}" || die "${errormsg}"
+ fi
+}
+
+pkg_postinst() {
+ if ! use portaudio && ! use pulseaudio; then
+ ewarn "Since portaudio and pulseaudio are not in your use flags,"
+ ewarn "espeak will only be able to create wav files."
+ ewarn "If this is not what you want, please reemerge ${CATEGORY}/${PN}"
+ ewarn "with either portaudio or pulseaudio USE flag enabled."
+ fi
+}