summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2010-10-05 21:11:18 +0000
committerWilliam Hubbs <williamh@gentoo.org>2010-10-05 21:11:18 +0000
commit93de517abe871b60b2c2a722b25cd4be39df74b6 (patch)
tree4482341994a19a2a3c560db31ea53dfacd10d66b /app-accessibility/speech-dispatcher
parentx86 stable, bug #336646 (diff)
downloadgentoo-2-93de517abe871b60b2c2a722b25cd4be39df74b6.tar.gz
gentoo-2-93de517abe871b60b2c2a722b25cd4be39df74b6.tar.bz2
gentoo-2-93de517abe871b60b2c2a722b25cd4be39df74b6.zip
version bump and remove old version
(Portage version: 2.2_rc88/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/speech-dispatcher')
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog8
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6.ebuild59
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1.ebuild73
3 files changed, 80 insertions, 60 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index 8a9631d1ba1a..baba4fe8b725 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/speech-dispatcher
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.68 2010/07/20 18:31:55 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.69 2010/10/05 21:11:18 williamh Exp $
+
+*speech-dispatcher-0.7.1 (05 Oct 2010)
+
+ 05 Oct 2010; William Hubbs <williamh@gentoo.org>
+ -speech-dispatcher-0.6.6.ebuild, +speech-dispatcher-0.7.1.ebuild:
+ version bump and removed old version
20 Jul 2010; Jeroen Roovers <jer@gentoo.org>
speech-dispatcher-0.6.7.ebuild:
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6.ebuild
deleted file mode 100644
index dcfefb3f2da1..000000000000
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6.ebuild,v 1.9 2010/03/03 07:34:06 williamh Exp $
-
-inherit eutils
-
-DESCRIPTION="speech-dispatcher speech synthesis interface"
-HOMEPAGE="http://www.freebsoft.org/speechd"
-SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 hppa ppc sparc x86"
-IUSE="alsa flite nas pulseaudio python"
-
-RDEPEND="dev-libs/dotconf
- >=dev-libs/glib-2
- alsa? ( media-libs/alsa-lib )
- flite? ( <app-accessibility/flite-1.4 )
- nas? ( media-libs/nas )
- pulseaudio? ( media-sound/pulseaudio )
- python? ( dev-lang/python )
- app-accessibility/espeak"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- sed -i -e 's/\(SUBDIRS.*\)python/\1/' "${S}"/src/Makefile.in
-}
-
-src_compile() {
- econf \
- $(use_with alsa) \
- $(use_with flite) \
- $(use_with pulseaudio pulse) \
- $(use_with nas) || die "configure failed"
- make all || die "make failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- if use python; then
- cd "${S}"/src/python
- ./setup.py install --root="${D}" --no-compile
- cd "${S}"
- fi
-
- insinto /usr/include
- doins "${S}"/src/c/api/libspeechd.h
-
- dodoc AUTHORS ChangeLog NEWS TODO
- newinitd "${FILESDIR}"/speech-dispatcher speech-dispatcher
-}
-
-pkg_postinst() {
- elog "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
-}
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1.ebuild
new file mode 100644
index 000000000000..e976bae630e5
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1.ebuild,v 1.1 2010/10/05 21:11:18 williamh Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="speech-dispatcher speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alsa ao +espeak flite nas pulseaudio python"
+
+RDEPEND="dev-libs/dotconf
+ >=dev-libs/glib-2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ espeak? ( app-accessibility/espeak )
+ flite? ( app-accessibility/flite )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-sound/pulseaudio )
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_with alsa) \
+ $(use_with ao libao) \
+ $(use_with espeak) \
+ $(use_with flite) \
+ $(use_with pulseaudio pulse) \
+ $(use_with nas)
+}
+
+src_compile() {
+ emake all || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS TODO
+}
+
+pkg_postinst() {
+ if ! use espeak; then
+ ewarn "You have disabled espeak, which is speech-dispatcher's"
+ ewarn "default speech synthesizer."
+ ewarn
+ editconfig="y"
+ fi
+ if ! use pulseaudio; then
+ ewarn "You have disabled pulseaudio support."
+ ewarn "pulseaudio is speech-dispatcher's default audio subsystem."
+ ewarn
+ editconfig="y"
+ fi
+ if [ -n "$editconfig" ]; then
+ ewarn "You must edit ${EROOT}etc/speech-dispatcher/speechd.conf"
+ ewarn "and make sure the settings there match your system."
+ ewarn
+ fi
+ ewarn "This version does not include a system wide startup script"
+ ewarn "since it is not intended to be run in system-wide mode."
+ ewarn
+ elog "For festival support, you need to"
+ elog "install app-accessibility/festival-freebsoft-utils."
+}