summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-03-16 22:43:05 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-03-16 22:43:05 +0000
commit03e1f27204b7f4f3ffa5ef5aefd112fac84629ae (patch)
tree3ebb88b151f05c358f4eaaa981c65bc424f8e797 /app-accessibility
parentNot so fast in regards to sparc, no stable OOo related package there (diff)
downloadgentoo-2-03e1f27204b7f4f3ffa5ef5aefd112fac84629ae.tar.gz
gentoo-2-03e1f27204b7f4f3ffa5ef5aefd112fac84629ae.tar.bz2
gentoo-2-03e1f27204b7f4f3ffa5ef5aefd112fac84629ae.zip
Version bump. Closes bug #340317 and #357381.
(Portage version: 2.2.0_alpha9/cvs/Linux i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/festival/ChangeLog9
-rw-r--r--app-accessibility/festival/festival-2.1.ebuild120
-rw-r--r--app-accessibility/festival/files/festival-2.1-gentoo-system.patch124
-rw-r--r--app-accessibility/festival/files/festival-2.1-init-scm.patch24
-rw-r--r--app-accessibility/festival/files/festival-2.1-ldflags.patch12
5 files changed, 288 insertions, 1 deletions
diff --git a/app-accessibility/festival/ChangeLog b/app-accessibility/festival/ChangeLog
index 51b6642628bb..0adfc2f60b85 100644
--- a/app-accessibility/festival/ChangeLog
+++ b/app-accessibility/festival/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/festival
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/ChangeLog,v 1.92 2011/03/04 20:12:51 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/ChangeLog,v 1.93 2011/03/16 22:43:05 neurogeek Exp $
+
+*festival-2.1 (16 Mar 2011)
+
+ 16 Mar 2011; Jesus Rivero <neurogeek@gentoo.org> +festival-2.1.ebuild,
+ +files/festival-2.1-gentoo-system.patch,
+ +files/festival-2.1-init-scm.patch, +files/festival-2.1-ldflags.patch:
+ Version bump. Closes bug #340317 and #357381.
04 Mar 2011; William Hubbs <williamh@gentoo.org> festival-1.96_beta.ebuild,
festival-1.96_beta-r1.ebuild, festival-2.0.95_beta.ebuild:
diff --git a/app-accessibility/festival/festival-2.1.ebuild b/app-accessibility/festival/festival-2.1.ebuild
new file mode 100644
index 000000000000..5963541ae8eb
--- /dev/null
+++ b/app-accessibility/festival/festival-2.1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/festival-2.1.ebuild,v 1.1 2011/03/16 22:43:05 neurogeek Exp $
+
+EAPI="2"
+inherit eutils toolchain-funcs
+
+MY_PV="${PV}-release"
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Festival Text to Speech engine"
+HOMEPAGE="http://www.cstr.ed.ac.uk/projects/festival/"
+SITE="http://www.festvox.org/packed/${PN}/${PV}"
+SRC_URI="${SITE}/${MY_P}.tar.gz
+ ${SITE}/festlex_CMU.tar.gz
+ ${SITE}/festlex_OALD.tar.gz
+ ${SITE}/festlex_POSLEX.tar.gz
+ ${SITE}/festvox_cmu_us_awb_cg.tar.gz
+ ${SITE}/festvox_cmu_us_rms_cg.tar.gz
+ ${SITE}/festvox_cmu_us_slt_arctic_hts.tar.gz
+ ${SITE}/festvox_rablpc16k.tar.gz
+ ${SITE}/festvox_kallpc16k.tar.gz
+ ${SITE}/speech_tools-${MY_PV}.tar.gz"
+
+LICENSE="FESTIVAL BSD as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~app-accessibility/speech-tools-2.1"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/festival
+
+pkg_setup() {
+ enewuser festival -1 -1 -1 audio
+}
+
+src_prepare() {
+ # tell festival to use the speech-tools we have installed.
+ sed -i -e "s:\(EST=\).*:\1/usr/share/speech-tools:" "${S}"/config/config.in
+ sed -i -e "s:\$(EST)/lib:/usr/$(get_libdir):" "${S}"/config/project.mak
+
+ # fix the reference to /usr/lib/festival
+ sed -i -e "s:\(FTLIBDIR.*=.*\)\$.*:\1/usr/share/festival:" "${S}"/config/project.mak
+
+ # Fix path for examples in festival.scm
+ sed -i -e "s:\.\./examples/:/usr/share/doc/${PF}/examples/:" "${S}"/lib/festival.scm
+
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}/${P}-init-scm.patch"
+ epatch "${FILESDIR}/${P}-gentoo-system.patch"
+
+ # copy what we need for MultiSyn from speech_tools.
+ cp -pr "${WORKDIR}"/speech_tools/base_class "${S}"/src/modules/MultiSyn
+
+}
+
+src_configure() {
+ econf || die "econf failed"
+}
+
+src_compile() {
+ emake -j1 PROJECT_LIBDEPS="" REQUIRED_LIBDEPS="" LOCAL_LIBDEPS="" \
+ OPTIMISE_CXXFLAGS="${CXXFLAGS}" OPTIMISE_CCFLAGS="${CFLAGS}" \
+ LDFLAGS=${LDFLAGS} \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ # Install the binaries
+ dobin src/main/festival
+ dobin lib/etc/*Linux*/audsp
+ dolib.a src/lib/libFestival.a
+
+ # Install the main libraries
+ insinto /usr/share/festival
+ doins -r lib/*
+
+ # Install the examples
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+
+ # Need to fix saytime, etc. to look for festival in the correct spot
+ for ex in "${D}"/usr/share/doc/${PF}/examples/*.sh; do
+ exnoext=${ex%%.sh}
+ chmod a+x "${exnoext}"
+ dosed "s:${S}/bin/festival:/usr/bin/festival:" "${exnoext##$D}"
+ done
+
+ # Install the header files
+ insinto /usr/include/festival
+ doins src/include/*.h
+
+ insinto /etc/festival
+ doins lib/site*
+
+ # Install the docs
+ dodoc "${S}"/{ACKNOWLEDGMENTS,NEWS,README}
+ doman "${S}"/doc/{festival.1,festival_client.1}
+
+ # create the directory where our log file will go.
+ diropts -m 0755 -o festival -g audio
+ keepdir /var/log/festival
+
+}
+
+pkg_postinst() {
+ elog
+ elog " Useful examples include saytime, text2wave. For example, try:"
+ elog " \"/usr/share/doc/${PF}/examples/saytime\""
+ elog
+ elog " Or for something more fun:"
+ elog ' "echo "Gentoo can speak" | festival --tts"'
+ elog
+ elog "This version also allows configuration of site specific"
+ elog "initialization in /etc/festival/siteinit.scm and"
+ elog "variables in /etc/festival/sitevars.scm."
+ elog
+}
diff --git a/app-accessibility/festival/files/festival-2.1-gentoo-system.patch b/app-accessibility/festival/files/festival-2.1-gentoo-system.patch
new file mode 100644
index 000000000000..a09e1379eebf
--- /dev/null
+++ b/app-accessibility/festival/files/festival-2.1-gentoo-system.patch
@@ -0,0 +1,124 @@
+diff -uNr festival.orig/config/systems/GentooLinux.mak festival/config/systems/GentooLinux.mak
+--- festival.orig/config/systems/GentooLinux.mak 1969-12-31 19:00:00.000000000 -0500
++++ festival/config/systems/GentooLinux.mak 2011-02-09 10:43:28.000000000 -0500
+@@ -0,0 +1,42 @@
++ ###########################################################################
++ ## ##
++ ## Centre for Speech Technology Research ##
++ ## University of Edinburgh, UK ##
++ ## Copyright (c) 1996 ##
++ ## All Rights Reserved. ##
++ ## ##
++ ## Permission is hereby granted, free of charge, to use and distribute ##
++ ## this software and its documentation without restriction, including ##
++ ## without limitation the rights to use, copy, modify, merge, publish, ##
++ ## distribute, sublicense, and/or sell copies of this work, and to ##
++ ## permit persons to whom this work is furnished to do so, subject to ##
++ ## the following conditions: ##
++ ## 1. The code must retain the above copyright notice, this list of ##
++ ## conditions and the following disclaimer. ##
++ ## 2. Any modifications must be clearly marked as such. ##
++ ## 3. Original authors' names are not deleted. ##
++ ## 4. The authors' names are not used to endorse or promote products ##
++ ## derived from this software without specific prior written ##
++ ## permission. ##
++ ## ##
++ ## THE UNIVERSITY OF EDINBURGH AND THE CONTRIBUTORS TO THIS WORK ##
++ ## DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ##
++ ## ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT ##
++ ## SHALL THE UNIVERSITY OF EDINBURGH NOR THE CONTRIBUTORS BE LIABLE ##
++ ## FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES ##
++ ## WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN ##
++ ## AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ##
++ ## ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF ##
++ ## THIS SOFTWARE. ##
++ ## ##
++ ###########################################################################
++ ## ##
++ ## Author: William Hubbs <williamh@gentoo.org> ##
++ ## -------------------------------------------------------------------- ##
++ ## Settings for Gentoo Linux distributions. ##
++ ## ##
++ ###########################################################################
++
++MANDIR=$(INSTALL_PREFIX)/share/man
++# Gentoo does not use termcap
++OS_LIBS = $(LDFLAGS) -ldl -lncurses
+diff -uNr festival.orig/config/systems/Makefile festival/config/systems/Makefile
+--- festival.orig/config/systems/Makefile 2011-02-09 10:41:01.000000000 -0500
++++ festival/config/systems/Makefile 2011-02-09 10:44:22.000000000 -0500
+@@ -41,6 +41,7 @@
+ Linux.mak \
+ RedHatLinux.mak \
+ DebianGNULinux.mak \
++ GentooLinux.mak \
+ alpha_Linux.mak \
+ alpha_OSF1V4.0.mak \
+ alpha_RedHatLinux.mak \
+@@ -94,6 +95,7 @@
+ sparc_SunOS5.8.mak \
+ sparc_SunOS5.mak \
+ unknown_DebianGNULinux.mak \
++ unknown_GentooLinux.mak \
+ unknown_Linux.mak \
+ unknown_RedHatLinux.mak \
+ power_macintosh_Darwin.mak \
+diff -uNr festival.orig/config/systems/unknown_GentooLinux.mak festival/config/systems/unknown_GentooLinux.mak
+--- festival.orig/config/systems/unknown_GentooLinux.mak 1969-12-31 19:00:00.000000000 -0500
++++ festival/config/systems/unknown_GentooLinux.mak 2011-02-09 10:45:34.000000000 -0500
+@@ -0,0 +1,41 @@
++###########################################################################
++## ##
++## Centre for Speech Technology Research ##
++## University of Edinburgh, UK ##
++## Copyright (c) 1996 ##
++## All Rights Reserved. ##
++## ##
++## Permission is hereby granted, free of charge, to use and distribute ##
++## this software and its documentation without restriction, including ##
++## without limitation the rights to use, copy, modify, merge, publish, ##
++## distribute, sublicense, and/or sell copies of this work, and to ##
++## permit persons to whom this work is furnished to do so, subject to ##
++## the following conditions: ##
++## 1. The code must retain the above copyright notice, this list of ##
++## conditions and the following disclaimer. ##
++## 2. Any modifications must be clearly marked as such. ##
++## 3. Original authors' names are not deleted. ##
++## 4. The authors' names are not used to endorse or promote products ##
++## derived from this software without specific prior written ##
++## permission. ##
++## ##
++## THE UNIVERSITY OF EDINBURGH AND THE CONTRIBUTORS TO THIS WORK ##
++## DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ##
++## ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT ##
++## SHALL THE UNIVERSITY OF EDINBURGH NOR THE CONTRIBUTORS BE LIABLE ##
++## FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES ##
++## WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN ##
++## AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ##
++## ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF ##
++## THIS SOFTWARE. ##
++## ##
++###########################################################################
++## ##
++## Author: William Hubbs <williamh@gentoo.org> ##
++## -------------------------------------------------------------------- ##
++## Settings for Gentoo Linux distributions. ##
++## ##
++###########################################################################
++
++include $(EST)/config/systems/Linux.mak
++include $(EST)/config/systems/GentooLinux.mak
+diff -uNr festival.orig/config/system.sh festival/config/system.sh
+--- festival.orig/config/system.sh 2011-02-09 10:41:01.000000000 -0500
++++ festival/config/system.sh 2011-02-09 10:42:10.000000000 -0500
+@@ -70,6 +70,10 @@
+ then
+ OSTYPE=DebianGNULinux
+ OSREV=`cat /etc/debian_version`
++ elif [ -f "/etc/gentoo-release" ]
++ then
++ OSTYPE=GentooLinux
++ OSREV=""
+ else
+ # Generic unknown GNU/Linux system.
+ OSTYPE=Linux
diff --git a/app-accessibility/festival/files/festival-2.1-init-scm.patch b/app-accessibility/festival/files/festival-2.1-init-scm.patch
new file mode 100644
index 000000000000..efe575b0c2b7
--- /dev/null
+++ b/app-accessibility/festival/files/festival-2.1-init-scm.patch
@@ -0,0 +1,24 @@
+--- festival/lib/init.scm 2006-09-15 01:34:32.000000000 -0500
++++ festival/lib/init.scm 2006-09-15 01:50:30.000000000 -0500
+@@ -52,8 +52,8 @@
+
+ ;;; A chance to set various variables to a local setting e.g.
+ ;;; lexdir, voices_dir audio etc etc.
+-(if (probe_file (path-append libdir "sitevars.scm"))
+- (load (path-append libdir "sitevars.scm")))
++(if (probe_file "/etc/festival/sitevars.scm")
++ (load "/etc/festival/sitevars.scm"))
+
+ ;;; CSTR siod extensions
+ (require 'cstr)
+@@ -133,8 +133,8 @@
+ ;;;
+ ;;; Local site initialization, if the file exists load it
+ ;;;
+-(if (probe_file (path-append libdir "siteinit.scm"))
+- (load (path-append libdir "siteinit.scm")))
++(if (probe_file "/etc/festival/siteinit.scm")
++ (load "/etc/festival/siteinit.scm"))
+
+ ;;; User initialization, if a user has a personal customization
+ ;;; file loaded it
diff --git a/app-accessibility/festival/files/festival-2.1-ldflags.patch b/app-accessibility/festival/files/festival-2.1-ldflags.patch
new file mode 100644
index 000000000000..e6559c8a8168
--- /dev/null
+++ b/app-accessibility/festival/files/festival-2.1-ldflags.patch
@@ -0,0 +1,12 @@
+diff -uNr festival.orig/config/systems/Linux.mak festival/config/systems/Linux.mak
+--- festival.orig/config/systems/Linux.mak 2011-02-09 10:08:20.000000000 -0500
++++ festival/config/systems/Linux.mak 2011-02-09 10:09:04.000000000 -0500
+@@ -46,7 +46,7 @@
+ JAVAH=/usr/bin/javah
+
+ TCL_LIBRARY = -ltcl
+-OS_LIBS = -ldl
++OS_LIBS = $(OPTIMISE_LDFLAGS) -ldl
+
+ ## the native audio module for this type of system
+ NATIVE_AUDIO_MODULE = LINUX16