summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-20 21:12:25 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-20 21:12:25 +0000
commit1aaea4a94bd00ccae6a4f2ac8c9c4896cadf611c (patch)
tree6779ab0fdde8b6b291a08d704fb69823ce57c72f /app-accessibility
parentFix shebang of gtk-builder-convert script. (diff)
downloadgentoo-2-1aaea4a94bd00ccae6a4f2ac8c9c4896cadf611c.tar.gz
gentoo-2-1aaea4a94bd00ccae6a4f2ac8c9c4896cadf611c.tar.bz2
gentoo-2-1aaea4a94bd00ccae6a4f2ac8c9c4896cadf611c.zip
Version bump. Translation updates.
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/accerciser/ChangeLog8
-rw-r--r--app-accessibility/accerciser/accerciser-1.12.1.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/app-accessibility/accerciser/ChangeLog b/app-accessibility/accerciser/ChangeLog
index ba019859bf02..079de4c55c4b 100644
--- a/app-accessibility/accerciser/ChangeLog
+++ b/app-accessibility/accerciser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/accerciser
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/ChangeLog,v 1.15 2010/10/12 18:08:01 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/ChangeLog,v 1.16 2010/10/20 21:12:25 eva Exp $
+
+*accerciser-1.12.1 (20 Oct 2010)
+
+ 20 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +accerciser-1.12.1.ebuild:
+ Version bump. Translation updates.
*accerciser-1.12.0 (12 Oct 2010)
diff --git a/app-accessibility/accerciser/accerciser-1.12.1.ebuild b/app-accessibility/accerciser/accerciser-1.12.1.ebuild
new file mode 100644
index 000000000000..ae56b55ad1b0
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-1.12.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/accerciser-1.12.1.ebuild,v 1.1 2010/10/20 21:12:25 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.4"
+
+inherit gnome2 python
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="http://live.gnome.org/Accerciser"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/ipython
+ dev-python/pygtk
+ dev-python/pygobject
+ dev-python/pycairo
+ dev-python/libgnome-python
+ dev-python/libwnck-python
+ dev-python/gtksourceview-python
+ dev-python/gconf-python
+ dev-python/librsvg-python
+ >=gnome-extra/at-spi-1.7
+ >=dev-libs/glib-2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.12"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --without-pyreqs"
+ DOCS="AUTHORS COPYING ChangeLog NEWS README"
+ python_set_active_version 2
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+
+ python_convert_shebangs -r 2 .
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+ python_mod_optimize "${PN}"
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup "${PN}"
+}