summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-06-18 04:29:20 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-06-18 04:29:20 +0000
commit27a782c72915915186fdb061cd38a3c20c6abd93 (patch)
tree2b69eb870d56df794addec1a89cc691443507c34 /app-accessibility
parentVersion bump. (diff)
downloadgentoo-2-27a782c72915915186fdb061cd38a3c20c6abd93.tar.gz
gentoo-2-27a782c72915915186fdb061cd38a3c20c6abd93.tar.bz2
gentoo-2-27a782c72915915186fdb061cd38a3c20c6abd93.zip
Fix test suite build (note: test suite itself still doesn't quite run), bug #552346, thanks to Patrick Lauer. Reduce logspam at runtime.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x18E5B6F2D8D5EC8D)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-atk/ChangeLog11
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild62
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h36
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch26
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch55
5 files changed, 189 insertions, 1 deletions
diff --git a/app-accessibility/at-spi2-atk/ChangeLog b/app-accessibility/at-spi2-atk/ChangeLog
index 69eacd161bd6..ca1bc63f38d2 100644
--- a/app-accessibility/at-spi2-atk/ChangeLog
+++ b/app-accessibility/at-spi2-atk/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-accessibility/at-spi2-atk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-atk/ChangeLog,v 1.73 2015/06/09 09:52:47 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-atk/ChangeLog,v 1.74 2015/06/18 04:29:20 tetromino Exp $
+
+*at-spi2-atk-2.16.0-r1 (18 Jun 2015)
+
+ 18 Jun 2015; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +at-spi2-atk-2.16.0-r1.ebuild, +files/at-spi2-atk-2.16.0-atk_suite.h,
+ +files/at-spi2-atk-2.16.0-null-gobject.patch,
+ +files/at-spi2-atk-2.16.0-out-of-source.patch:
+ Fix test suite build (note: test suite itself still doesn't quite run), bug
+ #552346, thanks to Patrick Lauer. Reduce logspam at runtime.
*at-spi2-atk-2.16.0 (09 Jun 2015)
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild
new file mode 100644
index 000000000000..b87fc74b2d31
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild,v 1.1 2015/06/18 04:29:20 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.15.5[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.15.4[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( >=dev-libs/libxml2-2.9.1 )
+"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751137
+ epatch "${FILESDIR}"/${PN}-2.16.0-out-of-source.patch
+ # Fixed in upstream git
+ epatch "${FILESDIR}"/${P}-null-gobject.patch
+ # Upstream forgot to put this in tarball :/
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751138
+ cp -n "${FILESDIR}"/${PN}-2.16.0-atk_suite.h tests/atk_suite.h || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure --enable-p2p $(use_with test tests)
+}
+
+multilib_src_test() {
+ # droute test requires session bus; ignore it
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h
new file mode 100644
index 000000000000..17aefcdd03d7
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h
@@ -0,0 +1,36 @@
+/*
+ * AT-SPI - Assistive Technology Service Provider Interface
+ * (Gnome Accessibility Project; https://wiki.gnome.org/Accessibility)
+ *
+ * Copyright (c) 2014 Samsung Electronics Co., Ltd.
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Library General Public
+ * License as published by the Free Software Foundation; either
+ * version 2 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Library General Public License for more details.
+ *
+ * You should have received a copy of the GNU Library General Public
+ * License along with this library; if not, write to the
+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ * Boston, MA 02111-1307, USA.
+ */
+
+#ifndef _ATK_SUITE_H
+#define _ATK_SUITE_H
+
+#include <atspi/atspi.h>
+
+#define ATK_TEST_PATH_ACCESSIBLE (const char *)"/Accessible"
+#define ATK_TEST_PATH_ACTION (const char *)"/Action"
+#define ATK_TEST_PATH_COMP (const char *)"/Component"
+
+void atk_test_accessible (void);
+void atk_test_action (void);
+void atk_test_component (void);
+
+#endif /* _ATK_SUITE_H */
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch
new file mode 100644
index 000000000000..a8f02a0eae1f
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch
@@ -0,0 +1,26 @@
+From 72220192a31df6b297312d82f059e9824e8a4dc3 Mon Sep 17 00:00:00 2001
+From: Christian Hergert <christian@hergert.me>
+Date: Fri, 15 May 2015 13:07:18 -0700
+Subject: [PATCH] atk-adapter: be careful with potential NULL GObjects
+
+I've been seeing warnings in my Gtk application for a while due to this.
+---
+ atk-adaptor/accessible-stateset.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/atk-adaptor/accessible-stateset.c b/atk-adaptor/accessible-stateset.c
+index f82910b..82820de 100644
+--- a/atk-adaptor/accessible-stateset.c
++++ b/atk-adaptor/accessible-stateset.c
+@@ -185,7 +185,7 @@ spi_atk_state_to_dbus_array (AtkObject * object, dbus_uint32_t * array)
+ {
+ AtkStateSet *set = atk_object_ref_state_set (object);
+ spi_atk_state_set_to_dbus_array (set, array);
+- g_object_unref (set);
++ g_clear_object (&set);
+ }
+
+ void
+--
+2.4.3
+
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch
new file mode 100644
index 000000000000..df9f006350d4
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch
@@ -0,0 +1,55 @@
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 6d388c9..b05b9bd 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -9,15 +9,15 @@ atk_test_CFLAGS = $(DBUS_CFLAGS) \
+ $(ATSPI_CFLAGS) \
+ -I$(top_builddir)\
+ -I$(top_srcdir)/tests/dummyatk/ \
+- -I$(top_srcdir)/tests/dummyatk/.libs \
+- -I$(top_srcdir)/tests/dummyatk/.deps \
++ -I$(top_builddir)/tests/dummyatk/.libs \
++ -I$(top_builddir)/tests/dummyatk/.deps \
+ -I$(top_srcdir)
+
+-atk_test_LDFLAGS = libxmlloader.la \
+- libtestutils.la \
+- $(GLIB_LIBS) \
+- $(ATSPI_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la
++atk_test_LDADD = libxmlloader.la \
++ libtestutils.la \
++ $(GLIB_LIBS) \
++ $(ATSPI_LIBS) \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la
+
+ atk_test_CPPFLAGS = -DTESTS_BUILD_DIR=\"$(top_builddir)/tests\" \
+ -DTESTS_SRC_DIR=\"$(top_srcdir)/tests\" \
+@@ -34,12 +34,12 @@ app_test_CFLAGS = -I$(top_builddir) \
+ -I$(top_srcdir)/tests/dummyatk \
+ -I$(top_srcdir)/atk-adaptor
+
+-app_test_LDFLAGS = libxmlloader.la \
+- libtestutils.la \
+- $(GLIB_LIBS) \
+- $(ATK_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la \
+- $(top_srcdir)/atk-adaptor/libatk-bridge-2.0.la
++app_test_LDADD = libxmlloader.la \
++ libtestutils.la \
++ $(GLIB_LIBS) \
++ $(ATK_LIBS) \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la \
++ $(top_builddir)/atk-adaptor/libatk-bridge-2.0.la
+
+ app_test_SOURCES = test-application.c
+
+@@ -52,7 +52,7 @@ libxmlloader_la_CFLAGS = $(GLIB_CFLAGS) \
+ libxmlloader_la_LIBADD = $(GLIB_LIBS) \
+ $(XML_LIBS) \
+ $(GOBJ_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la \
+ $(ATK_LIBS)
+
+ libxmlloader_la_SOURCES = atk-object-xml-loader.c\