summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-16 23:25:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-16 23:25:49 +0000
commit497dd6bcd122358851405d531e57d6154268745a (patch)
treeca57d083da13a3cd25f40e5c4b7a1f88abc81463 /app-accessibility
parentMask Python 2.7.1-r2. (diff)
downloadgentoo-2-497dd6bcd122358851405d531e57d6154268745a.tar.gz
gentoo-2-497dd6bcd122358851405d531e57d6154268745a.tar.bz2
gentoo-2-497dd6bcd122358851405d531e57d6154268745a.zip
Fix error message setting.
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/espeakup/ChangeLog6
-rw-r--r--app-accessibility/espeakup/espeakup-0.71.ebuild10
-rw-r--r--app-accessibility/espeakup/espeakup-9999.ebuild10
3 files changed, 15 insertions, 11 deletions
diff --git a/app-accessibility/espeakup/ChangeLog b/app-accessibility/espeakup/ChangeLog
index 488b513b5730..c780175b2976 100644
--- a/app-accessibility/espeakup/ChangeLog
+++ b/app-accessibility/espeakup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/espeakup
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/ChangeLog,v 1.20 2011/04/27 18:30:32 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/ChangeLog,v 1.21 2011/05/16 23:25:49 flameeyes Exp $
+
+ 16 May 2011; Diego E. Pettenò <flameeyes@gentoo.org> espeakup-0.71.ebuild,
+ espeakup-9999.ebuild:
+ Fix error message setting.
27 Apr 2011; William Hubbs <williamh@gentoo.org> espeakup-0.71.ebuild,
espeakup-9999.ebuild:
diff --git a/app-accessibility/espeakup/espeakup-0.71.ebuild b/app-accessibility/espeakup/espeakup-0.71.ebuild
index 147e67976aad..113599b54183 100644
--- a/app-accessibility/espeakup/espeakup-0.71.ebuild
+++ b/app-accessibility/espeakup/espeakup-0.71.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/espeakup-0.71.ebuild,v 1.8 2011/04/27 18:30:32 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/espeakup-0.71.ebuild,v 1.9 2011/05/16 23:25:49 flameeyes Exp $
inherit linux-info
@@ -16,12 +16,12 @@ IUSE=""
DEPEND="app-accessibility/espeak"
RDEPEND="${DEPEND}"
+CONFIG_CHECK="~SPEAKUP ~SPEAKUP_SYNTH_SOFT"
+ERROR_SPEAKUP="CONFIG_SPEAKUP is not enabled in this kernel!"
+ERROR_SPEAKUP_SYNTH_SOFT="CONFIG_SPEAKUP_SYNTH_SOFT is not enabled in this kernel!"
+
pkg_setup() {
if kernel_is -ge 2 6 37; then
- CONFIG_CHECK="~SPEAKUP ~SPEAKUP_SYNTH_SOFT"
- ERROR_SPEAKUP="CONFIG_SPEAKUP is not enabled in this kernel!"
- ERROR_SPEAKUP_SYNTH_SOFT=\
- "CONFIG_SPEAKUP_SYNTH_SOFT is not enabled in this kernel!"
check_extra_config
elif ! has_version app-accessibility/speakup; then
ewarn "Cannot find speakup on your system."
diff --git a/app-accessibility/espeakup/espeakup-9999.ebuild b/app-accessibility/espeakup/espeakup-9999.ebuild
index d346a5a97119..32e42f98a07e 100644
--- a/app-accessibility/espeakup/espeakup-9999.ebuild
+++ b/app-accessibility/espeakup/espeakup-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/espeakup-9999.ebuild,v 1.7 2011/04/27 18:30:32 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/espeakup-9999.ebuild,v 1.8 2011/05/16 23:25:49 flameeyes Exp $
EGIT_REPO_URI="git://github.com/williamh/espeakup.git"
inherit git linux-info
@@ -17,12 +17,12 @@ IUSE=""
DEPEND="app-accessibility/espeak"
RDEPEND="${DEPEND}"
+CONFIG_CHECK="~SPEAKUP ~SPEAKUP_SYNTH_SOFT"
+ERROR_SPEAKUP="CONFIG_SPEAKUP is not enabled in this kernel!"
+ERROR_SPEAKUP_SYNTH_SOFT="CONFIG_SPEAKUP_SYNTH_SOFT is not enabled in this kernel!"
+
pkg_setup() {
if kernel_is -ge 2 6 37; then
- CONFIG_CHECK="~SPEAKUP ~SPEAKUP_SYNTH_SOFT"
- ERROR_SPEAKUP="CONFIG_SPEAKUP is not enabled in this kernel!"
- ERROR_SPEAKUP_SYNTH_SOFT=\
- "CONFIG_SPEAKUP_SYNTH_SOFT is not enabled in this kernel!"
check_extra_config
elif ! has_version app-accessibility/speakup; then
ewarn "Cannot find speakup on your system."