summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-02-15 01:16:05 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-02-15 01:16:05 +0000
commit60806e5f95190811071b72582b20aabd86d5d4f7 (patch)
tree9d9be6b1998d23059d2d6af7e58d86238581c3e7 /app-accessibility
parentFix quoting. (diff)
downloadgentoo-2-60806e5f95190811071b72582b20aabd86d5d4f7.tar.gz
gentoo-2-60806e5f95190811071b72582b20aabd86d5d4f7.tar.bz2
gentoo-2-60806e5f95190811071b72582b20aabd86d5d4f7.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog8
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index 24804a914bde..147d0442ff92 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/speech-dispatcher
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.27 2008/01/11 16:23:15 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.28 2008/02/15 01:16:05 williamh Exp $
+
+*speech-dispatcher-0.6.6 (15 Feb 2008)
+
+ 15 Feb 2008; William Hubbs <williamh@gentoo.org>
+ +speech-dispatcher-0.6.6.ebuild:
+ Version Bump.
11 Jan 2008; Jeroen Roovers <jer@gentoo.org>
speech-dispatcher-0.6.5.ebuild:
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6.ebuild
new file mode 100644
index 000000000000..710160c72c05
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6.ebuild,v 1.1 2008/02/15 01:16:05 williamh Exp $
+
+inherit eutils
+
+DESCRIPTION="speech-dispatcher speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="alsa flite nas pulseaudio python"
+
+DEPEND="dev-libs/dotconf
+ >=dev-libs/glib-2
+ dev-util/pkgconfig
+ alsa? ( media-libs/alsa-lib )
+ flite? ( app-accessibility/flite )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-sound/pulseaudio )
+ python? ( dev-lang/python )
+ app-accessibility/espeak"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's/\(SUBDIRS.*\)python/\1/' "${S}"/src/Makefile.in
+}
+
+src_compile() {
+ econf \
+ $(use_with alsa) \
+ $(use_with flite) \
+ $(use_with pulseaudio pulse) \
+ $(use_with nas) || die "configure failed"
+ make all || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use python; then
+ cd "${S}"/src/python
+ ./setup.py install --root="${D}" --no-compile
+ cd "${S}"
+ fi
+
+ insinto /usr/include
+ doins "${S}"/src/c/api/libspeechd.h
+
+ dodoc AUTHORS ChangeLog NEWS TODO
+ newinitd "${FILESDIR}"/speech-dispatcher speech-dispatcher
+}
+
+pkg_postinst() {
+ elog "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
+}