summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-07-06 10:39:12 +0000
committerRoy Marples <uberlord@gentoo.org>2007-07-06 10:39:12 +0000
commit6ab97e2dffeed837e28272f3589143a6dd800c4c (patch)
tree0365fef79e7293e2552540304ea1c4c4c32918b1 /app-accessibility
parentRevision bump, latest (today - 06.07.07) git snapshot. (diff)
downloadgentoo-2-6ab97e2dffeed837e28272f3589143a6dd800c4c.tar.gz
gentoo-2-6ab97e2dffeed837e28272f3589143a6dd800c4c.tar.bz2
gentoo-2-6ab97e2dffeed837e28272f3589143a6dd800c4c.zip
Add patch to build on fbsd, #183686 thanks to Nathan Smith. Keyworded ~x86-fbsd.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/festival/ChangeLog7
-rw-r--r--app-accessibility/festival/festival-1.95_beta-r4.ebuild7
-rw-r--r--app-accessibility/festival/files/festival-1.95_beta-fbsd.patch21
3 files changed, 32 insertions, 3 deletions
diff --git a/app-accessibility/festival/ChangeLog b/app-accessibility/festival/ChangeLog
index 7a582a98c598..ecfba5574002 100644
--- a/app-accessibility/festival/ChangeLog
+++ b/app-accessibility/festival/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/festival
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/ChangeLog,v 1.66 2007/06/11 14:10:55 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/ChangeLog,v 1.67 2007/07/06 10:39:12 uberlord Exp $
+
+ 06 Jul 2007; Roy Marples <uberlord@gentoo.org>
+ +files/festival-1.95_beta-fbsd.patch, festival-1.95_beta-r4.ebuild:
+ Add patch to build on fbsd, #183686 thanks to Nathan Smith.
+ Keyworded ~x86-fbsd.
11 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org>
festival-1.95_beta-r4.ebuild:
diff --git a/app-accessibility/festival/festival-1.95_beta-r4.ebuild b/app-accessibility/festival/festival-1.95_beta-r4.ebuild
index e6f73344f134..69a7676cf733 100644
--- a/app-accessibility/festival/festival-1.95_beta-r4.ebuild
+++ b/app-accessibility/festival/festival-1.95_beta-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/festival-1.95_beta-r4.ebuild,v 1.8 2007/06/11 14:10:55 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/festival-1.95_beta-r4.ebuild,v 1.9 2007/07/06 10:39:12 uberlord Exp $
inherit eutils toolchain-funcs
@@ -29,7 +29,7 @@ SRC_URI="${SITE}/${MY_P}.tar.gz
${SITE}/festvox_us3.tar.gz )"
LICENSE="FESTIVAL BSD as-is"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ~ia64 ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="asterisk esd linguas_es mbrola X"
RDEPEND="sys-libs/ncurses
@@ -66,6 +66,9 @@ src_unpack() {
epatch ${FILESDIR}/${P}-init-scm.patch
+ # Allow building on fbsd, #183686
+ epatch ${FILESDIR}/${P}-fbsd.patch
+
# gcc 4.1 compatibility patches
epatch ${FILESDIR}/${P}-gcc41.patch
epatch ${FILESDIR}/${P}-gcc41-amd64-int-pointer.patch
diff --git a/app-accessibility/festival/files/festival-1.95_beta-fbsd.patch b/app-accessibility/festival/files/festival-1.95_beta-fbsd.patch
new file mode 100644
index 000000000000..1d7622007076
--- /dev/null
+++ b/app-accessibility/festival/files/festival-1.95_beta-fbsd.patch
@@ -0,0 +1,21 @@
+--- speech_tools/audio/voxware.cc.orig 2007-06-29 14:37:11 -0700
++++ speech_tools/audio/voxware.cc 2007-06-29 14:37:37 -0700
+@@ -61,7 +61,7 @@
+ #include "EST_error.h"
+
+ #ifdef SUPPORT_FREEBSD16
+-#include <machine/soundcard.h>
++#include <sys/soundcard.h>
+ #include <fcntl.h>
+ int freebsd16_supported = TRUE;
+ int linux16_supported = FALSE;
+--- speech_tools/audio/voxware.cc.orig 2007-06-29 14:53:01 -0700
++++ speech_tools/audio/voxware.cc 2007-06-29 14:53:20 -0700
+@@ -66,6 +66,7 @@
+ int freebsd16_supported = TRUE;
+ int linux16_supported = FALSE;
+ static char *aud_sys_name = "FreeBSD";
++static int stereo_only = 0;
+ #endif
+
+ #ifdef SUPPORT_LINUX16