summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-10-14 23:17:18 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-10-14 23:17:18 +0000
commit838cab98c0d21d1ea0c9b6c2358e488eb11dcab8 (patch)
treed9f387f1af73134400f5c18981b134de56dd8a5e /app-accessibility
parentbump to 2.20.0 and fix some QA warnings (diff)
downloadgentoo-2-838cab98c0d21d1ea0c9b6c2358e488eb11dcab8.tar.gz
gentoo-2-838cab98c0d21d1ea0c9b6c2358e488eb11dcab8.tar.bz2
gentoo-2-838cab98c0d21d1ea0c9b6c2358e488eb11dcab8.zip
bump to 4.6.0
(Portage version: 2.1.3.12)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/dasher/ChangeLog8
-rw-r--r--app-accessibility/dasher/dasher-4.6.0.ebuild78
-rw-r--r--app-accessibility/dasher/files/dasher-4.5.2-as-needed.patch27
-rw-r--r--app-accessibility/dasher/files/digest-dasher-4.6.03
4 files changed, 115 insertions, 1 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index 3f5af7b7f70d..b60b3ce53370 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.109 2007/10/08 02:52:20 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.110 2007/10/14 23:17:17 eva Exp $
+
+*dasher-4.6.0 (14 Oct 2007)
+
+ 14 Oct 2007; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/dasher-4.5.2-as-needed.patch, +dasher-4.6.0.ebuild:
+ bump to 4.6.0
08 Oct 2007; Leonardo Boshell <leonardop@gentoo.org>
+files/dasher-4.4.2-gnome.patch, dasher-4.4.2.ebuild:
diff --git a/app-accessibility/dasher/dasher-4.6.0.ebuild b/app-accessibility/dasher/dasher-4.6.0.ebuild
new file mode 100644
index 000000000000..c881e760883f
--- /dev/null
+++ b/app-accessibility/dasher/dasher-4.6.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.6.0.ebuild,v 1.1 2007/10/14 23:17:17 eva Exp $
+
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="1.8"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
+HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="accessibility cairo gnome"
+
+# The package claims to support 'qte', but it hasn't been tested.
+# Any patches from someone who can test it are welcome.
+# <leonardop@gentoo.org>
+RDEPEND=">=dev-libs/glib-2.6
+ dev-libs/expat
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2 )
+ accessibility? (
+ app-accessibility/gnome-speech
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-extra/at-spi-1
+ dev-libs/atk )
+ cairo? ( >=x11-libs/gtk+-2.8 )
+
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/libXt"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ gnome? (
+ >=app-text/gnome-doc-utils-0.3.2
+ app-text/scrollkeeper )
+
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ $(use_enable accessibility a11y) \
+ $(use_enable accessibility speech) \
+ $(use_with cairo) \
+ $(use_with gnome)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ sed -i -e 's:gtk-update-icon-cache:true:' ./Data/Makefile.am
+
+ epatch "${FILESDIR}/${PN}-4.5.2-as-needed.patch"
+
+ # Patches to fix compilation when USE=-gnome is used
+ # (bug #165154 and bug #189307)
+ epatch "${FILESDIR}/${PN}-4.4.0-gnome_help.patch"
+ epatch "${FILESDIR}/${PN}-4.4.2-gnome.patch"
+
+ cp aclocal.m4 old-macros.m4
+ AT_M4DIR="." eautoreconf
+}
diff --git a/app-accessibility/dasher/files/dasher-4.5.2-as-needed.patch b/app-accessibility/dasher/files/dasher-4.5.2-as-needed.patch
new file mode 100644
index 000000000000..3c3c76bdeb76
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.5.2-as-needed.patch
@@ -0,0 +1,27 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN dasher-4.5.2.orig/Src/Makefile.am dasher-4.5.2/Src/Makefile.am
+--- dasher-4.5.2.orig/Src/Makefile.am 2007-07-09 13:06:53.000000000 -0400
++++ dasher-4.5.2/Src/Makefile.am 2007-07-11 15:40:18.000000000 -0400
+@@ -24,10 +24,6 @@ AM_CXXFLAGS = \
+ -DPACKAGE_LOCALE_DIR=\"$(datadir)/locale\"
+
+ dasher_LDADD = \
+- $(GTK2BUILD_LIBS) \
+- -lexpat \
+- $(POPT_LIBS) \
+- $(GPELIB) \
+ Common/libdashermisc.a \
+ Gtk2/libdashergtk.a \
+ Gtk2/libdashercontrol.a \
+@@ -35,7 +31,11 @@ dasher_LDADD = \
+ DasherCore/libdasherprefs.a \
+ DasherCore/LanguageModelling/libdasherlm.a \
+ DasherCore/Alphabet/libdasheralphabet.a \
+- Common/libdashermisc.a
++ Common/libdashermisc.a \
++ $(GTK2BUILD_LIBS) \
++ -lexpat \
++ $(POPT_LIBS) \
++ $(GPELIB)
+ #endif
+
+ #if DOQTE
diff --git a/app-accessibility/dasher/files/digest-dasher-4.6.0 b/app-accessibility/dasher/files/digest-dasher-4.6.0
new file mode 100644
index 000000000000..d28cbcd232d1
--- /dev/null
+++ b/app-accessibility/dasher/files/digest-dasher-4.6.0
@@ -0,0 +1,3 @@
+MD5 ab9fce024bb2b1ea3cb479e82819d57d dasher-4.6.0.tar.bz2 6476900
+RMD160 d7874fa299ced668ecd121c76d94f801a4a05e4a dasher-4.6.0.tar.bz2 6476900
+SHA256 5c1b5ba9011ce2e31118cd25138dc4c4e8269a51d61c38788f797555cc6b5089 dasher-4.6.0.tar.bz2 6476900